Expected behaviour or faulty device?


  • My setup is two HD routers and a Mesh Point. The router I shall call Trouble is the slave router, connected via ethernet backhaul to the main router. The main router and mesh point have never given me a moment's problem. When first setting up Mr Trouble, I had to factory reset it more than 6 times before I could get it to connect to the network. It seemed to be pot luck. The time it managed it, it did so very quickly. Once connected everything is great and the signal is stable and fast. But if I have to power it down for any reason the charade begins again. This time, it was the firmware update this morning. Using my mobile app I said yeah fine update. The two polite devices did so quite quickly and came back online. Mr Trouble is sitting there saying "No internet". Powered on and off... Connecting... No Internet. Now I have no idea whether it updated its firmware - I suspect not seeing as it would have been interrupted by its master going down to update itself. What should I have expected in this situation, what do I do now, and what can I do in future to save throwing any more long hours of my life administering to this capricious creature?

    (NB I've done all the obvious troubleshooting tests - new ethernet cable, different ethernet point, different power socket, blah-di-blah...)


  • @inge-jones said in Expected behaviour or faulty device?:

    NB I've done all the obvious troubleshooting tests - new ethernet cable, different ethernet point,

    When you tested new cables and new ports, was this on a switch in your network or was this one of the 4 LAN ports on AmpliFi? My first hunch would be a possible loop, bad connections somewhere in the topology (This is where the switch question comes from) or a possible failure on the WAN port on Mr. Trouble.


  • It's not via a switch. It's "directly" connected via patch cable to two ethernet sockets, (and tried with different ones) which work flawlessly with other devices and also work flawlessly once the thing is up and running. I only have trouble if I have to restart the connection for any reason - either because I have powered it down or, in this case, the main unit took itself down for an update. What I am interested to know is, what happens when the user chooses to perform an update in this way? The slave unit can only get its update via connection to the main unit, which immediately becomes busy applying the update to itself. How is this implemented (when everything is working well)? I did try one time on a direct connection from an outgoing port of the master, admittedly it was some time ago now, but I don't remember getting any different results or I am sure it would have resulted in me rethinking the location of Trouble. Basically it was try, try, try again until by some fluke it accepted. At that time I just thought I'd held some button down too long, or done something in the wrong order.


  • @inge-jones The normal operation is when you select update, all the firmware files are downloaded to each device, then the install and subsequent reboot happens. Because of this, your ethernet backhaul device should not experience any delay in updating because the primary router rebooted. Have you considered filing an RMA claim for your ethernet backhaul router in case we are dealing with a hardware related issue?


  • @ui-brett Not until I feel fairly confident the problem is with the hardware. Now that I know this isn't expected behaviour, I will try one more time with a direct cable, and decide where to go from there. Now, unless something went wrong during the update, I take it I shouldn't expect it to need a reset (given that it had been all set up and working with the master only this morning?) So I'll bring it downstairs, give it one chance directly connected without a reset, one with a reset (if that didn't work) then I think I'll have to consider returning it.

    I really don't see how it can be a hardware problem with the ports though, otherwise surely I'd expect to occasionally see it in that state when I hadn't just had to disconnect it, via random connection drops. The only problem I get is at reconnection time, when it's been disconnected for a reason, and on this occasion I hadn't even jiggled it so nothing had disturbed the cable.


  • @inge-jones I encountered a fairly similar difficulty after having to do a factory reset and the slave router would not connect to the main router no matter what I did or tried. I could not do it using the app no mater how many different things and multiple resets I have tried. I finally discovered by coincidence that the extra router can be added to the network by a single tap on the main router LCD's screen (after using a pin to hard reset my Mr Trouble) and that worked straight away! I am not sure if this is something you have tried or aware of to possibly give it a try.


  • Thanks Ali, I will bear that one in mind. In my case I think I simply have a capricious device. This morning I was just about to bring it downstairs to trial connecting directly to the master, and decided to give it one last go in its usual place. Turned on power switch at the wall and bingo - connected within a few seconds. I hadn't plugged in or unplugged any cables, I hadn't touched the body of Mr Trouble, I'd touched nothing at any time except the wall power switch. Basically this thing is deciding for itself when it's in the mood to make its connection. Is it possible for there to be a firmware/software glitch that only affects the part of the process when the connection is first made, and not the continuing connection?


  • @inge-jones said in Expected behaviour or faulty device?:

    Is it possible for there to be a firmware/software glitch that only affects the part of the process when the connection is first made,

    possible, but also just as possible that some hardware aspect of your device could be giving us fits as well. In my office test network, I have every connection type and device configured so I can monitor most scenarios and I have yet to see this form this update or any of the prior, but there are so many possible scenarios so its hard to say.

    @Ali-Hadi brings up a good point and from the sounds of it you have configured it properly, but it's best to just ask to be certain. Is your Mr. Trouble configured as an independent network, or meshed together with Ethernet Backhaul enabled? Or responding in the app as a wireless mesh point?


  • @ui-brett As I think I mentioned in the first post, it's meshed to another identical Amplifi router via ethernet backhaul. The main/master router is in bridge mode to my ISP's modem router (which I didn't say). There is also a mesh point, connected obviously via wifi to the master Amplifi. I find it hard to imagine where the actual setup could be wrong or I am sure I would be experiencing problems on an ongoing basis, not just at times where I have directly caused the disconnect by updating or powering down. I'd expect it to be dropping connection occasionally on its own.


  • Ah I didn't respond to your specific question about how the app sees the connection. Yes the app confirms it's using the ethernet backbone.


  • Turned on power switch at the wall and bingo - connected within a few seconds.

    Hi @inge-jones - do you frequently power off this HD router via a wall switch?

    I believe you previously mentioned potential power issues at residence

    HD Router's can be power sensitive - for example at a 100V outlet I once started getting daily morning reboots during a particularly hot summer when everyone's A/C was running in a building overnight and the power company transitioned from "lower cost" delivery to "normal delivery" at 6am
    I was trying to sort it out with the ISP when it turns out there was enough voltage droop at 6am the HD would power cycle

    If the power delivery on that particular HD is marginal, power cycling may make it worse as well

    If it was me, and not too inconvenient, I would RMA it


  • @derek-saville no I try to avoid powering it down at all costs because of the hassle I have getting it connected again. It's not disconnecting or rebooting itself like you'd expect with power problems,it's completely stable until it has a planned disconnect or power off. And what I said in a previous post about having solved it by plugging directly into wall rather than into a power block I now think was a red herring - it just happened to be the time it randomly decided it would obey. Because each subsequent time I have had the same dance. And the only way to solve it is to patiently power it on and off until it finally decides on one cycle that this will be the one it connects on. I'd RMA it but I need a replacement first, as if the node is missing for more than a few hours my smoke alarms will start to show disconnected and need resetting all over again. That's a pain too.


  • @inge-jones said in Expected behaviour or faulty device?:

    I'd RMA it but I need a replacement first

    I can help with that. Submit the RMA and DM me the RM # and I will make sure we accommodate this for you


  • @ui-brett Ok, done that, and started a "chat" with you with the ref number


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.