Teleport Router to Router stuck at "Connecting"......


  • Just got myself an AmpliFi Instant Router to see if I can use it to teleport connections to my main HD Router at home and manged to go through the process as per the instruction but when trying to teleport my laptop which is connected to the Instant, I am forever stuck at the client displaying "connection in progress" - "connecting" on the app and the teleporting does not work. My main HD Router is connected at home in bridge mode and my remote Instant router is connected to a remote router using DHCP mode. What am I missing here and why can the teleport connection not be completed?


  • Hi @ali-hadi - I can confirm that I have it working with an HD Router

    Home Network = HD Router in Bridge Mode
    Remote Network = HD Router Double NAT in DHCP mode behind another ISP router

    Generated a Teleport code on the Home Network HD Router
    Connected an iPad to the Remote Network HD Router
    Using the AmpliFi app on a different device to manage the Remote Network HD Router, I selected the iPad from the Family tab and selected Teleport to Remote Router, entered the code and it connected right up

    Not sure what ports are being used or what mechanism works in the background to make the routing happen
    Maybe something is blocked on your Home Network firewall?


  • @derek-saville Thank you for the detailed desription of your setup. Mine is exactly the same with the only difference being the use of the same amplifi app on the same android phone to control both routers by switching from one to the other. Although I could not imagine that this would make much of a difference, I have just tried the procedure using two different phones each managing one of the routers to no avail and with the same error. It is difficult for me to imagine my upstream router at home to be the culprit seeing that the actual Teleport hardware is able to connect with no issues. I am puzzled.....


  • @ali-hadi I can confirm that using the same app is not a requirement, one of the features is generating codes for your family or friends to use your network, which naturally would be from a second device. My recommendation would be to make sure the Instant updated to 3.1.2, then factory reset and configure again. Not saying you did this, but avoid the temptation to tap the LCD screen when it says "New mesh point detected" 🙂


  • @ui-brett thanks for the rapid reply. I had initially added the new Instant Router as a mesh point to my home network to test it before factory resetting it and setting it up as a new router system to try the teleport. Do you feel that it might have left something onto my main router that would require me to reset that one as well?


  • Hi @ali-hadi - did you "hide" the Instant, removing it as a mesh point from your home network after taking it offline and resetting it?


  • @derek-saville yes, I did hide it.


  • Hi @ali-hadi - can you confirm that using the Teleport App works to access your home HD router in bridge mode?

    If the Teleport App works, it's hard to imagine the Router-to-Router Teleporting not working

    Sorry to hear you are having such issues...


  • @derek-saville thanks mate. Just tried using the teleport app with my phone connected to the remote router and it can access my home network and the internet with no problem at all. Did a whole factory reset on everything and started the process again to ensure RAAT is in no way associated with my home router. Unfortunately still getting nowhere with trying to connect via teleport. The only thing left for me is possibly to try the remote unit with a different away router to see if that would make a difference.


  • Hi @ali-hadi - I have only tried my RAAT at two location, both residential with ISP routers, and I didn't run into any issues
    One had a PPPoE connection which I figured would be worst case

    If I get a chance I will try more locations, and maybe even a hotel LAN if the portal gods cooperate

    The Home HD Router is in Bridge mode behind an ISP router, with a fixed IP address assigned to the MAC, which thankfully hasn't changed over the last couple of firmware releases or reboots...(and which I will now probably regret typing out loud)


  • PS @ali-hadi - one last thought, maybe try disabling things like HW NAT on the home Bridge mode router and on the RAAT if they are enabled, although I believe the Instant Router does not support HW NAT


  • Hi @UI-Brett - will generating Support Info files include any information to help diagnose Router-to-Router Teleport connection issues?
    Or once you have the Router ID's, are you able to look for issues on the backend servers?
    Hope you can implement some error codes or add something to the Diagnose tab to help sort out these issue in the future


  • Hi @ali-hadi - I know you have probably already confirmed this, but just to be sure, do you have completely different subnets setup for your Home network, and the network being deployed by the Instant RAAT i.e. 10.0.0.x at Home & 192.168.0.x on the RAAT ?


  • @derek-saville Thanks. No HW NAT on any device and no differing subsets. I will try today and reset my home router in case some firewall rule is interfering as I have set up some parental control parameters on it in the past.


  • Hi @ali-hadi - I believe it is a requirement to have different subsets for Router-to-Router Teleporting, even when the Home HD Router is in Bridge mode

    At least that was my understanding and what I did to implement the RAAT

    My Home network is 192.168.0.x
    My Remote network is 10.0.0.x
    My RAAT network is set to 192.168.101.x

    Not sure what the requirements are, but I made sure all 3 were different


  • @derek-saville thank you but I am really not at all good with the how subsets work but understand that DHCP would assign these subsets automatically. Trying to change my RAAT network subset to make it different from the remote gateway obviously made me lose all connections and I am not sure as to how to set this up. BTW, resetting my home router's firewall to factory defaults has not worked either.


  • Hi @ali-hadi - maybe wait until @UI-Brett can comment on subnet ranges being different to avoid unnecessary frustration

    I just recalled @UI-Karlis specifying that the subnets had to be different for Router-to-Router Teleport to work, but I may be mistaken

    The first thing is to note the IP address of your Home AmpliFi router in Bridge mode

    Then for your RAAT Instant, go into the AmpliFi app managing it and bring up the main setting

    Scroll down and select DHCP Server

    At the top in blue characters will be some numbers indicating the starting range

    If those first 2 sets of numbers are the same as your Home AmpliFi router, touch them, and then you will be presented with 3 options

    Change the starting range to something different than your Home AmpliFi router and hit the check mark in the upper right

    This will reset the server and drop connections to assign new IP addresses to clients

    I believe that should be enough, but I took the extra step of also ensuring the Remote location main router, which the RAAT is attaching to, was also serving a different subnet range just to be sure

    If your Remote location main router is also an AmpliFi it would be changed the same way

    If it is another router model then you would have to dig into it to change the subnet range if necessary


  • @derek-saville many thanks indeed for the detailed instruction and explanation. I have changed all IP subsets so that they are different from each other as recommended but still no joy unfortunately. I have a feeling that it must be a problem with the remote router as I am still facing the exact same problem after removing my home router altogether and replacing it by a bare modem with my home AmpliFi working in PPPoE mode now. Everything else is working as usual including HW and APP Teleport but Router-to-Router is still beyond reach I am afraid.


  • Sorry @ali-hadi - I hope @UI-Brett or someone can get it sorted out for you

    Like the original HW Teleport, it works pretty well...when it actually works


  • Have you tried rebooting the main router, as in manually unplugged it for 5 minutes then plug it back in?


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.