Latest Update is a Mess for MacBook Pro

  • Since the latest update, my MacBook Pro now completely drops signal. About once every half hour I have to turn wifi off and then back on again. This ALWAYS fixes the problem. Meanwhile, my wife on a regular (12") MacBook is browsing and everything is fine. So clearly it is not the ISP.

    We are both on the same version of the MacOS (High Sierra) and literally in the same room, connected to the same AP, roughly 8' apart from each other.

    Additionally, before the latest series of updates, my wifi performance with iperf3 has dropped; in the past is was ~400Mb/s, now it tends to gravitate to the 250-320Mb/s range.

    Any thoughts.

  • Disable band steering, router steering and make sure your Macbook Pro has a static IP. See if that helps.

  • Hi John

    I have been experiencing similar issues and I am currently in contact with support regarding this. They have been very helpful and is trying to track down what the cause is. I will update as soon as I have an answer.
    Here is a copy of my initial email to support:
    I have an Amplifi HD router with 2 HD mesh points. I have mainly Apple products in the house (iPhones, iPads, Macs etc.). The problem that I experience is that roaming is not smooth and devices randomly become unresponsive with internet connections. I use a Telus Mobility LTE/4G hub as a modem (ZTE MF275R). If I walk away from the main router (with an iPhone) towards a mesh point the handover is perfect without dropping the connection. If I walk from any mesh point towards the main router the signal drops and the iPhone connects to the cellular signal. It often stays connected to the cellular signal and then I have to physically reconnect it to the wifi. I am sometimes working on my MacBook when the browser suddenly stops responding. It might happen on one device, but other devices are not affected. I think it happens during roaming. The only way I could fix it was to reconnect to the wifi or if I wait for an extended period of time it might respond again.

    1. I have tried a factory reset on the Amplifi system.
    2. I have done a reset of the iPhone network settings.
    3. I have turned band steering/router steering on and off.
    4. I have given the devices static IP’s.
    5. I have tried a public DNS.
      None of the above made any difference.

    Interestingly I did also remove security settings and with an open network the roaming worked perfectly.
    I hope a firmware update will resolve the problem.


  • @peter-farrar

    Thanks, I will give that a try this evening. Additionally I will try to use my work MBP to see if that makes a difference. My mini is on a static IP and I have not noticed any issues, but truthfully I have only spent a few hours on the mini and it is hardwired.

  • @john-fruehe

    Just got an email back from support. They suggested that I move my mesh points further away from the main router and to look for a signal strength of about 50%. I had an idea that this might be part of my problem as my signal strength was 96% on one mesh point and 100% on the other. Anyway, I will try that and report back if it resolved the problem.

  • I have also noticed that my office mesh antenna had in the past been at ~70-80% with 5G. Then it fell to ~50-60% and defaulted to 2.4G. Now it is only ~32% and back to 5G.

    Additionally I am no longer able to access the system outside of my wifi. On my phone (LTE) it cannot find the system so I cannot manage it or view it remotely.

    Band steering was off but router steering was on. Turning off router steering bumped the office back up to 52%.

    Continuing to watch this, not happy with what I am seeing from the updates, the last few one have been real sketchy.

  • @john-fruehe

    Hi John
    With the help of support I can report that all my issues seem to be resolved. They have been very helpful in tracking down what was causing my issues.
    I have not noticed any disconnects and roaming is now super smooth after I moved the mesh points further away from the main router. I was quite frustrated before, but very happy now. I suggest you talk to support if you have ongoing issues. Hope you get it figured out!

  • @stefan-du-toit-0
    that's good to hear, but I am a little concerned about this 'fix'.
    Ubiquity has never made clear what the optimal signal strength for the mesh points to the router is. In fact, any novice looking at the visual representation would think that 100% on all mesh points is optimal.
    I don't think 50% is great as well though - I assume you have a measurable performance impact if you are connected to a mesh point (especially if it's via 3x3 on a MBP), which then only has 'mediocre' connectivity (in 5Ghz I assume) to the router?
    We really need a better way to determine what is too close, and what is too far (for the best performance)....

    John: Band steering means that you are steered to 5Ghz whenever possible. You want that. If it doesn't yield good results for you this likely means that in fact the distance between APs and / or you is too far or obstructed. You want to be on 5Ghz whenever possible. Router steering means that regardless where you are, the mesh points will try to point you at the router (and router will be more sticky). Not sure you want that either. It's not clear how Amplifi does that as I don't believe there is a full 802.11r implementation....

  • @daniel-osers

    With Apple devices it's best not use band steering, they can decide themselves which band to use and will switch accordingly.

  • As is sit in my family room with my MBP, I am ~8' from a router. The primary is downstairs, this one is in bridge mode. One antenna is in a screen porch ~60' away and the other is in the office, ~30' away. Pretty sure that I am never having my signal bounce to either of those antennas and it is never off of 5GHz mode.

    Here is an example of iperf in my family room:

    MBP-Home:~ xxxxxxx$ iperf3 -c -c
    Connecting to host, port 5201
    [ 4] local port 64118 connected to port 5201
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-1.00 sec 34.7 MBytes 291 Mbits/sec
    [ 4] 1.00-2.00 sec 30.3 MBytes 255 Mbits/sec
    [ 4] 2.00-3.00 sec 33.1 MBytes 276 Mbits/sec
    [ 4] 3.00-4.00 sec 26.0 MBytes 219 Mbits/sec
    [ 4] 4.00-5.00 sec 15.5 MBytes 130 Mbits/sec
    [ 4] 5.00-6.00 sec 4.69 MBytes 39.4 Mbits/sec
    [ 4] 6.00-7.00 sec 15.4 MBytes 129 Mbits/sec
    [ 4] 7.00-8.00 sec 20.7 MBytes 174 Mbits/sec
    [ 4] 8.00-9.00 sec 28.5 MBytes 239 Mbits/sec
    [ 4] 9.00-10.00 sec 32.6 MBytes 273 Mbits/sec

    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-10.00 sec 241 MBytes 203 Mbits/sec sender
    [ 4] 0.00-10.00 sec 240 MBytes 202 Mbits/sec receiver

    iperf Done.

    Notice that in the middle of the run suddenly it drops in half, then down into double digits then recovers. I see that a lot. Sometimes it will hit 0 for a couple tries and then recover.

    Server is on a static, about to shift my MBP over to a static to see if that fixes it. It it does, then this is a bug because Amplifi is doing the DHCP.

  • Went over to a static IP. Ran fine for a bit, then I got this:

    alt text

    Connected to my server, can ping fine. Iperf3 shows I am sending/receiving data, but my external access to the WAN is not working. Wife's running fine (different MB model).

    Reboot, still no external access.

    Go back to DHCP, magically it is working again.

    Now my performance is ~420Mb/s vs the ~220Mb/s before. But pretty sure it will degrade over time. I don't like that a reboot fixes things, they degrade, stop working and then a reboot brings it back. Too many variables here.

  • This morning, after having changed nothing, it now looks like this:

    MBP-Home:~ johnfruehe$ iperf3 -c -c
    Connecting to host, port 5201
    [ 4] local port 53811 connected to port 5201
    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-1.00 sec 5.34 MBytes 44.7 Mbits/sec
    [ 4] 1.00-2.00 sec 1.24 MBytes 10.4 Mbits/sec
    [ 4] 2.00-3.01 sec 3.70 MBytes 31.0 Mbits/sec
    [ 4] 3.01-4.01 sec 1.94 MBytes 16.3 Mbits/sec
    [ 4] 4.01-5.01 sec 3.69 MBytes 30.9 Mbits/sec
    [ 4] 5.01-6.01 sec 52.3 KBytes 429 Kbits/sec
    [ 4] 6.01-7.00 sec 5.81 MBytes 49.0 Mbits/sec
    [ 4] 7.00-8.00 sec 6.20 MBytes 52.1 Mbits/sec
    [ 4] 8.00-9.01 sec 9.11 MBytes 76.1 Mbits/sec
    [ 4] 9.01-10.00 sec 18.9 MBytes 160 Mbits/sec

    [ ID] Interval Transfer Bandwidth
    [ 4] 0.00-10.00 sec 56.0 MBytes 47.0 Mbits/sec sender
    [ 4] 0.00-10.00 sec 55.8 MBytes 46.8 Mbits/sec receiver

    iperf Done.

    This is after turning wifi on and off on the MBP. I have done several runs, they are at ~210Mb/s on the high side and ~120Mb/s on the low side. Normally I am connecting at ~80-80% signal and ~800Mb/s in terms of the connection but today's connection is ~75% and ~500Mb/s.

    It is the flakiness of the Amplifi system that is really bugging me. Things seem fine after a reboot and then give it some time and it starts to get flaky. Which typically feels like a memory leak in code for me.

  • @peter-farrar
    True, but of my ~35 devices, while all my computers, tablets and phones are Apple (about 12 total), the rest really benefit quite well from band steering 🙂

  • @peter-farrar That is odd as the iphone and ipad my wife use throw a wobbler if Router steering is turned on but work perfectly with just band steering enabled ?

Log in to reply