Just upgraded to gigabit, only seeing 200mbps download


  • I am using the performance test from the app. It is plugged into a netgear CM1200 3.1 modem with cat 6 going from modem to AMPLIFI router. I have the hardware NAT turned on. Should that performance on the app show close to 1gbps speeds?

    Edit: This is on Cox gigablast internet.


  • @brandon-lundgrin the app’s built-in speed test performance test is highly unreliable. You should use the Speedtest website or app you can download from the App Store or Google play. Even then you will typically only see gigabit speeds on a wired connection.


  • @brandon-lundgrin Try Ubiquiti's site at speed.ui.com.


  • @james-earl-ford I get half the speed from the link you provided vs. fast.com or Speedtest. I'm relatively sure it's what they use to measure the speed test with the app.

    @Brandon-Lundgrin There is a buffering option you could enable via the web interface that might help. What are you testing from. Ideally you'd likely want something connected to LAN for initial tests.


  • I did use the cox speed test when plugged directly into the cable modem and achieved the 1gbps speed. I tried testing wirelessly with the same cox speed test and only get about 175 mbps download speed. Thought I would get a bit faster than that on wireless. Also, when plugged in through Ethernet on the amplifi router port I’m only achieving 175 mbps download speeds. I feel like I’m getting a bottleneck somewhere on the router.


  • @chris-dunlop I will enabled the buffer and give it a try. Thanks!


  • Same problem on Comcast. Rarely see speeds over 280 Mbps on 5G even in the same room as router. On the 2G SSID the speeds have dropped as low as 11 Mbps I don't even have mesh points. Been trying to resolve with tech support for over a month. They are now telling me that Gigabyte speeds on AmplifiHD are only possible with a wired connection. Why would I use a WIRELESS router if I need to be directly connected by a cable? Plus I already have an additional port on the modem if I wanted to do that.
    Where is the option to turn on buffering on the web interface. Same page where you enable NAT? I don't see that anywhere?


Log in to reply