AmpliFi HD Mesh and Leviton HomeKit Switches


  • How can I get my new AmpliFi HD Mesh system to work reliably with my Leviton HomeKit Switches?

    I have had an Apple Time Capsule for 6 years and my HomeKit setup has worked well. The Time Capsule started having issues so after a lot of research I purchased an AmpliFi HD Mesh. I really like the AmpliFi HD Mesh, easy setup, good app, great signal strength, and I want to keep it, but I can't get it to work reliably with my Leviton switches. All my other HomeKit devices work except I get between 15-37 Leviton switches that show "No Response", and that number keeps changing. You could say this is a problem with Leviton Switches, but the Leviton switches were all working reliably with my Apple Time Capsule since I installed them 6 months ago.

    Are there any tools to help debug this? If I can't get this fixed I will reluctantly have to return the AmpliFi HD. I have spent the last miserable 3 weeks trying to get this to work.

    Below is information about my setup and what I have tried over the past 3 weeks.

    .

    Setup

    WiFi

    • New AmpliFi HD with 2 Mesh Points
      • Single SSID with both 2.4GHz and 5Ghz
      • Mesh Points get >95% signal
      • Both 2.4GHz and 5GHz signal seems strong throughout the house
    • Home is 4000 sq ft wood frame with a basement on a large lot
    • Only 2 other weak neighbor WiFi networks show up, so not much interference

    HomeKit WiFi Devices

    • 37 Leviton Dimmer Switch or Switch
    • 22 iDevices Switch
    • 2 Insignia Garage Door Opener
    • 1 August Lock
    • 1 Schlage Lock
    • 7 Apple Devices - 2 iPhone, 2 iPads, 2 Apple TV, 1 HomePod
    • 1 Starling Hub that uses Homebridge to connect 3 Nest Thermostats and 3 Nest Protects to HomeKit

    Other Wifi Devices

    • 1 Epson Printer
    • 2 GE WiFi
    • 3 Nest Thermostats
    • 3 Nest Protects

    .

    What I have tried, some of these multiple times

    AmpliFi HD

    • Rebooting the Amplifi HD
    • Factory resetting the AmpliFi HD and setting it up again
    • Moving the AmpliFi HD from the basement to the 1st floor

    HomeKit

    • Having only one HomeKit Hub, a HomePod
    • Moving the HomePod to another location
    • Rebooting the HomePod
    • Reinitializing the HomePod
    • Using my Apple TV 4K as the HomeKit Hub
    • Deleting the home and creating a new home in HomeKit

    Leviton

    • Putting the Leviton Switches on a separate 2.4GHz network. This should not be needed since the Leviton Switches work on both 2.4 GHz and 5GHz and the 5GHz signal is strong.
    • Deleting and adding Leviton Switches to HomeKit
    • Resetting and connecting the Leviton Switches to WiFi again. This will make them work for a while but usually then end up with sporadic "No Response"

    .

    Note: During 3 weeks of trying to get this working at one point after factory resetting the AmpliFi HD and then adding any Leviton switches back to WiFI that were "No Response", I woke up the next morning and everything was working. That lasted for about 36 hours until I had to move the HomePod to make room for decorations, and now I'm back to lots of "No Response". So that shows that under certain conditions things were working. I could not repeat this.


  • This post is deleted!

  • @jeff-zacharias Hi Jeff, sorry to hear your having disconnections. Have you sent a support file in? To get some further insight into what exactly is going on a support file would help us identify an issue faster. Levitron switches have a common issue with Mesh networks, it looks like the solution is creating a network with only one SSID. When you created an additional SSID did you configure it on the router or MeshPoint(s)?


  • @ui-jt Yes I did send in two support files on 11/24 but the support person who replied said they could not do anything with them.

    Thank you for your help! Telling me that “Levitron switches have a common issue with Mesh networks” does seem to be the problem. Although some people say Leviton switches work with Google WiFi and Eero nesh networks.

    To test this, I paused both mesh points and just used the main dual band SSID from the router. I still had about 12 Leviton devices that were not responding (maybe since they were looking for a mesh point?), so I spent an hour reconnecting them to the SSID, and then everything worked. For the rest of the evening and overnight every single device worked! Before I left for work I un-paused both mesh points and everything continued to work, but not sure how long that will last.

    Can you tell me how I should set this up now?  Since it will take 2-3 hours to change the Leviton switches I want to be sure. It seems like what I need is:

    1. A dual band SSID for most of my devices in a mesh network so that I have strong signal throughout my house.
    2. A dual band SSID just from the router to connect my Leviton switches to
      I don’t see a way to do this.  It seems like I have to setup an additional SSID on the router, for either 2.4 GHz or 5 GHz and put my Leviton switches on that, probably the 2.4 GHz would be better. I’d rather have them on a dual band. I also believe I tried this before and it didn’t work, but I did have the mesh points turned on.

    A couple of other questions:

    I have a 300 MB internet connection. I can get 200+ Mbps on a single 5GHz SSID, but only about 20 Mbps on a single 2.4 GHz SSID. This seems really slow. If I take my iPhone 11 Pro and sit 5 feet from the router I still get about 25 Mbps on the 2.4 GHZ SSID, and if I go to the farthest part of my house I get about 10-15 Mbps. Shouldn’t I get faster than 25 Mbps on the 2.4GHz SID if I’m right next to the router?

    Can you confirm I have this all is correct:

    1. There is one main dual band SSID on the router that can’t be changed.
    2. The mesh point band, which I have set to 5GHz, is just for a backhaul
    3. The mesh points will propagate the main router dual band SSID.
    4. If I setup an additional SSID on the router, that SSID is only available on the router, not the nesh points.
    5. If I setup an additional SSID on a mesh point, that SSID is only available on that mesh point.
    6. It is not possible to setup a dual band additional SSID on either the router or mesh point.

    I really appreciate your help!


  • @jeff-zacharias Hi Jeff,
    I am glad the advice worked. It looks like the Levitron devices do not play well with multiple SSID being broadcast. I am curious if we can create an additional 2.4Ghz SSID just for the Levitron devices on the router and connect them to that, this will eliminate the issues we are seeing with multiple SSIDs and MeshPoints. The throughput should not need to be to high for the Levitron devices because they are just dimmers and wont be pulling large amounts of data.

    1. Use the main Mesh SSID for your all devices excluding the Levitron devices.
    2. Enable additional SSID on the main router and set it to 2.4Ghz only, make sure the SSID differs from the main SSID. You will want to use 2.4 Ghz to get good coverage for the Levitron devices.

    For the speed issues: You should go in to the advanced wireless settings and change the channel width for 2.4Ghz to 20/40, this should give you more bandwidth. Here is an article for doing this https://help.amplifi.com/hc/en-us/articles/360039339174-Changing-Wireless-Broadcast-Channels-

    1. There is one main SSID that is broadcast on the router and Meshpoints.
    2. The MeshPoints use one dedicated backhaul link, you can set it as 2.4Ghz or 5Ghz.
    3. MeshPoints broadcast the one maine SSID from the router.
    4. Creating an additional SSID will broad cast on the device you configure it on. (Yes)
    5. Yes. See above.
    6. Correct, it will broad cast either example-2G, example-5G or both of these at the same time.

  • @ui-jt I want to thank you again for your help. You solved my problem and you answer every question I asked in a clear and concise manner.

    I set up the additional 2.4GHz SSID on the router, put all the Leviton switches on that SSID, and everything is working great. Not one "no response". This is the most stable HomeKit has ever been. And, I now have strong and fast WiFi throughout my whole house.

    If I had any requests, it would be to have the Leviton switches able to work with the mesh SSID, and to be a able to create an additional SSID that is dual band and that I can name without you adding a suffix like "-2G".

    Thanks again, I am now very happy with the AmpliFi HD!


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.