incorrect MTU in the LAN connected device


  • I've got trouble in the builds since 2.4.3, that if the linux box are connected to one of the lan ports, the ssh session keeps hanging, especially on big output or some kind of apps that produce big output, like ncurses based ones. So if I'm change the network interface MTU to 1492, it works perfectly. The are standards that are incompatible with Ethernet and IEEE 802.3/802.2. So please fix your little nice white box, so i can use it without problems again. 🙂

    Tried to reach them on the chat, but that stupid bot keeps saying me that your problem is solved, lol! xD


  • @justinas-marcinkevicius Do you have problems in your local network or when using ssh over WAN interface? If problems are with WAN, are you using PPPoE or non-default VLAN?


  • I've got similar problems with my box as well. While my cabled devices have yet to show any problems, all of my wireless devices face problems connecting with some sites/apps. I found out that, since my connection is delivered via PPPoE on a VLAN, the default MTU of 1500 gets shrunk down to 1480 (8 bytes VLAN header + 12 bytes PPPoE header), and the box still presents all interfaces (cabled + wireless) with a MTU of 1500.

    So, since those apps have a DF policy, I simply cannot connect to my bank accounts (and other apps which have the same policy as well, like the Android IMDB app) because they force me to use the interface MTU without fragmentation, and since there's no way (that I know of) to reduce the MTU on the wireless interface, I have to disconnect from my home network and use my 4G connection if I wish to use any of those apps.

    What I would like to know is: Is there a way to set the MTU only on the client-side interfaces, or will it be necessary to wait for a firmware upgrade? Also, if the upgrade is mandatory, how long would it take?


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.