Wifi 6 iPhone not loading webpages when connected to Alien


  • @gregg-levethan Lol, let's delay it until its perfect. Oh a new phone came out, better delay it again. Yup I am sure they want to spend that money waiting until its perfect on EVERYTHING!

    You do realize what you just said. If it not ready delay it, it cost money to delay it. If it works on 98% fine, release it. Then fix the issues as they pop up. WiFi 6 is new and not finished.

    Food for thought.....
    Most people buy it and take it home with Zero issues. They have no idea I am writing this and will never come here to this site.


  • Let's not sell too many for 6 months until the handful of people who want to be beta testers finish helping us out.

    Actually this is exactly what Ubiquiti does with their Early Access programs for the UniFi range
    The Dream Machine was in Early Access Beta for a long time...was it almost a year?

    Ubiquiti Labs (AmpliFi) has not adopted such a Beta program that we know of, but I am sure it would be popular with many of the folks on this forum if they did

    A good practice is avoiding the temptation to do updates (both on the router side and the client device side) until after they have been out in the wild for a while and seeing how they go, especially if you have a stable working device

    AmpliFi instituted a phased firmware release to help stop any issues that aren't caught in beta from affecting everyone simultaneously and they made it very easy to roll back the firmware as well

    In the case of Alien, being a relatively new platform without a lot of devices in the wild yet, an update to fix one bug just might break something else
    I believe the update that caused this thread was the one to fix the Ethernet backhaul issue that was found and quickly implemented without time for beta testing

    @UI-Karlis and @UI-Brett are very responsive on fixing issues once they are identified and one would expect a fix for this just as quickly


  • @derek-saville I am glad you get it.


  • Hi @timothy-farley - in the case of Alien, and just my personal opinion, I agree with @Gregg-Levethan

    Without WPA3 and WiFi-6 certification, the Alien launch seemed rushed in order to hit a Black Friday / Cyber Monday sales window

    They launched with what they thought was a stable firmware release, but wired backhaul was clearly broken and something like that should have been found before the initial ship of a mesh networking product

    I get the business choices and the nature of these products, and it didn't prevent me from picking up some Aliens to replace HD installations, but I have some experience with AmpliFi and knew what I was getting into

    Others are going to be frustrated and that is to be expected

    AmpliFi's product philosophy is all about consumer friendliness and ease-of-use, which is lost when features like Ethernet backhaul are broken and then all of sudden WiFi-6 access doesn't work
    (that's also why you may not get many of the more advanced features you have requested)

    But I know AmpliFi will fix them pretty quickly as well if they are easy to diagnose and fix


  • @derek-saville Bottom line is Amplifi is consumer/home user focused while Ubiquiti is business focused. Trying to force feed one into another is always going to cause frustration for those users who use them where they are not focused.


  • @timothy-farley I would have agreed with you had the price point of the Alien been right but given how over-priced the product is, one should expect a more complete and reliable product.


  • @derek-saville I agree with the rushed launch theory. I have only recently become aware of the Alien, I’m on their mailing list, but I’ve been browsing router reviews and posts for a while in anticipation of having to replace my current one. Prior to learning of Alien I had been focused on the Amplifi HD. But now I’m following along on these forums to learn of possible issues I might face. This particular one would affect me since I do have an iPhone 11 Pro Max. And that brings me to Apple having rushed out iOS 13 to make the product launch of the 11s.

    Day one of the release of iOS 13.0 I experienced multiple significant bugs, far more than any other previous ios. I became frustrated enough to install the beta on my iPad Pro in hopes of having at least some of them resolved. The just released 13.3.1 beta just fixed my most significant remaining bug which I’m very happy about. But here we are in December when the release of 13.0 was in September. 13.3 should have been the initial release of 13.0, it was really the first stable version they issued. In my opinion everything before 13.3 were just betas released to the general public.

    These mandatory product and software cycles do not serve the customers of these companies well but they do make for impressive promotional campaigns. The Alien remains my top choice but I’m glad I always choose to follow along for a while before purchase. As buggy as iOS 13 has been on my devices any glitches I would have encountered with the router I would have blamed on my ios devices. I’ll be waiting to hear that this one has been resolved.


  • Seriously some of you have not idea what its like on the other side. I had an Asus Gt-AX11000. Below are just some of the issues. I had it for a year and this issues were Never fixed. Their support sucks. Here you can report an issue an a real employee will take it up. No router is perfect at launch. I cant discuss Netgear as I have a NDA. Let just say they dont care. The Asus router I owned was $450. So just because you pay more does not mean anything now days. Wifi 6 is new and I am going to be honest with everyone here. Its not perfect yet, give it a few months if you are worried. This 1 bug we are talking about here just hit with the last firmware. Give them a chance to fix it. Its only been a week.

    Asus Gt-AX11000

    1. My 2.5Gb card would drop connection every large download.
    2. My Ecobee's would not reconnect after a router reboot.
    3. My Wifi 6 pc's would just drop randomly. Sometimes my son's would drop 8+ times a day.

  • @timothy-farley Thank you, thank you and thank you!


  • Hi @james-earl-ford - consider that Ubiquiti has shown the UniFi range (including the USG) at CES and marketed and sold the UniFi range in consumer retail channels

    And take this current banner (as of today) on their website for example:
    0_1576710538767_UDM.jpg

    They aren't referencing SOHO's there
    We know from rogue posts on this forum (quickly deleted) that there are outside hardware beta testers
    My comment that Ubiquiti Networks does use Early Access programs was more of a wish that AmpliFi would do so as well...

    Bottom line is any WiFi-6 Mesh system should both mesh and provide WiFi-6 access at the same time, regardless of the intended market, channel or target purchaser


  • Hi @timothy-farley - nobody is saying AmpliFi are not being responsive for the Alien
    They have already pushed out multiple firmware updates in a matter of weeks:

    • v3.2.0
    • v3.2.2 (20-Nov-19)
    • v3.2.3 (25-Nov-19)
    • v3.2.4 (11-Dec-19)

    And another is probably forthcoming in a matter of hours

    But AmpliFi doesn't have a perfect track record of being responsive and fixing bugs, some of which have never been fixed on the HD range

    Alien is a big launch and clearly getting a lot of priority attention
    WiFi is an impossible challenge to get right for everybody due to the infinitely variable environments and ever-changing clients
    I wouldn't want to see happen to Alien what occurred with the HD line where there were strings of successive firmware releases which continued to degrade performance and create other issues for sets of users - a very difficult challenge for the support engineers who do a great job on this forum


  • The iPhone 11 connectivity issue has been been fixed with the yesterday's firmware release v3.2.5. I am sorry it took that long.


  • @ui-karlis I guess I had better wait a couple months to the following year to get an iPhone 12. Just being sarcastic but that’s a pretty bad bug that would keep me from purchasing an Alien fearing a repeat with a new device.


  • Maybe your experience should keep you from buying another Apple device. It's their closed source software that usually is a issue. I work as a tech for Toyota and every single time there is a issue with a radio feature not working, or Bluetooth, it is always a iPhone, and problem can't be reproduced on Android. Just saying...break away from the herd


  • Hi @john-pappas - have you tried enabling the additional 5 GHz radio and giving it a unique SSID to confirm your iPhone 11 is working correctly on WiFi-5?

    I just checked and my family is not seeing any issues with iPhone 11 connecting to Aliens on WiFi-6 with v3.2.5 so it doesn’t seem to be a universal bug

    Have you sent support files to @UI-Karlis & @UI-Brett?


  • @derek-saville Thanks that’s good to know that you’re not seeing any issues. I’m using my Apple router, no issues. But it may be time to upgrade and I’ve been following the posted issues of the Alien since it’s at the top of my list as a replacement. And the 11 apparently was having a significant connection issue until the latest Alien software update. However I’ve seen similar issues with almost every recently released router regardless of manufacturer. But this bug took too long to resolve.

    At this point I’ve not seen any other device manufacturer, phone, tablet, computer, that would work as well and reliably for my needs. My philosophy is that you leave the dance with the one that brung you! And Apple has brung me to a lot of dances for many years.

    Anyway I’m glad this issue seems to be solved and will keep an eye on further developments. I think the Alien will be perfect for my apartment and needs as long as such issues can be avoided.

    Oh, I see that the forum is still not sending out notifications for new posts to followed threads. I know I was told that it was being looked into but it’s been quite a while.


  • Hi @john-pappas - HomeKit certified routers should be coming for Apple-centric homes, but no word if AmpliFi intends to support it with Alien


Log in to reply