Amplifi HD Speeds


  • Hello,

    I have Comcast Xfinity 1Gb, and I have been using their Xfi wifi router. The speed test speeds were always really high, even on wifi, but I was looking for more overage.

    I recently good a good deal on 3 HD routers. I put my xfi router in bridge mode and setup the HD routers. Everything is working perfectly, but the speeds are much lower than previously, wifi and hardwired.

    Wifi is usually below 200mb and hardwired is usually 300-500mb.

    I enabled hardware nat and hat did help a little.

    Any other ideas?


  • @jesse-mcnamara Hello, if your wireless speeds are still pretty slow try enabling A-MSDU in the web UI. You can get to the web UI by typing the routers IP (found on LCD of router) in to a browser or http://amplifi.lan/


  • @ui-jt Thanks, I will try that tonight?

    Any chance the Xfi modem/router is slowing things down since I'm not using it as a router, only in bridge mode? I plan on getting my own modem, but wanted to test Amplifi setup before a made the full commitment.


  • @jesse-mcnamara said in Amplifi HD Speeds:

    Any chance the Xfi modem/router is slowing things down since I'm not using it as a router, only in bridge mode?

    Doubtful. Most of the time when a device is placed into bridge mode it diverts requests and processes to the router which means it has limited functionality and impact on the network.

    I don't if its based on region or not, but I was instructed by Xfinity to enable IPv6 on my home network when I upgraded to 1 Gig speeds. Do you have IPv6 enabled on AmpliFi already?


  • I have enabled Ip6, I have attached a screenshot of the whatever settings.
    0_1576637120892_Screenshot_20191217-210648_Samsung Internet Beta.jpg


  • @jesse-mcnamara

    I Have a speed issue with my AmpliFi HD. On WIFI, my iPhone 11 Pro Max, 1 year old iPad, iPhone XS Max using Speedtest, Fast, Speedcheck and the builtin speed test of the AmpliFi HD - I get speed of around 200 or lower - 187 Mbps.

    I have a 400 tier speed, and I get 400 or more on my iMac Pro, 2017 MacBook Pro via wifi. The iDevices never get past 200. Very annoying.

    So today I plugged in my old Synology RT2600 and my iDevices all got near or more 400. I'm in a small apt, so my location to the routers is the same all the time. For computers and iDevices.

    I tried enabling A-MSDU suggested in this thread. I don't see any difference.

    Plugging the iMac Pro into AmpliFi HD with internet I get 475 - 500 once.

    Any thoughts would be appreciated


  • @just-me Just a thought and you may have already looked at this. In the communities I’ve lived in, townhouse and now condo apartment, there have been many nearby WiFi networks mostly using the 2.4 band. So when I set up my router, currently an Apple Time Capsule, I name the bands separately so that I can force my ios devices to only connect to the 5GHz band, in my apartment its coverage gets just about everywhere except one weak spot. I have set the devices to “Forget” the 2.4 network. Otherwise as I move around with them, go out of the apartment, come back in, etc. they will latch onto the 2.4 first since it can be detected much further away. And speeds on it are usually about half what they are on the 5GHz band. I’m on Verizon Fios 200/200 tier and on WiFi, 5GHz band, my devices get 300/300+ consistently.

    I’ve wondered about devices such as the Amplifi routers that use band steering as to whether the 2.4 issue would come up if the router or the device gets pushed to 2.4 instead of 5. I don’t know how this functions in reality but my hunch is that naming the networks separately so that you can stay on 5GHz all the time is a better solution. Especially for smaller spaces such as my apartment where the 5 reaches everywhere it really needs to. Perhaps the newer devices such as the Alien can overcome the issue of nearby network interference but I’m skeptical.


  • @john-pappas Thanks for reply - I have tried this with no difference.

    But - this morning I went in and changed the 5ghz channel to 149 (it was on auto and was using 48). I always used 149 even on all my past Airports. AND the speeds on all the iDevices now register close to 400 or over.

    No idea why - but happy.


  • @just-me That’s quite a coincidence, or maybe not. I asked here about setting the channel to 149 if I got the Alien router because that’s what I wound up doing on my current Apple router. In my apartment I found that 149 gave the best coverage and download speeds throughout. I tried the automatic setting but that did not work so well, quite inconsistent results. When I purchase the new router I may well have to do the same.


  • @john-pappas. A coincidence of real improvement. Very glad.

    I only ended on channel 149 from years ago, my Apple airport on Auto channel select always picked channel 149. 2 different locations too.

    Doing this simple channel switch, gave me back my wireless full speed.

    And as of this post - all speed tests are flying.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.