Teleport not connecting to Hhonors wifi


  • Currently, I am staying in a Hilton Honors hotel and I have trouble connecting the Teleport to their capitive portal. After selecting the right wifi ssid, I get the message that the Teleport network is going to reset, it does come up under wifi screen, but when I'm trying to sign in, I very briefly get the hotel's captive portal, but then the Teleport screen pops up and keeps "loading" internet (teleport.lan, second item "internet")

    I've got a logfile available if needed.


  • @micha-r I ran into some hiccups connecting to and passing the hotel's captive portal at a Home2 Suites last week. When I couldn't get it to work the first time from my iPhone, I connected to the teleport from my laptop and the hotel's captive portal finally popped up and let me enter my info to authenticate.

    I was able to get it working from my phone only on a different day (since Hilton makes you annoyingly re-authenticate every 24hrs)...but I think when I got stuck where you are at, I had to unplug the teleport, let it reboot and try again.

    You have to actually enter your info into the hotel's captive portal and get the success page before you'll be able to get past the "internet" green bubble on the teleport setup.


  • @micha-r said in Teleport not connecting to Hhonors wifi:

    I've got a logfile available if needed.

    Yes, please send the file to gunars.ritins@ubnt.com.


  • @Micha-R, @Jeremy-Smith: we'll have an update soon that will improve guest portal compatibility. It was solved for Xfinity, but we think many other networks have the same behavior.


  • I was wondering about this as a LOT of the Marriott properties have a captive portal you need to enter your room / name into before you get access.


  • @ubnt-gunars Awesome. That will obviously be a huge quality of life update as it seems most public wifi nowadays is behind some dumb captive portal. Good on you guys for upping the compatibility...I'm sure it is a headache to attempt to accommodate even the most common captive portal systems 😕


  • @Jeremy-Smith, @Joshua-Newton, @Micha-R: please update to the latest firmware via the app, and let me know if it works now.


  • I'll be in a Marriott property next week and will test out. The new firmware for the teleport unit or mesh router?


  • @ubnt-gunars I've updated my router but not the teleport yet since I haven't had a chance to bust out a laptop and manually upload the firmware. By the way...I'm sure you guys agree...but the ability to update the teleport through the app when it's on my local network would be a very nice quality of life improvement 🙂

    In any event, I'll be staying at a hilton hotel starting Dec. 11, so I'll be testing it then!


  • @Joshua-Newton, @Jeremy-Smith: Please, use in-app updates when Teleport is fully connected to the router (green color text in the app). Yes, local network updates would be great. Will check development estimates again.


  • @ubnt-gunars 😕 JUST updated the Teleport firmware manually. However I'll make sure to no update from the App.


  • Yes for honors I have to reset the Amplifi and connect through my laptop. It seemed when my lease was up it still thought it could do everything but the last step. It would just offer the "change connection" but even doing that didn't work.

    Could be the way Hilton blocks internet access until you renew your 24 hour session.


  • 0_1512557562696_Screenshot_20171205-202359.png

    I can't get past this screen without unplugging my device for an extended period of time. Then once I plug it back in, I get the captive portal again. I left it unplugged last night for a few hours while I slept.


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.