[SOLVED with 3.4.0 Firmware update] Not getting advertised speeds with single Alien Router


  • @Vernon-Chan I will try this when i get home if that is the problem would connecting second router via wireless degrade performance a great deal? I chose to try ethernet backhaul to maximize performance at least that was the idea.


  • @Amara-Fofana

    If your electrical cabling isn’t ideal for power line adapters and you don’t have the option to directly connect router to mesh point via Ethernet, wireless mesh may yield better performance. Wireless mesh performance varies based on many factors but some of the main factors include distance from Primary router and WiFi interference/congestion

    The alien uses either its 2.4 ghz WiFi 6 or 5 ghz WiFi 6 band as the backbone. For fastest speeds, the 5 ghz band should be used, and for best range, the 2.4 ghz band.

    In my case, the performance is degraded due to channel congestion of the 5 ghz WiFi 6 band. Until channel selection of the WiFi 6 band is enabled, the performance of the wireless mesh system is at the mercy of auto selection, which may or may not select a congested channel.


  • @Vernon-Chan I appreciate your detailed response and i will test powerline adapter first if that is the problem. I will go to wireless mesh connectivity. Would you suggest turning on router and band steering if i go that route? In addition i have an older home so i am assuming if i need to select a backhaul band i should select 2.4ghz for range. I did do a network diagnostic test yesterday via my mac and told me the only congestion i had on my network was my 2.4ghz channel and gave me alternative channel to use for better performance which i changed last night.


  • @Amara-Fofana

    For the backbone band, it's easy to switch via the Amplifi app. I'd try the 5 Ghz Wifi 6 band first (set to this by default) and if you have connectivity or greatly varying speeds on speedtest, switch to the 2.4 Ghz backbone. Generally, I'd only use 2.4 Ghz as the backbone if my mesh router is a very long distance from the primary, as the results in speed of using the 2.4 Ghz as a backbone will be a significant decrease.

    Based on the description, router steering will try to connect clients to the primary router even if the primary has a lower signal... This sort of defeats the purpose of a mesh system, so I leave it off

    Band steering switches your clients from a 5 Ghz band to the 2.4 Ghz band if the signal drops too low. From my experience with this router so far, even with this disabled, the behavior was the same for me. When I roamed too far in my backyard from either the router or mesh point, my phone switched over to the 2.4 Ghz band (verified by checking client details for my phone in the Amplifi app). The SSID for both my 2.4 Ghz WiFi 6 band and 5 Ghz WiFi 6 band are the same, so that may have some impact on the behavior.

    Also, one more thing I thought of - Verify the ethernet cable that you are using from powerline adapter to either your laptop, desktop, or Alien mesh router is CAT5e or better. If it is CAT5 your transmit rate will be capped at 100 Mbps.


  • @Vernon-Chan I really appreciate your detailed responses. I will leave steering disabled and i am only using Cat 6 cabling currently. I am going to leave work early to test all of this i am excited to troubleshoot this issue with the wealth of information you have provided. I will provide an update once i get home.


  • @Vernon-Chan I just disabled Ethernet Backhaul and removed power line adapters. Second Router has 74% signal strength to the router and I am now having acceptable speeds.


  • Glad you found a solution that worked for you!


  • @Amara-Fofana Did it test much higher?


  • @UI-JT yes much higher I was previously getting 24mb down now I’m in 200s. I still might do some placement tweaking.


  • @Amara-Fofana If you can get it to about 80% you should see better results.


  • @UI-JT It’s interesting because in the app it says my connection is between 80-84% on my mesh point/router but on the MeshPoint LCD says 73% why is that ?


  • @Amara-Fofana Its something we are working on, the app seems to be off a bit. The display on the router will be accurate.


  • @UI-JT Ok thanks for the explanation and is 73% still good or should I look to move my meshpoint ?


  • @Derek-Saville Im looking into this now with my development team. Thank your tagging me about this.


  • @UI-Brett any update on selectable channels for wifi6? Is it at least expected for 2020?


  • Wanted to give a quick update after the new firmware. It seems like with the new firmware 3.4.0 not only did it come with the awesome new UI but I'm finally getting gigabit level speeds over WiFi. I noticed a few times I've been downloading from 80-85 MBps (yes.. capital B for bytes) and finally broke the triple digit mark by uploading to my NAS server around 100 MBps!

    0_1592573653654_33A5AB34-48AE-400A-86E8-0A4C075DCA85.jpeg

    This was the speed I was always looking for going to a high end WiFi 6 access point and I'm very happy about it. My laptop is about 10ft away from the Alien Router so that is some awesome real life usage there.

    Please keep up the great work! I'm also going to update the title of the topic to [SOLVED] 🙂


Log in to reply