[SOLVED with 3.4.0 Firmware update] Not getting advertised speeds with single Alien Router

  • I was watching the youtube channel unbox therapy (https://www.youtube.com/watch?v=gf8mCl1ycBQ) and saw him get around 600-800 download mbps for WiFi 6 devices. I have an iPhone 11 Max Pro and laptop w/ Intel's AX200 WiFi 6 chipset. I usually got around 300mbps with my older netgear orbi using wifi 5. I have the router connected in bridge mode and the internet speed I get usually 800 down/900 up.

    I received the Alien router and have only been getting around 370-430 down and 350 up. I also have the 802.11v and 802.11k enabled including band steering and router steering. Anything else I can do to get those advertised speeds?

  • @vincent-ngo Can you confirm what wired speeds you are getting from the Alien? Also, what speed test websites are you using? Currently the in app speed test from AmpliFi can provide false test results while we are improving this feature.

  • @ui-brett I have FiOS gigabit and get 800/900 wired using the router internet speed test. wireless im getting around 300-350 down/300 up with an iPhone 11 Pro max. I get similar speeds using my laptop with an intel ax200 wifi card.

  • @ui-brett 0_1579228297643_D0683C0C-2714-43A0-8C13-9B8C72DE259A.jpeg

    my speedtest results


  • I have a note 10+ running Android 10, and when I am sitting close to the Alien router, I can get to connect with link speeds of 1.2Gbps. However, it does not seem to hold it for a long period of time. If I keep checking the link speed on the settings>connections>wifi, the link speed keeps changing from 1.2Gbps to 400Mbps some times 200Mbps as seen in the attached captures. Some times disabling and re-enabling wifi helps. When the link shows 1.2Gbps, I can get speed test using the speedtest app of 700Mbps down and 400Mbps. My ISP is VFios Gigabit and the router wired speed is closed to advertised speeds. Not sure why even when I am close to the router the link speed keeps changing so much. With my old Linksys AC router, I could get 900Mbps when sitting at the same spot in my living room. I have band steering disabled and separate SSIDs for wifi 6 2.4 GHz and 5Ghz Bands and also have the wifi5 5GHz disabled. 0_1579233877071_SmartSelect_20200116-225829_Settings.jpg 0_1579233889621_SmartSelect_20200116-225922_Settings.jpg

  • @UI-Brett is it normal for the link speeds to vary so much ? As I stated in my last post, even when I am close to the router it does not hold the 1.2Gbps link speed. I have seen it go as low 30Mbps. Thanks.

  • @plex-kuser It should not vary that much. I would suggest look for different points of interference near Alien. If possible, even a slight shift in placement can sometime help tremendously. If moving the device is not easy in your environment, you can simply rotate Alien on its side and test again.

    I would suggest after taking a few speed tests, generate support files for us to review as well.

  • @plex-kuser my link speed is showing 1.2gbps. Your numbers are closer to what I was expecting to get at least for the download part. I also tried disabling band steering and getting only around 367 down/282 up

  • @vincent-ngo with link speeds of 1.2Gbps I was able to get around 700Mbps down, as seen on my screen capture. @UI-Brett ok cool I will try changing the position of the router. However, I won't be able to move to a different location because my ONT cable from Verizon is fixed around my walls. I will report later on my testing, and share log files if I am still having issues. How do I share log files? Just post it here ?

  • @plex-kuser If you use the app, it will prompt to email them into support and all you will need is to reference this community post in the email. Or, if you have them downloaded on a computer you can email them directly to me.

  • @ui-brett perfect thanks

  • @UI-Brett after doing several tests. I have found the source of my wifi link speed issue. It is my home theater system. I have a Nakamichi 9.4.2 that uses 2 wireless subwoofers. Nakamichi says that their subs operate in the 5.8GHz band, and I just verified that as soon as I turn my home theater on, my link speed drops from 1.2Gbps to 50 Mbps and some times it stays at 100to200Mbps. Is there anything you could recommend from the router stand point to try ? Other than moving the router out of my leaving room ? Would changing channels help? Thanks

  • I have moved to channel 44, and that has fixed my issue. Now I am locked at 1.2Gbps. I am good now. I had the channel set to auto and it was using channel 36 which was being killed by my HT system.

  • @UI-Brett I am not sure why even if I change the channels for the 5Ghz band, when I use a wifi analyzer app is still saying that I am using channel 149 and not 36 or 44 or any of the options provided by the router ? 149 would for sure interfere with my HT system but they say that using either 36, 40, 44 or 48 would be ok. However I just realized that the wifi analyzer app keep saying that my network is using 149. The option you offer for changing the 5Ghz channel only affects the wifi5 chip and not the wifi6. I am broadcasting 3 separate SSIDs (2.4Ghz,and the 2 5Ghz for wifi 5 and 6) and I just realized that the wifi5 is using the channel I configured but the wifi6 is using 149 which would interfere with my HT system.

  • Currently there is no channel options for the wifi 6 radio, not sure if it's an over site, or it's that way because they are going to add dfs and 160MHz

  • @mike-p that kind of sucks. I upgraded to this router for the wifi 6 support. I just tested with the wifi 5 network using channel 36 and it can get full link speed of 866Mbps with my HT system on. I mean this is what I was getting with my old AC router. @UI-Brett will you guys consider the option of adding extra channels for the wifi6 network?. This would even be an issue for a crowded area with a bunch of people using the same channel. Is wifi 6 always set to 149? Also why if the additional 5Ghz wifi is disabled for wifi5, the app still provide the option to change the channel if changing the channel does not affect the wifi6 network? Thanks

  • Updated FCC documents were submitted for v3.2.4 and released on 1/15:

    • Change #1: 2.4G ac/ax function added (firmware change only)
    • Change#2: 5G (Band 1 & band 4) Beamforming function added (firmware change only)

    Still only showing up to HE80, so no 160 MHz channels yet

    Seems like v3.2.5 was a quick fix for an issue, but the longer delay now for v3.2.6 or later hopefully means testing for more channels maybe being certified???

    Apologies @UI-Brett if this violates any posting guidelines...

    The available 5GHz channels are listed as:


    And for reference the 2.4GHz channels are listed as:


  • @plex-kuser It does sometimes use other channels, mine is currently using 157. For whatever reason, the app lacks wifi6 radio channel selection options. You know with the current firmware I don't think we can get near to the capabilities of wifi6.

  • You know with the current firmware I don't think we can get near to the capabilities of wifi6

    Hi @mike-p - as of v3.2.4 (and very likely v3.2.5) for 5 GHz, WiFi-6 has only been implemented in the upper 5725 - 5850 MHz band and limited to USA compliant non-DFS channels

    So there is only one WiFi-6 80 MHz (HE80) channel # 155, two WiFi-6 40 MHz (HE40) channels # 151 & 159, along with the typical 20 MHz WiFi-6 (HE20) channels # 149 to 165

  • @derek-saville Yeah and those channels are not user selectable

Log in to reply