Can't get more than 120mbps


  • Hello everyone. I've got Amplifi HD system with two mesh points.
    I have 500mbit/sec ISP and I can't get more than 120-130 mbit/sec speed.
    I can see that my laptop has PHY mode at 802.11ac connection and agreed speed more than 390 mbit/sec.
    Also I've tried to add additional ssid on closest mesh ap with manually enabled 5ghz with no luck.
    When I connect my laptop via wired connection to router and enable hardware nat I can get through to 500mbit (kind of 495mbps).
    When I open an Amplifi app and start speed test router shows same 120-130mbit/sec.
    Any suggestions please?


  • Through the Amplifi app, I get around 600mbps on my 1gig connection with the speed test. When I hard wire I get 910 mbps through fast.com. I don't think the amplifi app speed test is the most accurate.


  • Hello.
    More tests show that directly wireless connection to router, excluding mesh point, gives true 500mbit.
    Checked signal straight from mesh point to router - shows at least 84%. Couldn't understand is that normal or what...
    Im gonna try to move mesh points around.


  • @gsi0
    Hello,
    Same results here. Wired perfect according to my subscription. With wifi it drops to 120 mbps, mesh and router.
    I have 500mbps ISP


  • @apeldof
    Problem is between mesh ap and router. You need to make it closer to each other. I'm going to move ISP cable from 3rd floor to second install router on second floor and move mesh point to first and third floor.


  • @gsi0
    Hi,
    Both mesh point give a 100%. For me useless to move the things around. Cables from one point to another cannot be the solution in buying a wifi/mesh Router combination.
    Why did I ever spend 350 on this one.


  • @apeldof
    It's sad. Do you have use it in appartmen or in house?


  • @gsi0
    It’s sad indeed. I live in a house.

    @ubiquiti, any suggestion?


  • @apeldof Get the Meshpoints signal level down to about 80% and test.


  • @UI-JT
    I turned the antennas in order to get around the 80%.
    I checked if the device was connected to one of the mesh and not to the base.
    I cannot notice much difference. Perhaps a max of 10% more very close to the mesh.
    Base speed is 140 mbps, mesh 110. Again ISP 500mbps.
    Base cabled 600 + mbps up/down


  • @apeldof Login to the web UI with the router ip address (found on the front screen by tapping) and enable A-MSDU.


  • @UI-JT
    Hi, thanks for your response.
    This has certainly a positive effect. Base is around 250mbps and the mesh 160mbps wifi.
    Do not know what I have done by enabling A-MSDU but it helps.
    Thanks again.


  • @apeldof
    With removing my meshpoints I even get more wifi speed.
    I am now on 280mbps out of 500.
    These meshpoints are the problem and slowing down everything.


  • @apeldof The MeshPoints are usually slower than the router, anytime you introduce more noise in the envirnment this will cause performance to decrease but you will have more coverage. Try going in to the web UI again and enable 802.11k and 802.11v this may help your devices transition between access points better and improve throughput. Please note anytime you are connected to a MeshPoint that the throughput loss can be as large as 50% here is a good breakdown of how this works: http://www.revolutionwifi.net/revolutionwifi/2012/02/mesh-network-performance-impact.html


  • @UI-JT
    Thanks a lot for your reply.
    Did what you suggested and tried to understand the article. For how I understand (correct me if I'm wrong) the mesh point haven to be in line of each other, so point 1 is feeding point 2. Most of the lost (50%) is after point 1.
    What if the base is feeding two mesh separately is the lost still 50%
    In my situation the mesh points are in different angles of the base.


  • @Joshua-Smith did this problem ever get resolved? I’m seeing really poor speed from my mesh points. I’ve given up and unplugged them.


  • @rseanj im having the same issue. have you gotten anywhere?


  • @pbernikier nope, I guess that is all you get from a meshpoint. I have disable my meshpoints and deal with the homebase.
    Meshpoints are a disapointment, never should by them.
    Ubiquiti Amplifi is great.


  • @pbernikier I was thinking that this is just they way it works. The meshpoint operates at about 50% of the router speed.
    But then I bought an add on mesh point for a friends house, and it works perfectly. No degradation.

    So, I opened a ticket with UI and have done extensive testing on this. Amplifi has been working with me by email to try and figure this out, but no resolution yet. I've found some weird things - like if I enable a secondary SSID with 2.4ghz, I get about the same speed from it as I do from a 5ghz SSID through the mesh point. So I have a suspicion that the mesh point isn't working at 5ghz.

    I have certainly seen a lot of people complaining about this scenario online. But I know the mesh points can work (or at least one does) - just mine do not.

    There was a software update last week but it didn't make it any better.


  • @rseanj I too am working with ubiquiti support to get this resolved. the issue I am having it's similar to yours but I'm having issues with the router as well. From a wired connection I get my full ISP number... (Right now that's only 200 but I tested it with 400 and it was good) and with Wi-Fi as long as I am within line-of-sight of the router I get that as well but I can be 20 feet away and behind a sheetrock wall and get 35 Mbps. And the same goes for the mesh points I have too mesh points one is in what they call the "perfect" position and the other one average. The one that's in the perfect position if I can see it while using it I can get between 110 and 190, but if I can't see it it doesn't even give me that good. But the one that's average won't even give me 100 Mbps.so I don't see what the point is.

    Just so you understand my setup I live in a home that is about 65 by 32 and has a basement and two stories. My router is directly in the middle of the main floor. So my original setup was that I had one mesh point on each of the outer walls. But when I had them set up like that they were both average and they got terrible speeds. My office which is in the basement is most important for the fastest speed. So I walked around my basement with a mesh point and I figured out that the only way to get it to be in the "perfect" was in the room under the main router... So now that's where I have it and it helps somewhat but not drastically.

    when I spoke to amplify support the only thing they could tell me is to shut off the microwave the other large electronics, so I told them that the only large electronics running in the vicinity are my PCs. Let's see what they're able to dig up.


Log in to reply