Wireless latency and packet drops to router every 60 seconds

  • I have a reoccurring wireless issue between my computers and the router.

    While running a ping from a computer to the router (via mesh), I see a group of packets once every 60 seconds that has increased latency and sometimes packet drops. Normally, I get a response of 1-3ms. During this event, latency jumps to 200ms - 2000ms.

    If I am on a video conference session (Zoom, Skype, etc), audio is garbled during these times. 150ms is generally considered when audio quality starts to noticeably degrade...and this is just wifi inside my network (not accounting for internet hops and performance)

    My troubleshooting thus far:

    -Version is latest 3.1.2 (no updates available)
    -Rebooted router and mesh points.
    -Connectivity from mesh points to the router is 84% & 100% strength.
    -Wired connectivity to the router is unaffected.
    -Used wireless diagnostic tool to look at signal strength and channel numbers. Statically set both 5Ghz and 2.4Ghz to channels that were not in use or very very low signal by neighbors.
    -I am not seeing any jump in wireless noise or SNR during these events.
    -Have reproduced with multiple computers.
    -Have reproduced on both 2.4 and 5Ghz
    -Band steering was on. Toggled off.
    -Reproduced when there is very little other use on the network (no streaming or downloads going)
    -Have disconnected the mesh APs, reproduced standing a few feet away from the router.

    It is so reliably every 60 seconds, that it feels like some sort of scheduled process, channel/frequency scanning or antenna event. Check this out:

    PING ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=64 time=2.323 ms
    64 bytes from icmp_seq=1 ttl=64 time=1.774 ms
    64 bytes from icmp_seq=2 ttl=64 time=2.709 ms
    64 bytes from icmp_seq=3 ttl=64 time=553.560 ms
    64 bytes from icmp_seq=4 ttl=64 time=787.327 ms
    64 bytes from icmp_seq=5 ttl=64 time=558.008 ms
    64 bytes from icmp_seq=6 ttl=64 time=322.998 ms

    64 bytes from icmp_seq=7 ttl=64 time=3.259 ms
    64 bytes from icmp_seq=8 ttl=64 time=1.705 ms
    64 bytes from icmp_seq=9 ttl=64 time=2.557 ms
    64 bytes from icmp_seq=10 ttl=64 time=1.716 ms
    64 bytes from icmp_seq=11 ttl=64 time=2.223 ms
    64 bytes from icmp_seq=12 ttl=64 time=3.231 ms
    64 bytes from icmp_seq=13 ttl=64 time=1.432 ms
    64 bytes from icmp_seq=14 ttl=64 time=2.434 ms
    64 bytes from icmp_seq=15 ttl=64 time=2.908 ms
    64 bytes from icmp_seq=16 ttl=64 time=1.946 ms
    64 bytes from icmp_seq=17 ttl=64 time=1.835 ms
    64 bytes from icmp_seq=18 ttl=64 time=1.776 ms
    64 bytes from icmp_seq=19 ttl=64 time=2.662 ms
    64 bytes from icmp_seq=20 ttl=64 time=1.731 ms
    64 bytes from icmp_seq=21 ttl=64 time=2.767 ms
    64 bytes from icmp_seq=22 ttl=64 time=2.937 ms
    64 bytes from icmp_seq=23 ttl=64 time=3.187 ms
    64 bytes from icmp_seq=24 ttl=64 time=3.181 ms
    64 bytes from icmp_seq=25 ttl=64 time=2.624 ms
    64 bytes from icmp_seq=26 ttl=64 time=1.703 ms
    64 bytes from icmp_seq=27 ttl=64 time=1.685 ms
    64 bytes from icmp_seq=28 ttl=64 time=1.979 ms
    64 bytes from icmp_seq=29 ttl=64 time=1.774 ms
    64 bytes from icmp_seq=30 ttl=64 time=1.751 ms
    64 bytes from icmp_seq=31 ttl=64 time=2.119 ms
    64 bytes from icmp_seq=32 ttl=64 time=3.401 ms
    64 bytes from icmp_seq=33 ttl=64 time=1.752 ms
    64 bytes from icmp_seq=34 ttl=64 time=2.579 ms
    64 bytes from icmp_seq=35 ttl=64 time=4.223 ms
    64 bytes from icmp_seq=36 ttl=64 time=2.906 ms
    64 bytes from icmp_seq=37 ttl=64 time=1.704 ms
    64 bytes from icmp_seq=38 ttl=64 time=1.660 ms
    64 bytes from icmp_seq=39 ttl=64 time=1.660 ms
    64 bytes from icmp_seq=40 ttl=64 time=2.408 ms
    64 bytes from icmp_seq=41 ttl=64 time=1.747 ms
    64 bytes from icmp_seq=42 ttl=64 time=1.488 ms
    64 bytes from icmp_seq=43 ttl=64 time=2.625 ms
    64 bytes from icmp_seq=44 ttl=64 time=3.676 ms
    64 bytes from icmp_seq=45 ttl=64 time=1.982 ms
    64 bytes from icmp_seq=46 ttl=64 time=2.004 ms
    64 bytes from icmp_seq=47 ttl=64 time=1.972 ms
    64 bytes from icmp_seq=48 ttl=64 time=1.826 ms
    64 bytes from icmp_seq=49 ttl=64 time=2.062 ms
    64 bytes from icmp_seq=50 ttl=64 time=1.918 ms
    64 bytes from icmp_seq=51 ttl=64 time=2.796 ms
    64 bytes from icmp_seq=52 ttl=64 time=2.639 ms
    64 bytes from icmp_seq=53 ttl=64 time=3.568 ms
    64 bytes from icmp_seq=54 ttl=64 time=2.632 ms
    64 bytes from icmp_seq=55 ttl=64 time=2.110 ms
    64 bytes from icmp_seq=56 ttl=64 time=1.690 ms
    64 bytes from icmp_seq=57 ttl=64 time=1.946 ms
    64 bytes from icmp_seq=58 ttl=64 time=1.716 ms
    64 bytes from icmp_seq=59 ttl=64 time=1.792 ms
    64 bytes from icmp_seq=60 ttl=64 time=4.143 ms
    64 bytes from icmp_seq=61 ttl=64 time=3.097 ms
    64 bytes from icmp_seq=62 ttl=64 time=2.940 ms
    64 bytes from icmp_seq=63 ttl=64 time=399.298 ms
    64 bytes from icmp_seq=64 ttl=64 time=1.672 ms
    64 bytes from icmp_seq=65 ttl=64 time=192.678 ms
    64 bytes from icmp_seq=66 ttl=64 time=731.818 ms

    64 bytes from icmp_seq=67 ttl=64 time=1.957 ms
    64 bytes from icmp_seq=68 ttl=64 time=1.745 ms


  • Dylan,

    By chance are you seeing these pings from a Mac? I came across your post while trying to solve the exact same problem with my UniFi setup involving a wireless uplink. I'm getting the exact same pattern of pings from by 2015 MacBook Pro running Catalina. I can stop the problem from happening by disabling Location Services (System Preferences>Privacy>Location Services). When I toggle Location Services back on, the high-latency / dropped pings come back with that 60 second frequency.


  • @Dylan-Bruesch I have the same problem running version 3.3.0 and have tried the same steps. Also correlated loss at local gateway with a node in my ISP network so know it's not just icmp been dropped destined to local gateway. My latency however occurs ever 10 seconds or so for a few seconds but adds 20-150ms latency. I assumed the gateway address was the Amplifi HD gateway (mac address matches) but after a few tests with reloading the virgin hub and swapping cables I cannot be 100% sure if that. Anyway, factory resetting both my Amplifi HD and Virgin Hub do not fix the issue.

  • I'm having a similar problem on version 3.3.0, although happening more frequently than every 60 seconds. I have tried most of the steps you've outlined as well. Here is a sample of my pings to the router.

    Reply from bytes=32 time=6ms TTL=64
    Reply from bytes=32 time=6ms TTL=64
    Reply from bytes=32 time=6ms TTL=64
    Reply from bytes=32 time=3ms TTL=64
    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time=198ms TTL=64
    Reply from bytes=32 time=357ms TTL=64
    Reply from bytes=32 time=389ms TTL=64
    Reply from bytes=32 time=110ms TTL=64
    Reply from bytes=32 time=218ms TTL=64
    Reply from bytes=32 time=468ms TTL=64
    Reply from bytes=32 time=382ms TTL=64

    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time=3ms TTL=64
    Reply from bytes=32 time=5ms TTL=64
    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time=5ms TTL=64
    Reply from bytes=32 time=3ms TTL=64
    Reply from bytes=32 time=5ms TTL=64
    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time=4ms TTL=64
    Reply from bytes=32 time=343ms TTL=64
    Reply from bytes=32 time=60ms TTL=64
    Reply from bytes=32 time=178ms TTL=64
    Reply from bytes=32 time=435ms TTL=64
    Reply from bytes=32 time=469ms TTL=64
    Reply from bytes=32 time=21ms TTL=64
    Reply from bytes=32 time=316ms TTL=64
    Reply from bytes=32 time=217ms TTL=64

    Reply from bytes=32 time=2ms TTL=64
    Reply from bytes=32 time=5ms TTL=64
    Reply from bytes=32 time=5ms TTL=64

    This is happening across a number of wireless devices. Wired devices are fine. I have had my AmplifiHD router for 1-2 years and this problem just became noticeable in the last 2 weeks. I have always had issues with temporarily losing connectivity when being transferred from the router to APs, but that's unrelated. Perhaps it's time to ditch Amplifi and invest in a different system?

Log in to reply