Bridge mode


  • I put my Alien into bridge mode and now both of my network names show up. Should I choose the alien one or the Verizon router? Thank you.


  • @H-K You would want to connect to the Alien WiFi broadcast, and disable the wireless broadcast from your Verizon router.


  • @UI-Brett thank you. Even if the alien is the one in bridge? I appreciate it.


  • @H-K Yes, Alien will not be assigning IP addresses, or handling any port forwarding rules and other aspects like that, but you will want your devices to connect to the Alien WiFi for WiFi-6, range and overall wireless performance that Alien offers.


  • @H-K As Brett said turn off the radios on the Verizon router. I’m currently using another router but the set up is the same. I have my Fios router’s radios turned off, my Apple router in bridge mode and providing my wifi network. You could leave the radios on with the Verizon router but no reason to have extra interference in your home. My Fios router is needed for certain tv/dvr features but my Apple router is more centrally located with better range so I use it for my network. I’m looking forward to using an Alien and seeing if the range is even better.


  • @John-Pappas the Alien is ridiculously fast. I haven’t even set up the additional mesh and getting 800/400 in my office which used to be real slow. I turned off my verizon broadcast. Thank you for the tip.


  • @UI-Brett thank you.


  • @H-K I’m glad to hear it’s working so well for you. I’ve been researching routers since becoming concerned that my current one is getting pretty long in the tooth. The Amplifi products have had the most appeal for me and when the Alien was announced and released I zeroed in on it but wanted to see what the experience of others was.


  • @John-Pappas I had the HD mesh in my last house and it was great. BUT, it does not compare with the Alien. Worth the money. We have a pretty big house, that is configured unconventionally and the Alien router still touches the entire home.


  • @H-K That’s what I want to hear! Thanks.


Log in to reply