Power Supply Dead - UK (USB-C)


  • Hi, the power supply that came with my Amplifi HD set ( with 2 mesh sticks ) died yesterday.It is not pushing anything out at all.I have chatted to an Amplifi guy on the Help line via the App and it seems clear that the only available PS from Amplifi as a replacement item is the US one. He suggested contacting a UK reseller but that's going nowhere: the 2 distributors only sell boxed items.

    So have I now got a very attractive set of 3 white bits that are non-functioning just because of a failed PS that costs $12 in the USA but is not available on the UK? The 2 Mesh sticks are locked to the router aren't they so that's great? When I bought the stuff, one of the sticks had to go back to the USA via RMA because it failed to connect.

    I'm past the warranty period. I've never had a PS unit die on me for any of the dozens of electrical items purchased over the years, but here out of a set that comprises 4 units ( router, PS, and 2 mesh) 2 have failed within 2 years (a mesh and now the PS)! Sure, Amplifi looks great but I reckon it's form over function, and unless I can find a solution in the 48 hours, another router will have to be acquired and it won't be an Amplifi.

    Someone on Reddit. (also posted there)has suggested using a generic USB- C PS. I tried my LG phone cable but got the dreaded "Adaptor Error" message but at least it indicated that the router hadn't been bricked (yet). Previously I have read advice warning against using generic PS because the Amplifi is so picky.

    Any help welcomed. Thanks.


  • Update:
    Had some exchange on the Reddit forum. Found this recommended by a member on here who also had a UK problem. So following his lead with this:

    https://www.amazon.co.uk/dp/B07RKV6KQL/ref=pe_3187911_189395841_TE_dp_1

    I will update when tried it out. Fingers crossed...


  • Took delivery of these today. Plugged in to back of Router first and then Anker plug and then to mains voltage.

    Up and running.

    Anker 30W Power IQ 3.0 USB C
    https://www.amazon.co.uk/dp/B07RKV6KQL?ref=ppx_pop_mob_ap_share

    NIMASO USB C Cable [2-Pack...
    https://www.amazon.co.uk/dp/B07Z75HBR2?ref=ppx_pop_mob_ap_share

    Seems ok.....


  • @Jack-Splash Some users have experienced similar successes, yes other users using the same product could not function properly. It comes down to network draw, especially LAN ports. Happy it's working for you, and you found a solution! But this is why we at support cannot recommend one because everyone's environment is different.


  • @UI-Brett
    Fair enough Brett. thought it could be helpful to share my experience with others who may find themselves in the same boat on this side of the pond.
    The reality for me has been that Amplifi only stock US plugs. UK and other European distributers only seem to be able to supply whole kits and not replacement separate items. So when faced with a single point of failure (a $12 item) and possible costly whole-system replacement I had to self-help to find a solution. Better if Amplify stocked UK/EU power supplies than leaving us (cutomers) on our own..... Just saying.


  • @Jack-Splash I absolutely agree with you, and I think you sharing this success story is great for everyone to see just in case they are in a similar situation. I just wanted to add our reasoning to this post just in case someone tries those adapters and does not have the same success.


  • @Jack-Splash just to confirm for anyone else in this predicament - the Anker works fine 👍🏽


  • Just been alerted to Franz S' posting. I can happily report that 10 months later everything has been functioning fine with the generic PS.


  • Morning guys. Thanks so much for this information as my dog chewed through my power cable on my new amplifi gaming edition (3 days old) yesterday and I'm taking delivery of the Anker plug today so fingers crossed. I have one cheeky question to ask if possible. Does the amplifi normally constantly show the upload and download speed as mine is very variable? It will sit at zero for ages then goes up to 50 or 60 then back down. Speed tests are fine at over 400mbps but the router doesn't show this speed constantly (more like 0) even though everything connected is working fine. I just wondered if the router may have a slight issue and if it should be constantly showing the upload and download speed. Thanks again. Steve


  • I can confirm the Anker combination works for me. Thank you


  • @EvoSTeAkK Yes I have seen this phenomenon too where nothing is actively downloading to my knowledge. But then for 10 seconds or so the router will show a peak of activity. I put it down to certain apps or devices "phoning home"...! I wouldn't worry if I were you.


  • @Jack-Splash thanks mate. So just to clarify it shouldn't show the current Internet speed constantly, just when I run an Internet speed test? Thanks for your time, much more help than Ubiquiti.Even though I love the product the support sucks haha. The plug has been lifesaver as I'd had it 3 days before the dog chewed it. Can't believe you can't just buy one.


Log in to reply