Teleport for macOS


  • I just wanted to add that I was able to get the iPad app installed on my MacBook Air M1 for anyone that is in a similar situation. It worked to get be tunneled to my home router.


  • This post is deleted!

  • Please add Mac OS and Windows support!


  • If Amplifi is not going to release a MacOS or Windows Teleport client... will they at least allow a third party to develop one? This is a critical (and expected) thing to have FROM A $380 ROUTER!


  • +1, have a OS X application working please


  • OSX and Windows app please, kinda asinine a router 3x the cost of competitors with open VPN cant support is VPN on computer that actually use vpn...


  • @peytoncas I can confirm that this works. I was able to use it to play Minecraft in LAN mode between two M1 Macs, one of which was on the local network and the other of which was not.


  • @peytoncas could you please share details about setup?


  • @saaibo Hey, unfortunately, this might only for an M1 mac as there is an option to run iOS apps on Mac OS essentially. Basically, search for the Amplifi Teleport app in the Mac App Store and if its available, you should be able to download it and configure it.


  • @peytoncas, thanks, that’s good news!


  • +1 for desktop. Keep it alive.


  • ++1 keep this request alive


  • @tmarijnissen said in Teleport for macOS:

    Please add Mac OS and Windows support!

    yes please, it would make things so much easier


  • @peytoncas -- Great Suggestion!! I just tried installing the Amplifi Teleport app (for IOS) on my M1 MacBook and it actually does work! The App Store indicates it is not tested to work on MacOS, but I have it working and have a stable Teleport Connection for over 30 minutes. I am experimenting with setting the Amplifi HD in router mode and also in bridge mode to see what the effects are. I am able to establish a Teleport connection from my Mac to the AmplifiHD in both modes, but I have not explored things enough to determine if one is preferable. I am attaching a screenshot to show it functioning. I have a wifi tethered connection to my phone cellular data, and you can see that Teleport app on the MacBook creates a VPN connection. The picture shows "Your Phone" instead of "Your MacBook" because the phone is the Internet connection. The phone definitely is not using the Teleport app when I took this screenshot. The upload and download speeds are limited by the upload speed of my home ISP and the upload of my cell phone provider.
    0_1653148533908_Teleport-M1 copy.jpg


  • @Bruce-Cole it works, but it's not as reliable as it could be, and I can't access my LAN's NAS. It's definitely what I would consider a lucky and convenient workaround if you have an M1 MacBook, but it's limited.

    Aside from being frustrated as a customer, I'm also frustrated as a product and marketing person. A free and simple-to-use VPN with your router that you could use away from your home is such low-hanging fruit for Ubiquiti. It's such an easy marketing win and value add for consumer-level customers, which is the target audience for Amplifi products. But it's been officially rejected with absurd reasoning and continues to be ignored by Ubiquiti. I don't get it, but I have to assume they don't have the internal resources (someone who understands what's being requested and why it makes sense) to consider it properly.


  • @henshaw
    … under teleport Devices do you have turned on Lan network access for your device?

    In my case lan access works perfectly.


  • @nme I didn't even know that was an option. Thanks for sharing. I'll test it out the next time I'm not connected to my home LAN.


  • @henshaw
    You can also turn this option on from your phone or M1 macs with AMPLIFI app if you have Remote Access 😉


Log in to reply