AmpliFi HD Firmware v3.3.0


  • @originlly Interesting. I'm on 3.3.0 and haven't noticed any issues. I run 2 Amplifi HDs, but most of my devices just connect to the primary router. I went ahead and downgraded to 3.1.2 and did a factory reset to test out what you've been experiencing. Everything seems about the same.


  • @Mark-Christopherson Most of my issues have not been with the router, but clients connected to the mesh points. In the past a factory reset has only created a huge pain by losing all my settings without gain. Now back on 3.1.2 everything seems to work well including the more challenging IOT/HomeKit devices.


  • @Harald-Striepe I set up an additional 2.4 SSID to use with my IOT/HomeKit devices. I rest them all the devices to use the additional SSID. All of them work better since they are on a dedicated 2.4 and not having to handle the mesh system of band steering. Also, it’s safer For you system since they are not on the main WiFi SSID. If you are using muiltple apple hubs (AppleTV’s or homepods) make sure they are signed into the same apple account. If not, the HomeKit devices will not work properly.


  • @Jamie-Loeb How is that "safer" unless your additional 2.4 SSID is the guest network? If it's not the guest network, then all devices on the network can talk to each other regardless of access point or SSID used.

    At least that's my understanding of Amplifi's architecture. Would love to be shown wrong so that I truly can have segmented networks with amplifiHD without use of


  • @Jamie-Loeb This would not work for me. My Macs also use HomeKit and everything is integrated. There is also a HomeKit bridge which integrates Logitech Harmony. I need the mesh since it all spreads across a larger property with three mesh points.


  • I think I am done with this now. Wasted 30 minutes during an already hectic morning just now having to reset things again - similar to issues that I had last year before 3.1.2.

    Internet dropped out, app showed that the router was not connected to internet or to mesh points. Restarted router, and it worked for about 20 seconds and then would reboot. This cycle continued while my family wailed about "what is happening with the internet??".

    Procedure required is to switch all mesh points off. Restart the router, then restart the meshpoints. A bit of early morning exercise running around the house. Obviously something in one of the mesh points continually crashes the router. (FYI I use an HD, with another HD and an Instant as mesh points using ethernet backhaul).

    This used to happen frequently last year. 3.1.2 stopped that, but since downgrade from 3.0 we are obviously back here again.

    These things have been trouble since the moment I set them up (which took 6 hours of messing about as documented previously). WIFI should just work. You should not need to think about it.

    Obviously there is something fundamentally wrong here. Either the software has so much technical debt / is so wonky, and / or the engineering team are not capable of stabalizing things and managing their way out of the mess.

    At this point I will mention my previous 5 years with three Apple Airports. In those days the wifi didn't go down, ever. Software updates would come occasionally and they would just WORK. You didn't have to check forums, or set a reminder to see if other users were having issues after a month before you dared to upgrade. It worked.

    There are 165 posts on this thread and we have no information if the issue is properly understood, if there will be a fix. My guess is that Amplifi users will just have to live like this..

    So I'm done. Going to find a different wifi solution so that I can take one more stress factor out of my life...


  • I run a number of HDs in bridge mode and had no problems at all after all firmware updates which occurred since a got my first HD in November 2018. Also FIRMWARE V3.3.0 works fine, meanwhile for a HD mesh network of 10 HDs of which 9 are connected via ethernet and only one only wirelessly. From my of point of view the HDs work as trustworthy and flawless as a few Apple Airport Extreme devices used as access points which were replaced by the HDs.


  • @Mark-Seall I'm with you. Very frustrating. Similar issues. Homekit and other devices constantly dropping. Sent in report to support and their solution was downgrade to what worked. Who bug tests this stuff? This is very similar as you say to what was going on before 3.12 in my opinion and experience.


  • @Otto-Wilhelm I think that the problem is that home networking setups like this can have a LOT of different configuration possibilities which means a lot of edge cases, so you need a basically robust and stable system underneath. I wish I had had your experience, but like a lot of people here I've spent a lot of time and had nothing but trouble.

    During the weekend I setup a Unifi Dream Machine with two APs connected and put the Amplifi kit in the box. My hope now is that I can go back to never having to think about the b***y wifi again...


  • @Otto-Wilhelm I guess you missed the part that everyone’s mostly having WIRELESS backhauled meshpoint issues. Some of us don’t have the option of having Ethernet backhaul between all of our meshpoints and with 3.3.0 it seems to have killed our wireless throughput.


  • @Mark-Seall What did you use for APs? The UDM looks very nice, but I need a second AP with ethernet out for devices. My home is not wired so need a mesh solution. Current running two HD's with the second as an AP. It would be nice if one of those could be an AP off of the UDM.


  • @Mark-Christopherson Am using Unifi FlexHD. very nice looking and discreet units. Not sure if you can mesh them wirelessly - I haven't gotten that deep in to it. But what I do notice today is that my laptop has over 2.5 times the throughput that I used to have. (used to log around 250 megabit, now I'm getting around 700).

    Which shows me how poorly the Amplifi units were really performing.


  • @Mark-Seall still going strong? I've been curious about going good route but haven't.. yet lol


  • @MichaelE Well, I don't want to highjack this thread by talking about the DreamMachine, and it has only been 3 days, but so far I am really pleased. Initially I was concerned that as a Prosumer device it might be a bit to complicated and time consuming, but initial setup was as simple, or simpler than the Amplifi - in fact, considerably simpler because it worked first time (I had a devil of a job getting wired meshpoints working with Amplifi and spend around 6 hours messing with it).

    The DreamMachine was up and running with 2 access points in around 20 minutes. Plus another 30 minutes for obligatory but pointless messing with settings (none of which I changed - defaults all fine) and a few minutes making some cables nice.

    Job done. Been working flawlessly, super fast everywhere. Couldn't be happier.


  • Can I get the 3.1.2 firmware as I can’t rollback past the RC versions I installed.


  • @Mark-Seall do you have gig?


  • @MichaelE Yep. I also notice that wired devices on the Amplifi used to max out at around 850Mbs. On the DreamMachine I get a fairly consistent 930Mbs. Not that one notices the difference...


  • Any update on these issues? All of my issues started when I upgraded to 3.3.0, then I rolled back to 3.1.2 and factory reset it and things were much better...for a few days. Now I’m having all sorts of speed related issues. Wired, wireless, it’s all slow unless I reboot the HD then everything runs smoothly again for anywhere between 10 minutes and 2 hours. Then I’m dropping simple ping packets even to internal devices that are hard wired directly into the HD.

    We stopped using Ubiquiti devices at our clients because getting support when things weren’t working was impossible. I only have this device at my house because we tried it at a client and it didn’t work. I’ve wasted so much time on this already.

    How are the beta firmware versions? Stable? Better? Worth trying? Or should I use these for target practice and get something else?


  • @USCPU

    Pinging a wireless device sitting directly under an HD from a wired device connected to the same HD.
    Minimum = 1ms, Maximum = 153ms, Average = 10ms

    A Nest Hello.. Hi..
    Minimum = 1ms, Maximum = 51ms, Average = 10ms

    Interesting.....


  • @MichaelE Based on prior posting, I'd suggest you move the wireless device ten or twenty feet away from the HD, then retest. There are issues when you are too close to any device acting as a WiFi AP; in this case the HD.


Log in to reply