AmpliFi HD Firmware v3.3.0

  • /edit: adding @UI-Brett because everyone seems to 😛

    Anectdotal: I am connected to AmpliFi HD router over ethernet port 2 to a laptop.

    Did upgrade to v3.3.0 ~12 hours ago and all seemed fine. Just 30 min ago I did a test and was consistently seeing ~50Mbps down and ~19Mbps up. Before the update I was seeing closer to 600Mbps/40Mbps. I'm on cable internet so thought maybe just lots of neighbors active now as opposed to 12 hours ago (but shouldn't affect down) and not much running on my network at both times.

    I reverted to v3.1.2, almost as soon as update was finished I did and get 620Mbps down and 13Mbps up.

    Is there a known issue with ethernet performance on v3.3.0?

  • I’m having very strange issues since last days when I update fw. Cant browse sites when connect on WiFi , chats apps work , can’t access to App Store and Spotify can’t update playlist to. On Pc connected via cable works fine
    Other problem is today I reboot amplifi hd and after reboot display stay always on and no hours show on lcd. I think I have to reset don’t know
    Ps: connect vpn on my iPhone I can browse everything

  • @UI-Brett thank, I did, and then gave it a try back since the updates showed up again. This time, it worked fine. Thanks again.

  • So, I would also like to confirm, pretty much all (most) of the problems people raised in here, on the update. Couple of days after I did updated, I haven't actually noticed much issues, but then:

    • Mesh AP started too loose connectivity with the router HD
    • Main HD router started to act strange (loosing connectivity to the ISP modem)
    • strange up & down speed variation
    • completely loosing internet connectivity for seconds up to minutes sometimes

    Now, thing is I was running all the pre-production (RC's) before, without noticing any of those problems.
    The update to the final version was smooth, at first.
    Why do I say at first? Because for couple of hours (I think it was until the next day), until some small connection problems come up. Then i decided to do a full factory reset for all the devices which compose my mesh network (1 HD, 1 RAMP and 3 Mesh AP antennas).

    I might, as others are suggesting too, to revert to the last version I was using (which for me would be the last pre final version, so the last RC).

    Those would be the updates I can share after (if I'm not wrong), 2 weeks of using the production version of this firmware release.

  • Hi @UI-Brett & @UI-Karlis - v3.3.0 appears to have broken HW Teleport WiFi

    Please see this thread...

    Can you guys help?

  • @Virgil-Nicolae said in AmpliFi HD Firmware v3.3.0:

    Then i decided to do a full factory reset for all the devices which compose my mesh network (1 HD, 1 RAMP and 3 Mesh AP antennas)

    After the reset, you were still experiencing the issues i'm assuming?

  • @UI-Brett yes, still persists

  • @UI-Brett Another test I've done yesterday:

    • connected a laptop directly to the ISP modem (Cat6) and ping for which I got an aprox reply time of 5-7 ms.
    • connected the things "back to their daily state": ISP modem -> Amplifi router. Connected the laptop again, using the same cable and ping google again. First try, ping time 8-9 ms. Second try (seconds later), ping time 18-20ms.

    And those 18-20 ms is now my normal, on a daily basis. All cables are Cat6 (with a few patch ones which are 5e)

  • @Virgil-Nicolae said in AmpliFi HD Firmware v3.3.0:

    Mesh AP started too loose connectivity with the router HD

    I'm having the same issues as you are describing.
    Now I did a roll-back to 3.2.1 and now things are stable again.
    I never learn, updating major version like 3.3.0 before there is an version like 3.3.1 is not the smartest thing to do.

  • @Kent-Husvik Thank you for confirmation and the information 🙂

  • @UI-Brett

    I just wanted to log my issues that I had with the v3.3.0 firmware.

    I have been working from home (like a lot of the world at the moment) for a week without any issue connected via RDP back to work. This is with an ethernet cable connected to a desktop computer so removes any issues regarding WiFi performance etc.

    I got the notification about the firmware update and applied it on Saturday and it seemed fine for general day to day usage and I hadn't noticed any issues.

    Monday I connect back to work and anything between 5 - 10 mins I get a slowdown and the connection drops to the "reconnecting screen". This happens consistently.

    As I have a Gamers Edition I put it into low latency mode and this cures the problem - so @Virgil-Nicolae comments about erratic ping times may have some bearing on the issue.

    To test whether changing mode did resolve the issue and it wasn't just a coincidence I put it back into Throughput mode and the constant drop outs started again.

    I don't want to keep the router in low latency mode as it effectively halves my bandwidth (I'm on a 200mbps connection) so I downgraded to 3.2.1 and this has eliminated the problem.

    So there does seem to be some issue with the v3.3.0 firmware.

  • @UI-Brett im told by one of your colleagues that it is not possible to give mesh points DHCP reservations... and that they can only get DHCP addresses.

    I'm sorry if I find that rather an absurd response. If a client can get a DHCP dynamic address, it can get a reservation... the process is the same. I've been doing this for 20+ years, i know my way around a DHCP server and reservation... and I know this worked, so why does it no longer work?

    Some of the odd decisions that are being made for these devices are beginning to make me wish I hadn't spent over £500 on the hardware.

    No ability to manage the devices other than with an app? I get that they are consumer level plug and play, but how difficult can it be to expose the underlying OS for those that know how to manage these things?!

  • @Ian-Webber Hello, Do you have hardware NAT enabled?

  • @Dainis-Jonitis and @Ian-Webber

    I don't have the Gamers Edition (AmplifiHD) and had reverted to 3.1.2 but am also experiencing slowdowns and dropouts every so often -- more prominent yesterday.
    Unsure if the dropouts could be remnants of 3.3.0 configurations?

    Was in video conference calls and probably 6-10 times throughout the day my ethernet-connected laptop had total dropouts of internet connectivity. The dropouts lasted about 70-90 seconds each time. Sometimes the dropouts occur less than 5 minutes from each other and other times it goes unnoticed for a couple hours in between (although I'm not sitting at computer straight during that time so it's possible dropouts occurred without notice).

    Last night I did enable hardware NAT (did not have it enabled previously), so maybe that will help.

    I just did another test.
    This time once from my iPhone 11 Pro simultaneous to my ethernet connected laptop.
    iPhone 11 Pro: 120Mbps down; 9ms unloaded latency; 33ms loaded latency; 12Mbps upload. (sample was 90MB down and 20MB up).
    1Gb Ethernet: 88Mbps down; 118ms unloaded latency, 113ms loaded latency; 17Mbps upload. (sample was 140MB down and 70MB up).

    I haven't yet taken my laptop direct to the modem to compare difference. But just the wild swings between Amplifi's ethernet and wifi seems to not put the sole blame on modem/ISP.

    /edit: iPhone is 11 Pro, not XS as originally stated.

  • @originlly said in AmpliFi HD Firmware v3.3.0:

    1Gb Ethernet: 88Mbps down; 118ms unloaded latency, 113ms loaded latency; 17Mbps upload.

    This test is ran from a hardwired laptop directly to a LAN port on AmpliFi? Or are there any switches involved? Does AmpliFi connect directly to the modem, and what model of modem is in use (Is it a modem/router combo?)

  • @UI-Brett
    Reminder: This is all on v3.1.2 firmware post roll-back from v3.3.0.

    I'm starting to think it's a performance degradation over time (the longer the NIC is up) until perhaps resources get oversaturated which ends in dropouts and disconnects.

    Modem is an ARRIS SB8200 to comcast ISP w/1Gbps down plan.
    Modem connected to AmplifiHD via a Cat5e patch panel from Monoprice (7299).
    Then Port 2 on AmplifiHD to my dell thunderbolt docking station (TB16) via cat5e cable.

    This has been my setup for the last 2 weeks or so unchanged.

    Now for this testing, I have:
    (A) Dell XPS 9370,
    (B) Dell TB16 dock,
    (C) Macbook Pro 16",
    (D) 1GbE adapter (Dell DA200, USB-C to various ports).

    On (C) Macbook:

    • Wifi: 280Mbps down; 14ms unloaded latency; 28ms loaded latency; 27Mbps up
    • Using (D) on (C): 990 Mbps down; 15ms unloaded latency; 29ms loaded latency; 24Mbps up

    This caused me to think it's device (B) dock.
    Used (D) adapter on my (A) Dell, saw 540Mbps down; 10ms unloaded latency; 18ms loaded latency; 16Mbps up.

    I then changed from (D) to (B) TB16 dock on (A) and saw 600Mbps down; 10ms unloaded; 19ms loaded; 20Mbps upload. As I was typing this, my connection dropped on (A) (hardwired via B) -- so perhaps 3-5 minutes after reconnected to network. Just ran a test on (A) with (B) post re-connect and I'm back up at 580Mbps; 11ms unloaded; 10Mbps up.

    So I'm not quite sure where the culprit may be.
    The only true lesson is that my (C) MBP16" with (D) adapter can scream if conditions are met 🙂

    And for kicks I just did (A) with (B) and got 880Mbps down; 13ms unloaded; 15Mbps up.
    So it seems all my devices can be OK.

    All of these tests are done without removing any devices from the network (wifi or LAN) except obviously switching where the cable plugs into and disabling wifi on the same devices.

    All of my previously posted tests were using (A) and (B); along with my cell phone as I assumed cell phone on wifi should be less than the hardwire so that was my one method as a control (is it my ISP or something on my LAN). (Cell phone is iPhone 11 Pro, not XS as originally stated in previous post.)

    Not sure where this leaves me, but hopefully something from above helps a little for someone.

    /adding: Cabling from modem to patch to amplifiHD are unchanged and stable. Cable used from AmplifiHD to the endpoint is also unchanged and stable. Only difference is on which port/adapter I am plugging the same cable into on an endpoint.

  • @originlly Just to clarify, prior to updating to v3.3.0 you experienced none of these issues? then even after rolling back the performance issues did not correct themselves? This makes me feel like it does not have to do with the FW update, because rolling back would eliminate all changes, which in turn should correct everything. I have not face an issue where a rollback faltered or did not return all values, but a solid way to test this would be to perform a factory reset on the AmpliFi HD, which would start everything fresh on v3.1.2 since that's the current FW.

    Before doing that though, I would ask that you generate a support file from your AmpliFi after running a few of these speed tests (As well as a speed test in the AmpliFi app) that way the data is captured and we can review to see what may be causing this.

  • @Dainis-Jonitis Hi, yes I do have hardware NAT enabled.

  • @UI-Brett - I updated and all went well but noticed that all my hardwired devices were no longer receiving DHCP assignments. The weird thing was that WiFi based assignments were still working. I tried restarting the router and hardwired devices, tried to force a DHCP request, tried static IP assignments - nothing would work. I do have a few switches connected to the router but don't think that should be an issue. I rolled back to 3.1.2 as I have a lot of hardwired devices that just stopped working and am up and running again.

  • @UI-Brett To be honest I'm not positive whether these hardware LAN issues were present beforehand or not.

    Looking back I don't recall having the disconnects/dropped connectivity prior to v3.3.0 nor the performance issues on both wifi and ethernet. But I also wasn't conducting intermittent testing -- though to be fair, there was also no observed issues which made me want to do speed tests and comparisons between devices.

    In day-to-day (prior to 3+ weeks ago) I only had my patch and a downstream old wifi router in use for its LAN ports and also a separate switch. Not much high bandwidth demand.

    It wasn't until post v3.3.0 update that I really noticed the disconnects and performance degradation. It was almost immediately noticeable but I figured I'd give services a bit to settle and see if it corrects itself. When it didn't, that's when I stumbled on this thread and decided to do speed tests testing before and after revert to v3.1.2 to see if amplifihd was really a kink or just my ISP was having issues. That's where post #82 came to and I decided that something did affect my performance on v.3.3.0.

    The disconnects on LAN from my work laptop I just figured was something odd with my OS or GPO configurations going on and off VPN until Ian's post (#92) described similar behavior and where it struck a chord with what I was seeing too.

    After upgrade to v3.3.0 I did change device icons and changed a couple settings prior to reverting to v3.1.2.

    I'm a little hesitant to do the factory reset just because so much depends on internet at home right now (stay-in-home and work-from-home directives). But may do so in the evening at some point.

    I did generate a support file after doing speed tests from 2x laptops both wired and wifi along with iPhone speed test. How is best to get the support direct to someone that can tie it to my comments here?

Log in to reply