AmpliFi HD Firmware v3.3.0

  • @UI-Brett Done full factory reset. Managed to find the hub via the app. Set it to bridge mode (as its just used for wireless access and as an ethernet hub for my study), and we're now back to the same behaviour.

  • @UI-Brett Issue resolved. Reboot of internet router and restart has restored normal service.

  • @Sylvain-Levacher just unplug each device one at a time and the one missing will be identified for you

  • @Mark-Seall which version are you using as I’m still on v2.6.3 and it runs like a champ. But I’m open to anyone who can clearly tell/sell me why I should upgrade? I’d consider it mostly if the security or signal and/or speed was improved.

  • @Neil-O-Keefe could you share any feedback on the new firmware other than it being a challenge to work after the initial install which seems to be every update...

  • After receiving the notice to update on my router, I did so using the iphone app. After several minutes, I received a message to log into my wireless connection because it couldn't be detected. The router showed the introductory screen, and the mesh points just kept flickering. I unplugged my cable modem, then the Amplifi router, then plugged both back in. After several minutes of loading by the router, it eventually found the previous settings. The one mesh point was not detected. I unplugged the mesh point and reinserted, then the mesh point was detected. I notice that status of the mesh points have changed, one used to show excellent, the other good. Now one shows good, the other average. The test speeds are slightly slower than before. Should I have updated using the router instead of the app?

  • Hi, it's really cool that now we can change icons for each device, but I'm wondering if you can add brand logos too, like I currently owns 3 different models of OnePlus devices, but I don't need the icon to shows the actual phone picture but just the OnePlus logo, this way is much easier to identify and you don't need to put extra work to add the actual phone picture, so even the picture is missing people can easily put the brand logo icon on.

  • @Rich-Sammon Hello Rich,
    I do not understand your answer.

    What I'm trying to find out is to which of the 2 routers (Red Circle) is my mesh "Kitchen" unit connected. I don't want to force it to connect to one router more than another. I just want to have the information.

    I know it is directly connected to a router (icon in the blue circle) but nothing in the application gives precise information.

    So, this information is given in the application and I did not find it?
    Or, is it possible to add this information in the next firmware?

    thank you


  • @Sylvain-Levacher ok I have a similar setup and was told the antennas will only communicate to the main router that was bundled together and the additional router that is backboned is not able to talk to the antennas. There is no way to show you this to my using this network since it first came out. Also take notice the antennas are listed underneath your router “Fibernet” that is the one they are all talking to. The backboned router is only used for wired or Wifi connected devices but not the antennas so for best results your Fibernet router should be in a best location for all the antennas to talk to it.

  • @Rich-Sammon Am currently on the pervious version: 3.1.2. I started at 3.0, or 3.0.1 or something last July. Back then it was normal to have to reboot the system once a month. Very frustrating when the Internet just stops working. Since 3.1.2 was installed I didn't do a single restart. Really hope this version is the same and that stability has generally been solved. Obviously there are a few reports of trouble in this thread - just waiting to see if these are mostly edge cases or if we are back to buggy releases again before I update.

  • My Apple Watch disconnects after a while, does not show up under devices.

  • @Rich-Sammon Ok Rich, thanks for your reply.

    @UI-Brett Do you confirm that, the backbone router is not used to link the mesh units?


  • @Mark-Seall Absolutely correct.
    I am not looking to solve for anything, and I am a new Ubiquiti user as of the last month. I don't have the first complaint. So I think I will hold off on the update for now and just monitor.

  • @Ahmed-Ahmede Is it connected to your phone? If so it will drop off from WiFi seeing that it's picking up the needed data through Bluetooth. If you disconnected it from the phone it should pop up back under devices since it's then relying on the WiFi.

  • @Tristan-Baptist Bluetooth is switched off on my phone. It initially appears under devices , then drops off and never appears again unless i reboot my watch.
    I have tried enabling and disabling Bluetooth on my phone.
    Still does not re appear. Disabled Bluetooth from the settings menu. No change.

  • @Ahmed-Ahmede try a 2.4ghz channel change see if that helps try 1,6 or 11.

  • @Edward-Dolezal it connects on 2.4ghz initially, then disappears from the device list.

  • @Ahmed-Ahmede are you running the amplfii as primary router?

  • Yes. AMPLIFI HD with AMPLIFI Instant as a Mesh

  • @Neil-O-Keefe Thank you for working through that and posting your step by step diagnostics along the way. Glad everything is up and working!

Log in to reply