AmpliFi HD Firmware v3.3.0

  • @UI-Brett Everything was working perfectly for weeks until the fw update. 3.3 caused massive network loss. I contacted support, they said try 3.3.1. Still borked. I had to call support to get back on 3.2.5 (I didn’t know about the rollback feature addition at that time (communication) which I’m on now running trouble free.

  • @UI-Brett I looked at roll back, it wants to go back to the rc. Unless I missed an option to pick how far back I want to go?

    Never been good at articulating my issues. Nest cams can be choppy. Speedtests get slower as each day moves forward. I have gig internet and Netflix will buffer. It's strange and very hard to pin point. Even though my mesh point (routers as mesh points) are hard wired, it seems there is a performance hit when connecting to a point vs the router and not a minimal 5ms hit, like a quarter of my bandwidth.

    When I've had problems in the past I've sent logs to support and nothing really comes from it except maybe turn on this feature and see what happens lol

    With hardware nat turned on my wife and I can't use our separate VPN connections lol. Same program, different employers. It will connect, just still not route.

    It actually would be nice for someone to tell us what aqm the HD uses for WiFi clients and how it gives priority to ethernet? How does the 👽 work differently? Is it codel? Cake? Either way I think it might be interfering with the pie on docsis 3.1 modems.

    When I got my new modem my m$ teams started having an issue where the calls would turn to static. When I plugged it in to ethernet and disabled WiFi it was fine again.

    I put my erx back in the middle to cool down the bloat on the wifi but I want to remove all the qos/aqm and try a build that others say is stable.

  • @propheadcity I can supply you with a firmware file to roll back manually to a specific version, but without knowing it will be a lot of trial and error to discover which one you were on, let alone if the issue you are having isn't caused by the update, rolling back might not fix it.

    What exactly is not working when you say massive network loss. Have we gathered support files from your system after a crash to review? If so, let me know the support ticket number and I will look into this with you.

  • @MichaelE said in AmpliFi HD Firmware v3.3.0:

    When I've had problems in the past I've sent logs to support and nothing really comes from it except maybe turn on this feature and see what happens lol

    This may be true, but the files help us on the back end find issues and solutions we can implement on future releases, and sometimes different settings help alleviate the problem without needed a full rollback.
    I don't know the details behind priority whether its cake, codel or other or I will pass that information alone, sorry.

    If you are pretty diligent with updating firmware on every release, I would say lets generate support files from your system on 3.3.0 after you experience the issue, then roll back to the last public FW of 3.1.2.
    I can provide you with instructions and files to your inbox

  • Is a fix happening any time soon? I’m pretty sure a lot of people have sent in log faults to you guys already. It would be nice to update this to full working capability since we all stuck at home and trying to work from home.

  • I am curious if the 3.3.0 version has been getting reported as having poorer performance than the previous version or not? Since upgrading to 3.3.0 performance is much spottier than it was previously. 1_1587512557708_IMG_2.jpg 0_1587512557708_IMG_1.png

    And I also noticed it seemed to dropped to "Average" after updating as well. Any advice on what to do would be greatly appreciated.

  • @UI-Brett I was pretty clear. I’m on 3.2.5. Everything is working fine. There is no problem other the bad communication (like you not reading my post carefully x2).

    Is 3.2.5 the correct current working firmware?

    I have no interest in beta testing your software.

  • @Harald-Striepe 3.1.2 has been great. It even restored function of a flaky HomeKit WiFI switch connection to my detached garage I had blamed on the switch and not the MeshPoint.

  • @Harald-Striepe said in AmpliFi HD Firmware v3.3.0:

    @Harald-Striepe 3.1.2 has been great

    +1 for v3.1.2...that was probably the best release of all time for the HD series

  • Hi @propheadcity - you can find the stable release public Firmware Release Notes here:

    The topic thread that you are currently posting in here is for the AmpliFi HD series routers

    But you are mentioning releases such as v3.2.5 and v3.3.1, which were only for Alien routers

    So it would help to know which router you are actually talking about, and if you are using an Alien, post in the AmpliFi Alien area of the community

    Your original post indicated...

    I'm on 3.25 and 3.3 AND 3.3.1 both borked my network.

    Are you trying to use both HD and Alien routers together?

    Assuming you meant v3.2.5, which never existed for the HD, then how did you obtain "3.3" which never publicly existed for the Alien?

    Do y’all even test this stuff first?

    Yes, there is a small active Beta community
    But for awareness, there has never been a firmware release that I can recall where at least one person didn't have an issue, which can happen on any reboot even without a firmware update depending on how the dynamic wireless environment might have changed, or when clients have updates to their firmware, such as iOS on Apple has broken WiFi in the past

    Everything was working perfectly for weeks until the fw update. 3.3 caused massive network loss.

    Where did you get the "3.3" update and for which router was it intended?
    If you were using v3.2.5 on an Alien, then the next public release was v3.3.1
    If you had an HD, there was no v3.2.5 release, and the HD went from v3.1.2 to v3.3.0

    I contacted support, they said try 3.3.1. Still borked. I had to call support to get back on 3.2.5 (I didn’t know about the rollback feature addition at that time (communication) which I’m on now running trouble free.

    How did you rollback?
    Manually, by downloading the v3.2.5 firmware and installing it from the web interface?
    These appear to be Alien public firmware releases and the automated rollback from the Support web UI hasn't been implemented yet on Alien

    I was pretty clear. I’m on 3.2.5. Everything is working fine.

    Just so you know, v3.2.5 on the Alien has issues that other users are trying to see fixed, so it is not working fine for everyone

    Is 3.2.5 the correct current working firmware?

    Assuming you have an Alien, the latest stable public release is v3.3.1, which works for some, but others are having issues
    It sounds like v3.2.5 is stable and working for you, so no need to update

    There should be an announcement when the next stable release is published after v3.3.1 and you will see a notification on the router and in the app
    AmpliFi uses a rolling release in case issues come up that were not caught in Beta

    I would suggest checking the Update community section for whichever routers you are actually using before ever installing any updates

    If you have an Alien, asking questions in an HD firmware release thread might cause some confusion, and the issues being reported may not apply to you

    I personally usually wait about a month before installing new firmware on any primary routers to see how well a release is working in the community
    For example, my primary Alien has been left on v3.2.5 because I can live with the couple of bugs that I am experiencing, and too many other people have reported issues

    I have no interest in beta testing your software.

    You should only receive Beta release candidates if you enroll for them on the web UI

  • @Derek-Saville opps yup i posted in the wrong place I’m an alien. Anyway thanks for the update. My app is telling me there is an update available but offers no clue what that update is. Ill just hang and wait but please keep us updated better.

  • Hi @propheadcity - if you do click on the update in the app, it should show you the version information to confirm before actually installing

    Be careful not to accidentally hit the UPDATE button the LCD (it would be great if there was a way to disable it)

    I would recommend staying on Alien v3.2.5 until they come out with a new release after v3.3.1

    v3.3.1 does fix some critical issues that uses were experiencing, but seems to have caused others pain, and there are reports of things like WiFi Calling not working for some carriers, which can make WFH difficult

    AmpliFi has indicated they are actively working on a big update for Alien to potentially support things like 160 MHz channel widths, channel compliance and certification for outside the USA, etc., but there is no timeline for release

    And many of us are hoping for things like WiFi-6 upper channel selection, WPA3, WiFi-6 certification, etc.

    Under the current situation though, my personal advice is if your WiFi is working for you, don't touch it...

  • After looking at the 3.3.0 firmware release notes, one thing stands out.

    “ AmpliFi HD, Instant and Gamer Edition

    v3.3.0 (16-Mar-20)

    Icons for devices are now selectable
    Additional SSIDs for each radio can be defined separately
    DNS-based ad blocker incorporated
    Security update (CVE-2020-8597)
    Wi-Fi channels and power limits updated
    Resolved MAC address issue when switching to Bridge mode
    Other minor enhancements and updates “

    AmpliFi never let end users adjust WiFi/wireless power limits of the antennas. This new firmware supposedly adjusts signal power and the common problem most people seem to be having are wireless issues. I have wireless backhaul issues between my Gamers Edition and the single only regular HD that’s setup as a meshpoint (RAMP). My signal strength tanked with v3.3.0 despite none of my hardware physically moving nor environment changing.

    So since there wasn’t an editable option before or after v3.3.0 for antenna power limits. I’m now wondering those of us who updated to v3.3.0 and have issues had our wireless power limits changed, then rolled back firmware and still experiencing wireless issues due to 3.3.0’s power changes carrying over during rollback? There’s no way for us to see what the output power of the antennas were/are before and after. @UI-Brett @UI-JT

  • Downgraded to 3.1.2 and all seems right with the world again. Of course that could be because I restarted everything in the course of doing so.

    I had to downgrade each HD router (I have 3) individually. I had to re-add my ssid and all additional ssids but so far so good.

    I generated a file before (emailed) right after and I'll generate one today and one in a week.

    I have not tried hardware nat with VPN and probably won't yet.

    I disabled all Amplifi prioritization. I disabled my upload smart queue on my erX that is in-between my modem and main HD. However the erX is still in place (not double Nat, transparent - so my HD has the wan IP).

    My Nest cams are streaming good. Netflix has no issues. I am getting better speedtests on WiFi.

    Now we'll both get to work today (both wfh right now) and see how it goes.

  • Wow, glad to see that i am not the only one having problems with this firmware.
    I am experiencing slow downloads and devices getting kicked from my network.
    Unfortunately i can only rollback to 3.3.0 RC6, is it possible to download older firmware files anywhere?

  • Hi @Jacob-Rudolph - generate a Support Info file and send an e-mail or direct chat message to @UI-Brett
    His e-mail address is on his profile page...
    Then they will send you a link to download an older release that you can install via the web UI

  • @Derek-Saville
    Alright, thanks.
    I generated the support info file and send it from the Amplifi app 🙂

  • Hi @Jacob-Rudolph - make sure to e-mail @UI-Brett or directly send him a chat message with a reference to the support file and ask for a link to the previous firmware release

    This will typically get you a quicker response

  • @Tony-Penev Good observation, Ill look into that further.

  • @UI-JT @Tony-Penev @UI-Brett I finally got around to factory reset about 14 hours ago (after downgrading from 3.3.0 and having issues for almost a month) and so far so good (overall). Probably too early to tell and I think I'm in the minority of feeling like problems persisted post downgrade.

    To summarize my various posts in this thread:

    March 27: Upgraded to 3.3.0. Lasted for about 14 hours before performance issues were too much to live with. Then downgraded to 3.1.2.

    March 27: Downgraded to 3.1.2. Speeds 'back to normal' at times, but then began noticing stability issues that were not observed prior to 3.3.0 upgrade. For example, nest cameras not connecting to nest servers either consistently on/off in 30 minute windows before being OK for hours. All the meanwhile, other devices on the network had internet connectivity and the issue wasn't believed to be a Nest server-side issue. As the days went by, there were even times when one nest product couldn't reach server but the other one did. Hardwired devices would have intermittent network drops or numerous packet losses while those on WiFi didn't have a perceived issue (i.e., my hardwired on video call would stutter and tell me bad internet while my wife's wifi video call at same time was just fine).

    A few logs collected and sent to @UI-Brett between then and now. Devs came back with findings from logs:

    • Confirmed: hardwired laptop link goes up and down, but logs don't help answer why (maybe device settings or cable quality)

    • Confirmed: One nest connected to 5GHz router, has good signal and quality and there are device drops but nothing in logs help show why.

    • Confirmed: Second nest was connected to 2.4GHz MP for a long time (then I pulled the MP's because of performance and networking headaches!). Then it goes to 5GHz router, also has good signal and quality and there are device drops but nothing in logs help show why.

    • Observed: Main router's internet interface may be bad connection due to inetchecks occurring. I have my personal doubts on this one as even when doing the router's built in speedtest checks sometimes can't find the speedtest server and yet all devices on network have internet connection just fine and get expected speeds from near the moment of failed in-built speedtest failed connection. But we'll see, could still be a part of it.

    April 22: Factory reset and so far stability issues are no longer observed (only been 14 hours). One of my nests did have a 1-minute or 2-minute disconnect while the other one was fine (based on nest recorded data) that occurred around the 12-hour mark after factory reset. Will keep an eye on that but if it's a 1-2 minute drop every 12 hours that's more livable than the 10-15+ drops in a 30 minute window.

    No cables or movement of wired intermediate devices moved to date. I am going to live with it for now and see if problems develop over time before resorting to moving devices or changing cables out.

Log in to reply