Issue with IPv6 Stateful Autoconfiguration & DHCPv6 in Bridge Mode


  • Hi everyone,

    First of all, thank you for the good equipments are make ! They work pretty well ! 🙂

    I see that all my devices connected in WiFi behind my AmpliFi HD Router have some difficulties to obtain an IPv6 address in IPv6 Stateful Autoconfiguration Mode or DHCPv6 Mode when the AmpliFi HD Router is in Bridge Mode.

    My devices have no issue to obtain an IPv4 address in DHCP but with IPv6, NDP seems to not pass between my device and my router.

    I made some tests with my laptop (HP Elitebook 840 G4) to determine where the issue can be (Router, Router Configuration, AmpliFi HD, Devices, Device WiFi Driver,etc...)

    • First I connected my laptop and other devices directly in RJ45 to my router and they obtained directly a Global IPv6 address that works fine so my router configuration is good.

    • Then, I connected my laptop on the WiFi of my AmpliFi HD Router. My laptop obtained directly an IPv4 address via DHCP but no IPv6 Address. I started a Wireshark instance to capture all the IPv6 traffic on the Wireless NIC of my laptop and I saw that my laptop was sending ICMPv6 requests (Router Solicitation) to ff02::16 but without any reply so it was keeping sending this packet until randomly it get a reply from the router and obtain an IPv6 address. It's the same with DHCPv6. I issued my laptop to renew it's IPv6 lease with the commands ipconfig /release6 "Wi-Fi" & ipconfig /renew6 "Wi-Fi" but it take a timeout.

    • I tried with another different device (iPhone XS) and it's the same. The iPhone get and IPv4 address with DHCP but nothing in IPv6 until randomly it get one. And at the end it don't last.

    • I checked on my router with TCPdump and no packet related to IPv6 NDP / ICMPv6 arrive while the devices are requesting a discover or router solicitation on the AmpliFi physical interface so now I start to believe that the issue is the AmpliFi HD Router.

    • Today my AmpliFi HD Router received the 3.3.0 update so I installed it and I checked again but nothing better related to IPv6. I tried to make a factory reset of the AmpliFi HD Router and I checked back after I put all my configuration and it's the same. IPv6 works randomly. When I enable the IPv6 function in the AmpliFi App, the AmpliFi HD Router get an IPv6 address with a gateway and is routable in 30 seconds. Also when I reboot it.

    So that why I open a case to find the issue and if it's firmware related, to correct it.

    For information, please see details of my equipments

    • HP Elitebook 840 G4 (Device)
      Windows 10 (1909)
      Intel Dual Band Wireless-AC 8265
      Intel Wireless Drivers v20.70.16.4

    • Apple iPhone XS (Device)
      iOS 13.3.1

    • Ubiquiti AmpliFi HD Router (Wi-Fi Access Point)
      Firmware: 3.3.0
      Mode: Bridge
      IPv6: Enabled
      802.11r: Enabled
      802.11k: Enabled
      802.11v: Enabled
      A-MSDU: Enabled
      STP: Disabled

    • Juniper SRX300 (Router)
      JunOS 18.4R3.3

    Thank you for your time and your help. 🙂
    Saldru


Log in to reply