Teleport also works when in Bridge Mode?


  • Hi,

    I can only use the Amplifi HD in bridge mode because I have to use my AVM Fritz Cable 6490 as first router. Will the teleport work with the Amplifi HD Router if this is in bridge mode? Or can I use it anyway with the AVM Fritz Cable router as my first router (wifi is deactivated at the fritz Cable) and then log in in my mesh network?

    Thomas


  • @thomas-frensch Teleport usually works fine with its router in bridge mode. There might be some edge cases where it doesn't, but so far we haven't encountered them in the wild, and we might be able to fix them if they occur. Most beta testers use this configuration, as they have existing (AmpliFi) setups.


  • The Amplifi app on iOS reports the error "Teleport feature is not supported in Bridge mode" error code: 23.

    This appears to be an intentional block rather than weird edge cases. Any update?

    I have an existing home network comprised of an EdgeRouter and UniFi access points. I am trying to set up an Amplifi HD in bridge mode to allow teleport to a remote site where an Amplifi HD is setup as network router.


  • Hi @michael-richmond - will the AmpliFi router only be used for Teleport access to the remote network?

    If so, you can run it in DHCP mode and Router-to-Router Teleporting should still work through the double NAT


  • @derek-saville Yes. The Amplifi HD is only to be used as tunnel to the remote network. (Remote family IT support.)

    I am attempting to setup the Amplifi HD configured for DHCP. The Teleport connection is failing to establish. It looks like I will need to setup a port forwarding rule on my EdgeRouter to allow the teleport connection to complete.

    Can anyone tell me which ports teleport uses so I can set up this forwarding rule? (Plan is to configure my EdgeRouter to serve a static address to the Amplifi HD.)


  • Hi @michael-richmond - can you confirm you have AmpliFi routers at both ends?
    And what type of device do you want to Teleport from your local network to access the remote family network?


  • Remote network:
    Internet -> ISP Router -> Amplifi HD (firmware 3.1.2) configured in bridge mode (referred to as "AmplifiAA")

    Local network:
    Internet -> EdgeRouter -> UniFi AP -> Amplifi HD (firmware 3.1.2) configured in DHCP mode (referred to as AmplifiBB)

    With an iPad connected to the UniFi access port the Teleport app works to access devices connected to AmplifiAA.

    With a laptop connected to AmplifiBB via WiFi, I can access webpages on the Internet. (Confirming that AmplifiBB is configured and doing basic traffic routing.)

    I used AmplifiAA to generate a Teleport Code eg "TC1234".

    The laptop connected to AmplifiBB I go into the Amplifi app for AmplifiBB, from the "Famliy" tab I select the laptop and use "Teleport to remote router" to enter the teleport code "TC1234". This results in a status of "connecting" that never completes the connection. (Allowed 15 minutes to establish connection.)

    AmplifiAA and AmplifiBB are registered with different remote access accounts on ui.com. I am assuming there is no need for these devices to be on the same remote access account.


  • Hi @michael-richmond - thanks
    I was actually messaging @UI-Brett earlier today about some issues with router-to-router Teleporting and errors I was receiving regarding Bridge mode and establishing connections

    I believe they are having an issue with the back-end systems and he said he would look into it tomorrow and get back

    I would suggest waiting for his update and maybe send him a DM as a reminder referencing this thread


  • @derek-saville Thanks.

    I found your separate thread that reports a setup like I am attempting does work.

    Once Ubiquiti have their backend systems stable I have three other ideas to explore if I continue to have issues. In order of preference:

    1. set up static port forwarding on EdgeRouter if I can identify the inbound teleport ports.
    2. enable upnp2 on the EdgeRouter (not sure if this is a default service).
    3. prepare a DMZ on the EdgeRouter for the AmplifiBB.

    Ultimately, the Teleport hardware device (or a Teleport App for OS X) would be ideal for my use case. I'm chasing this route because the Teleport hardware is discontinued and an Amplifi HD is less expensive than the Teleport hardware.


  • @michael-richmond - I will let you know if I hear anything from @UI-Brett as well
    I was seeing the issues after updating to an Alien and I wasn't sure if the problems were Alien specific at the time, so thanks for confirming your setup and what you were attempting to do


  • @michael-richmond said in Teleport also works when in Bridge Mode?:

    I am trying to set up an Amplifi HD in bridge mode to allow teleport to a remote site where an Amplifi HD is setup as network router.

    Your topology described should be working, the only bridge mode limitation I have found (and tested) is is your remote location is placed into bridge mode, it will not work.

    Both routers do not need to be configured on the same remote access account, all that does is make it so you do not have to generate a code to Teleport, you can just simply select one of your registered networks.

    By generating a code on the home network (which is in bridge mode) then using the code on the remote network (NAT) you should be able to make a connection. I just performed this exact test and Teleported a Nintendo switch.

    In this situation, I would suggests attempting to make the Teleport connection, and when it fails generate support files from your remote router and home router if possible so we can identify what is causing the connection to fail.


  • @ui-brett I have captured the support bundle from both routers (attached to this post).

    AmplifiAA (Bridge mode behind a SpeedStream 4200 ISP provided router) is in Australia.
    AmplifiBB (DHCP mode behind an EdgeRouter) is in the USA.

    0_1578457211830_SupportBundles.zip


  • Not to hijack this thread, but I can report the Android version also errors out with "Teleport feature is not supported in Bridge mode". I am using an Amplifi Instant w/latest firmware and app.

    I use a VPN router and want to avoid double NAT, so only want the Instant for wireless mesh and (especially) Teleport. I plan to use Teleport device-to-router only, not router-to-router. They obviously coded this in intentionally, so maybe it causes known faults? I'm using it in router mode and just ignoring the double NAT, and Teleport is working, but it's a dirty way of doing business. Will this be fixed/enabled later?


  • @steve-zeppi Using device to Amplifi (in bridge mode) definitely works using iOS on the latest firmware and apps (Amplifi WiFi and Amplifi Teleport.)


  • There is no restriction on the home AmpliFi router where you are trying to Teleport to - both bridge mode and DHCP NAT mode are fine

    So the Teleport App always works

    If you are going to use an AmpliFi router at the remote location for a router-to-router connection, it must be in DHCP NAT mode, either as the primary router, or double NAT’ng behind another router


  • derek-saville: "If you are going to use an AmpliFi router at the remote location for a router-to-router connection, it must be in DHCP NAT mode, either as the primary router, or double NAT’ng behind another router"

    Is this a new requirement? In this thread, my target Amplifi is in bridge mode behind an ISP-provided router. iOS Teleport app is working in this configuration.


  • Is this a new requirement? In this thread, my target Amplifi is in bridge mode behind an ISP-provided router. iOS Teleport app is working in this configuration.

    Hi @michael-richmond - sorry for the confusion
    The “target” AmpliFi router is what I was referring to as the home router (the one you want to Teleport to) and it can be in either mode = no restrictions, so the Teleport App should always work

    Your terminology is much better

    For router-to-router, the AmpliFi router you are initiating the connection from (not the target router) must be in DHCP NAT mode


  • @derek-saville said in Teleport also works when in Bridge Mode?:

    For router-to-router, the AmpliFi router you are initiating the connection from (not the target router) must be in DHCP NAT mode

    Ah Ha, I thought. I have two AMPLIFI HD, both running latest firmware. One is at home, in bridge mode behind an edge router X doing DHCP. Call that one Home router. The other is traveling with me and is setup to provide WiFi and uses dhcp to get it’s WAN network from the router wherever I am. It did not have hardware NAT enabled, so I just turned that on. Call that the remote router. Either way the hardware nat is enabled Or disabled, I get the same result. Devices on the remote router get internet connection ( and one of them is able to software teleport, but that’s another story, useful here to indicate that ports are probably not being blocked). Whenever I click on any of the client devices from the remote management and proceed to teleport to the home router, it gets so far and then stays “please wait, connecting” info screen, forever. No timeouts, just stays that way. From the main screen the teleport icon is blinking blue.No info fields for the Teleport are filled in. Now on the home router management I am able to see the teleported client and it has been assigned IP information. The remote device now has no internet connection. So, the teleport is partially setup but not completely.


  • Hi @wayne-wilson - you might have a similar issue as @Michael-Richmond in this thread, where using a target (home) AmpliFi router in Bridge mode behind an EdgeRouter is failing to make a router-to-router Teleport connection, so the same problem probably occurs with the Teleport App too

    @UI-Brett requests that if you can, attempt the connection, and after it fails generate a support file for the home target router and email it to him at BRETT.BENNETT@UBNT.COM

    I would recommend also copying @UI-Karlis at karlis@ui.com and reference this thread

    Something on the ER is either blocking the Teleport connection, or not enabled thus preventing the connection

    You may also want to post a message on the Ubiquiti Community forum, as it is likely an ER configuration change needed, such as maybe enabling UPnP


  • @derek-saville OK thanks. I did that. 2 curious things that may be of interest. In order to get the support file you either need apple mail setup or be able to go the local IP of the router. Since I don't have apple mail setup and wont' do it, for reasons too long to explain, I needed to go to the local interface. But, how could I do that without a VPN. If you remember from above, curiously, only my ipad can run successfully the teleport app, so I was able to access my local lan and the home router to generate the support file.!


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.