Teleport also works when in Bridge Mode?

  • @derek-saville Thanks for the clarification.

    You're right, terminology is complicated when talking about VPN setups.

  • @derek-saville For my setup, I have confirmed that my EdgeRouter does have upnp2 enabled. (This is at the Teleport client site.)

    I have not tried disabling upnp2 and instead enabling upnp on the EdgeRouter.

    I have tried removing the EdgeRouter from the client network. This setup is as follows:

    Client network:
    Internet (Cable Modem) -> Amplifi HD (firmware 3.1.2) configured in DHCP mode (referred to as AmplifiBB)

    With a laptop connected to AmplifiBB via WiFi, I can access webpages on the Internet. (Confirming that AmplifiBB is configured and doing basic traffic routing.)

    I used AmplifiAA to generate a Teleport Code eg "TC1234".

    The laptop connected to AmplifiBB I go into the Amplifi app for AmplifiBB, from the "Famliy" tab I select the laptop and use "Teleport to remote router" to enter the teleport code "TC1234". This results in a status of "connecting" that never completes the connection. (Allowed ~10 minutes to establish connection.)

    This is the same behavior as exhibited with the EdgeRouter in the network. (Client network: Internet [Cable Modem] -> EdgeRouter -> Amplifi HD [firmware 3.1.2] configured in DHCP mode [referred to as AmplifiBB] )

    Observing the same behavior is surprising because:

    1. double NAT is removed
    2. removes any concern with the EdgeRouter configuration

    This may suggest a problem with the VPN handshaking.

    Support bundles for this test sent via email as "".

  • There has been no new information on my problem so I solved it another way. The way I solved the problem was by going outside the AmpliFi world. I purchased a small device Using openwrt with the WireGuard VPN installed on it. I then installed the WireGuard app on all my travel devices, iOS, kindle fire and android and it works just fine. This was so easy to do that I then purchased a small travel router that also had WireGuard on it so that I didn’t have to worry about installations on devices and I could also use tethered to my iPhone over LTE. I think AmpliFi should just drop Teleport and replace it with WireGuard.

  • @wayne-wilson That is exactly what I have done. A couple of cheapo GL.iNet routers and problems solved. Easy setup and working solid with no issues at all.

Log in to reply