Unable to get DHCP or use Static IP in Windows Virtual Machine on Wifi


  • I've been trying to track this down for awhile and think I have it figured out.

    It appears as though the Amplifi HD won't assign IP addresses to virtual machines in VMware. I have even tried assigning a static IP to the virtual machine, and it will work very briefly and then stop. (like after seconds)

    If I changed vmware to NAT, then it will work, but it does not work in bridged mode over wifi. If I plug in an ethernet adapter in the macbook, then the virtual machines have no issues in bridged mode. There are a few messages on VMware forums that say some routers don't assign addresses to virtual MAC addresses, they restrict to just the physical MAC address.

    My question, is this what the Amplifi is doing? To trouble shoot, I took laptop to office where we have Ubiquiti and on Wifi, same exact issue, on ethernet, everything works fine in bridged mode. When I look in the Amplifi app, the virtual machines are never listed. Ping will show them responding just briefly after bootup, then no response. They will occasionally get an IP right after boot, then no response and won't get another IP if trying to do a lease refresh.

    My setup:
    Macbook Pro
    have replicated this in Mojave and Catalina
    VMware Fusion latest version
    Virtual machines, XP, 7 and Win10, same results in all
    Have tried completely uninstalling and reinstalling vmware, and vmware extensions in the virtual machines.
    Have tried static and dhcp assignments in vms.
    Have tried deleting and creating new network adapters in vms.
    Have taken copy of VM that doesn't work from laptop, put on work computer that is on ethernet and it works fine with no issue. (to rule out particular vm issue)
    Have googled extensively with not much results.

    If this is a 'feature' of this networking hardware, I'd just like to know so I can plan accordingly and made adjustments to my environment or get a different router.

    Thank you.


  • @bhyahoo I just recently removed VM fusion from my Mac, so this will take me some time to actually test, however I was never experiencing any issues with my VM's (win10 and server 2019 I believe). My computer was connected via WiFi, but my AmpliFi router was in DHCP mode, not bridged.

    Assigning IP addresses is something AmpliFi will not do in Bridge Mode, maybe for a test you can place AmpliFi in DHCP creating a double NAT and see if IP's get appropriately assigned?


  • @UI-Brett

    My VM is set to bridge mode, not the Amplifi. I don't have any other issues with any other devices on my network receiving dhcp addresses from the Amplifi.

    When I say that everything worked fine on ethernet in bridged mode, I mean that the vmware vm was set to networking bridged mode, the mackbook was plugged into an ethernet adapter to the amplifi and only in that config would the Amplifi give out a dhcp address to the vm.


  • @UI-Brett Were you able to test this functionality?

    I recently upgraded to Ubiquiti and for some reason my virtual machines (VMWare Fusion 11.5.3) are no longer able to get IP addresses via DHCP when connected to my AP-nanoHD.


Log in to reply