Chromcasts no longer connecting after firmawre update


  • Hi,

    I have a set up of 4 AmplifiHD's (1 router, 3 mesh points). Everything always worked fine, chromecasts never had an issue connecting or streaming. After the last update (3.3.0), that is no longer the case. Chromecasts & my xbox one x can no longer connect to the Mesh wifi. All other devices have no problem (laptops, smartphones, tablet, hue bridge, Heos speakers ...).

    I have factory reset all Amplifi HD's, reset my chromecasts, restarted my phone & tablet before fresh chromecact setup, used only the amplifu HD router without any meshpoints, all to no avail...

    The chromecasts have no problem connecting to the integrated wifi directly from my ISP modem.

    I have no clue what is going on and don't seem to find anything similar online.

    Any help?
    Thank you!
    Lansen


  • @LansenW Can you connect it to the Guest network or an addition ssid if you create one? See this for more help on creating SSIDs: https://help.amplifi.com/hc/en-us/articles/360010201854-Configuring-SSIDs


  • Hi @UI-JT ,

    Thanks for the reply.
    so, I set up a guest network and tried to connect to no avail.
    I also created an additional ssid on the meshpoint, with no success.
    What is really werid is that if worked fine before, and all other devices (smartphones, tablets, Philips hue bridge, laptops) connect just fine. It is only the chromecasts and Xbox that can't connect.

    Really in the dark here... Any other suggestions?
    Thank you!
    Lansen


  • @LansenW Can you shut off all the hue devices? Some users have had issues with connectivity when using hue.


  • So, I did a complete factory reset of all routers and started the installation from scratch. Everything is back online, xbox, heos speakers and chromcasts connected immediately without problems. Still have no idea why it happened.

    thanks for the support!
    Best,
    Lansen


Log in to reply