Router keeps alternating between "OK" and "no internet connection"?

  • My Amplifi keeps alternating between normal operation and displaying this message: No Internet connection. Please contact your ISP. When clicking "diagnose problem" in the app I get this message (translated from dutch it says: check IPv4-configuration)

    Funny thing is: internet seems to be fine. When I go to '' sites on my phone I see my public IP from my home (which confirms I'm on the WiFi and not connected via LTE or something). I've opened a continuous ping to the amplifi router: 0% packets lost, the amplify is responsive and online. Another continuous ping to also confirms no connection issues.

    ping -t
    Pinging [] with 32 bytes of data:
    Reply from bytes=32 time=5ms TTL=55
    Reply from bytes=32 time=5ms TTL=55
    Reply from bytes=32 time=5ms TTL=55
    Reply from bytes=32 time=5ms TTL=55
    Reply from bytes=32 time=5ms TTL=55
    Ping statistics for
        Packets: Sent = 310, Received = 310, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 5ms, Maximum = 7ms, Average = 5ms

    ping -t <LAN IP OF MY AMPLIFY>
    Pinging <LAN IP OF MY AMPLIFY> with 32 bytes of data:
    Reply from <LAN IP OF MY AMPLIFY>: bytes=32 time<1ms TTL=64
    Reply from <LAN IP OF MY AMPLIFY>: bytes=32 time<1ms TTL=64
    Reply from <LAN IP OF MY AMPLIFY>: bytes=32 time<1ms TTL=64
    Reply from <LAN IP OF MY AMPLIFY>: bytes=32 time<1ms TTL=64
    Reply from <LAN IP OF MY AMPLIFY>: bytes=32 time<1ms TTL=64
    Ping statistics for <LAN IP OF MY AMPLIFY>:
        Packets: Sent = 432, Received = 432, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 2ms, Average = 0ms

    So I'm thinking the Amplify uses something like to 'ping' and test if internet connectivity is OK and that is experiencing trouble or something.

    So my question: does anyone know what host the Amplifi uses to determine if internet connectivity is okay? Or if it's not a simple ICMP ping then what method it uses to determine the connectivity? Maybe it's my ISP's route to the Amplifi host...

    I'm looking to fix the alternating display implying something is wrong with the internet connectivity which there clearly isn't. It's been doing this for the past several hours and hasn't (to my knowledge) done this before.

    Full disclosure: I have also posted this on reddit

  • I just spoke with support; the transcript is below:

    Chat started: 2017-11-12 02:37 PM UTC

    (02:37:08 PM) Rob Janssen: Router keeps alternating between "ok" and "no internet connection"?
    (02:37:14 PM) *** Ron T joined the chat ***
    (02:37:21 PM) Ron T: Hi Rob.
    (02:37:24 PM) Rob Janssen: Hi! I just posted this:
    (02:37:31 PM) Ron T: Welcome to the AmpliFi Support!
    (02:37:45 PM) Rob Janssen: But then I noticed the chat being online. So I was hoping for a "quick answer" 😉
    (02:39:53 PM) Ron T: It might be due the ethernet cable not plugged well on the WAN port of the AmpliFi.
    (02:40:15 PM) Rob Janssen: Nope, because I keep a connection over WiFi to the internet just fine.
    (02:40:29 PM) Rob Janssen: That's all explained in the post.
    (02:40:55 PM) Ron T: Just give me a moment.
    (02:41:03 PM) Rob Janssen: Take your time 😉
    (02:42:08 PM) Ron T: May I know are you getting the same issue as mentioned in the post?
    (02:42:45 PM) Rob Janssen: I made the post.
    (02:42:54 PM) Ron T: Okay
    (02:43:15 PM) Ron T: Please check the software version on the App.
    (02:43:44 PM) Rob Janssen: 2.4.3
    (02:43:51 PM) Ron T: Okay.
    (02:44:28 PM) Rob Janssen: Has been on 2.4.3 for a few weeks now IIRC
    (02:44:58 PM) Rob Janssen: Beginning of November.
    (02:45:03 PM) Ron T: Have you faced this issue before upgrading this firmware?
    (02:45:15 PM) Rob Janssen: Nope.
    (02:45:23 PM) Rob Janssen: But also it's been doing this since today
    (02:45:30 PM) Rob Janssen: HAsn't done it before
    (02:45:42 PM) Rob Janssen: and I've been on 2.4.3 since at least a week now.
    (02:45:44 PM) Ron T: Do you have AmpliFi Kit or just the router?
    (02:45:54 PM) Rob Janssen: Router + 2 mesh points
    (02:46:37 PM) Ron T: I would request you to please hard reset the AmpliFi device including the Mesh points and then reconfigure it.
    (02:47:09 PM) Ron T: Sometimes, we need to hard reset the AmpliFi device after the firmware upgrade in order to remove the bugs.
    (02:47:17 PM) Rob Janssen: Seriously? I'm pretty sure it's just experiencing trouble connecting to or something.
    (02:47:27 PM) Rob Janssen: It works fine. Internet is fine. Everything is fine.
    (02:47:39 PM) Rob Janssen: It's just displaying this message alternating to the "clock"
    (02:48:04 PM) Ron T: Yes, you are right but the display shows this error even the internet works fine.
    (02:48:16 PM) Rob Janssen: I'm quite sure it's just a routing problem to wherever it tries to connect to see if the connection is OK.
    (02:49:09 PM) Rob Janssen: All I'm looking for is the answer to: what exactly does it do to determine if the connection is OK?
    (02:49:16 PM) Ron T: There is no advanced configuration in the AmpliFi router for the Routing to modify.
    (02:49:24 PM) Rob Janssen: I know
    (02:49:38 PM) Rob Janssen: I'm thinking a routing problem from my ISP, not the amplify.
    (02:49:50 PM) Rob Janssen: I'm trying to figure out what causes the message.
    (02:49:51 PM) Ron T: You can send us the support file so that I can forward to the Tier 3 team and they will be able to check the logs.
    (02:50:15 PM) Rob Janssen: So you can't tell me what exactly it does to determine the connection is OK or not?
    (02:50:51 PM) Rob Janssen: All I want to do is try to reproduce and see if the problem is with my ISP.
    (02:51:08 PM) Ron T: Sorry, we won't be able to tell you the exact issue unless we will not check the Support file of your device.
    (02:51:50 PM) Rob Janssen: I am not looking for you to solve the/any issue. There is no actual issue besides the display telling me there's something wrong with my connection.
    (02:52:10 PM) Rob Janssen: All I'm looking for is: what does the amplify do exactly to determine the connection is OK or not?
    (02:52:43 PM) Rob Janssen: I can send you the support files but that doesn't answer the question nor will a level 3 support team be able to do anything usefull with it
    (02:53:19 PM) Ron T: You can try by changing the ethernet cable which is connected to the WAN port of the AmpliFi device and check if it still shows that message.
    (02:54:09 PM) Rob Janssen: The problem is NOT in the cable since WiFi keeps working just fine. Please, I've put a lot of effort in the post explaining what's going on. There is no connectivity issue.
    (02:55:29 PM) Ron T: Have you tried rebooting the AmpliFi by unplugging it?
    (02:56:11 PM) Rob Janssen: Aw jeez. Sorry, I can't keep going over this. For the love of God, please try to read what I'm saying. YES I have rebooted the device (twice actually).
    (02:56:31 PM) Rob Janssen: And yes, I've unplugged it. Twice too. (So actually 4 reboots)
    (02:56:39 PM) Rob Janssen: I've sent over the support files.
    (02:57:03 PM) Ron T: Thanks for sharing the support file.
    (02:58:15 PM) Ron T: I would request you to please wait for some time. Once the Tier 3 team will check the logs, then they will reply you with the issue.
    (02:58:24 PM) Rob Janssen: Now, please: try to answer this simple single question:
    *WHAT* does the Amplify router do exactly to determine the connection status?
    (02:58:41 PM) Rob Janssen: Does it do an ICMP ping? What host does it (try to) connect to?
    (02:58:56 PM) Rob Janssen: So I can open a ping and see what's going on.
    (02:59:02 PM) Ron T: The AmpliFi router pings the google server to test the internet.
    (02:59:11 PM) Rob Janssen: Finally. Ok.
    (02:59:18 PM) Rob Janssen: That WOULD explain a thing or two.
    (02:59:57 PM) Rob Janssen: Because GMail seems to be experiencing trouble, Youtube loads slow today. So it might be an overal problem with Google's connectivity (in the Netherlands, maybe for my ISP in particular).
    (03:00:48 PM) Ron T: Okay.
    (03:00:49 PM) Rob Janssen: Do you happen to know what host exactly?
    (03:00:58 PM) Rob Janssen: Just Or... or...?
    (03:01:41 PM) Ron T: The AmpliFi pings different google servers, not any particular server.
    (03:02:16 PM) Rob Janssen: Can you clarify "different google servers"? How does it determine which servers? Hard-coded IP's? DNS?
    (03:03:02 PM) Rob Janssen: I'm trying to do a ping from my (LAN connected with UTP) workstation to see if I get the same results over wired.
    (03:03:29 PM) Rob Janssen: I should loose packets in the ping at the same time the Amplifi's display switched to "not connected"
    (03:03:31 PM) Ron T: You can try by pinging
    (03:04:17 PM) Rob Janssen: Yeah, that's not it. I get a ping reply just fine from but the Amplifi is (currently!) displaying the "not connected".
    (03:05:02 PM) Rob Janssen: So you don't have an (actual) list of servers it tries?
    (03:06:01 PM) Ron T: Yes, we don't have the actual lists available of the Google servers which AmpliFi pings.
    (03:06:14 PM) Rob Janssen: Ok, thank you.
    (03:06:38 PM) Rob Janssen: I'll see if I can figure it out myself then. Maybe do some tcpdumps on my gateway...
    (03:06:46 PM) Rob Janssen: Thank you for your patience and help.
    (03:07:35 PM) Ron T: You can report us in the email if the issue got resolved.
    (03:07:41 PM) Ron T: Do you have any other questions I can help answer today?
    (03:08:09 PM) Rob Janssen: Whatever I find out, I will post in the topic I linked to earlier in the conversation so everybody is updated with new info 😉
    (03:08:16 PM) Rob Janssen: No further questions, thank you!
    (03:08:21 PM) Ron T: Okay.
    (03:08:32 PM) Ron T: It was the pleasure to serve you!
    (03:08:39 PM) Ron T: Take care! Bye
    (03:08:45 PM) Rob Janssen: You too! Bye!
    (03:08:49 PM) *** Ron T left the chat ***

    So no clear answer (yet). But I guess it's related with some sort of (local?) outage Google seems to be experiencing today. Before I dig in deeper I'll give it 24hrs.

  • For those interested: I had a response over at Reddit and learned that the Amplifi router doesn't do a 'ping':

    Internet connection message should be translated as DNS problem. What is your DNS server (Internet settings), is this default from your ISP or manually set to some other (primary, secondary)? Hm, what is your region, ISP, interesting if others facing the same issue.

    Here's my response and what I've learned so far:

    Internet connection message should be translated as DNS problem. What is your DNS server (Internet settings), is this default from your ISP or manually set to some other (primary, secondary)?

    It's no DNS problem. I have a OpenBSD gateway that runs DNS, DHCP etc. on my LAN. The Amplifi router is provided the IP of this gateway as DNS and (d'uh) gateway. DNS works fine.

    Hm, what is your region

    Netherlands, Noord Brabant


    Edutel business (Fiber, 200/200)

    interesting if others facing the same issue

    I'm quite sure there are (screenshots for archive purposes). These graphs show the number of reported problems with Google / GMail today (english here). As stated in the transcript: I have been experiencing slow / no loads of Google, GMail and YouTube today. And since Google uses a lot of techniques to always connect you to the nearest server(s) and since the support rep. (finally) mentioned Google being used for the connectivity status reporting I put 1 + 1 together. My experienced "problem" can/could be "local" because of this technique Google uses. And, although I think it makes sense to use Google for this (very high uptime etc.), I do think it's a bit weird to rely solely on Google for this. As said; I wouldn't think it weird to (also) test something like or or whatever as a secondary (or tertiary or...) test before concluding something is wrong with the connection based on solely one test (Google).

    I am looking at my Amplify router since I've been writing this post and the clock has been showing all this time (no mention of connectivity problems). And Google, my GMail and YouTube load fine currently. So I'm 99% sure that was the problem. Saves me of (hard) resetting (and needing to reconfigure etc.) my Amplifi. I will, still, do a tcpdump soon just to find out (out of curiosity) and confirm what the Amplify actually uses for connectivity test(s).

    Update: Here's what I learned from a tcpdump from the Amplify router:

    HEAD /generate_204 HTTP/1.1
    Accept: */*
    HTTP/1.1 204 No Content
    Content-Length: 0
    Date: Sun, 12 Nov 2017 21:24:55 GMT

    So it doesn't seem to do an ICMP ping as reported by the support rep ("The AmpliFi router pings the google server to test the internet.") but does HTTP requests to,, and And it seems to do this at an interval of 15 seconds. Turns out that today Google decided to reply to ICMP pings just fine but not reply (50/50) to HTTP requests. (Update: the problem at Google was confirmed by some network engineers I work with today, 2017-11-13)

    So the next step: whenever I encounter the problem again (the Amplifi router alternating OK / connectivity problem on display), I'll open the same tcpdump and see what's going on then. I'm quite sure the aforementioned HTTP request will then be failing.

    So to be clear: The "issue" has been resolved; internet is (and was) working fine. The display alternating between clock ("ok") and "No Internet connection" was very likely due to some ("local") problems over at Google (or my ISP's routing to Google) or something along those lines.

  • Hello all, I just joined the forums today. I am having this exact same issue!!. My Amplifi router keeps alternating netween "OK" and "no internet connection". What is a bit strange is that when this happens if I plug a device directly into the Comcast router/modem I am able to reach the internet. I am not sure what else to do. Is there an issue with my Amplifi hardware? Thank you in advance for any help.

  • @mark-kosier Hi Mark, can you send us your router support info? Please, collect it soon after the issue occurs, and before any resets or power cycling. You can send it to my email

  • Actually been getting this issue myself, unfortunately it can be over so quickly I can't get a chance to test/ping anything.

  • @ubnt-gunars - I've been having this issue as well, may I do the same if it happens again?

  • @d-t sure, good support info usually lets us resolve issues quickly.

  • @ubnt-gunars - Sweet. I am going to factory reset both units before I do that however, I don't want to waste support time with something I can do myself.

    I would love the ability to back up settings though. I've reset the units enough that it would come in super handy.

  • @d-t Support info is only analyzed by developers.

  • @ubnt-gunars - that's fine and understood. But what I am hoping for in the future is to back up the settings for the router for when we have to do a factory reset as I've had to do more than I'd care to admit during my time so far. I know other users have asked for it and there may be a vote on it, it's definitely got my vote. lol

  • I've had this problem too since today on a cube-type meshpoint connected through an ethernet backbone to the router. Ethernet connection works fine (my Mac is connected to the internet through it), and even Wifi works fine (using my phone to test, I'm sitting next to the meshpoint). But the display keeps alternating between "normal" behaviour and "router has no internet connection".

    Earlier I've been unsuccesful when trying to reach the meshpoint with the Amplifi app - the device is either greyed out, or sometimes I could select it but would then get a black screen saying something like "connection unsuccesful" - the screen disappears too quickly to get a screenshot.

    However, the last couple of minutes I have been able to access the meshpoint via the app and was able to get the logfile sent to my mail. Here it is:

    I've also now done a reboot via the app, but that didn't change anything.

    I've done a firmware upgrade earlier this week to 2.6.1 which seems to be fine for the network overall.

    @Rob-Janssen I agree that the network connection seems to be fine all the time, so I assume it's a bug in the firmware.

    Awaiting your reply @UBNT-Gunars & cheers --Mike

  • @michiel-carpentier Thanks for the logs, according to them your Mesh Point ending with D8A8 is really disconnecting from the main router every couple of minutes. Connections with two other mesh points are just fine. We think issue might be on Router side, therefore please send to me ( support info from your AmpliFi Router. Please do not restart or factory reset the system before collecting support info. Thanks!

  • @andrejs-hanins It's in your mailbox!

    Thanks --Mike

  • @michiel-carpentier Thanks, I responded in email.

  • @michiel-carpentier A follow up to our troubleshooting session over emails so everyone can benefit from it.

    The issue appeared to be an IP address conflict between one of Mesh Points and Onkyo AV receiver. That Onkyo AV receiver seems to have a misbehaving DHCP client which steals an IP belonging to a different device (Mesh Points in this case).

  • Dear Forum,

    Ubiquiti support was simply incredible. They did not relent until the problem was solved. It was without exaggeration the best customer experience I ever had. The problem is indeed solved now, it proved to be an IP address conflict between one of the mesh points and an Onkyo receiver on my network. Everything is running now like a Swiss watch, all thanks to Andrejs and his colleague Dainis. Bravo guys, and thanks again!

    Cheers --Mike

  • I am having the same issue and I also have a Onkyo receiver on my network. I have tried setting the Onkyo receiver to a static IP and also tried to reserve the DHCP IP in the router, but I am still having the same issue. What was the resolution to this issue, so I can try that myself?

  • @zachary-buford @UBNT-Andrey Do you remember the solution to @Michiel-Carpentier issue?

  • i am also struggling with this issue that my two mesh routers are loosing the internet connection - i have a fritzbox and two mesh router backboned via DHCP connected with the blue wan port to my switch. Everything works fine until both mesh routers show no internet connection. i also can not reach the internet from a lan-connected computer - any suggestions?

Log in to reply