WiFi Calling On iPhone's

  • My ISP is AT&T fiber internet which uses a Pace 5268AC residential gateway (RG). I've been having wifi calling issues for months, and just found this post on AT&T support forums which might be helpful. I'm going to try this workaround in the coming days.

    Anyone else had success with these RG firewall rules?


  • This post is deleted!

  • I just purchased an Alien router and satellite pack, and added a second router to the mesh for a 3 piece setup. Right away I started having issues with WiFi calling on my AT&T iPhone 11 Pro (running 13.5.1). I was experiencing calls dropping, as well as a weird situation where my iphone would have full Wi-Fi strength and I was able to surf the Internet and do everything else, but when I tried to make an outgoing call it simply would try to place the call for up to 30 seconds not and the phone would then say “call failed”. During such general periods I was also unable to receive phone calls and people told me that they had called me but it never rang on my phone. The only thing I found that solves the problem was to reboot the mesh point but then eventually the problem would occur again, which makes for a very unreliable system. I am hopeful Amplifi releases a firmware update to fix this WiFi calling issue very soon as I depend heavily on Wi-Fi calling for work from home, otherwise I will need to return these three units which are otherwise great! Unfortunately their unusually short 14 day return policy does not leave Ubiquity much time to fix the problem while I try to do a 30 day comparison to a similar Orbi 6 three- piece mesh setup. At the moment the Orbi6 is delivering superior range and much more consistent WiFi calling (and they have technical support taking phone calls!).

  • @clavav That’s the exact behavior I have. Curious; do you have a public IP showing for your WAN IP or a private IP? Type “what’s my IP” into Google and see if that matches your WAN IP on your main Alien router. I am starting to think that Alien handles UPnP differently for some reason. Maybe it struggles with releasing port assignments or something. Also, do you have more then one phone on your network that has WiFi Calling enabled? If so, check both phones...I bet one is showing WiFi Calling when the other isn’t.

  • @mears148 same issues here. Max sometimes 2/5 phones will connect or show WiFi calling. Just out of curiosity have you tried turning off UpnP? Curios to see if that makes a difference at all.

  • @Tristan-Baptist I have tried turning off UPnP however, my internet uses a Class A private IP for the WAN IP. So because of that, I have a router behind my router that is run by my ISP and therefor, I am double NAT’d and can’t control that. That’s why I’m trying to see if others can verify if port forwarding rules would make a difference without UPnP. Keep in mind that despite the Alien router allowing for multiple duplicate port forwarding rules to different Private IPs, that will not work, and probably create issues because you can’t port forward the same external port more then once. That’s not how NAT works unfortunately.

  • This post is deleted!

  • @mears148 why cant you control that? Cant you put your ISP's modem / router into bridge mode... Search the Googles for bridge mode and the make and model... this will eliminate your double NAT issues...

  • I finally fixed my issue, by turning off DMZPlus mode on my Pace 5268AC. My iPhone Wifi calling audio issues are resolved, and I was having SFTP transfer issues with "stalled" to some of my cloud servers. This actually creates a DoubleNAT on my lan, however my problems are fixed. The DoubleNAT should not be an issue for me unless I start gaming or something. One day I will get a different modem from ATT.

  • @shpider I am operating off of a Wireless Internet Service Provider (WISP) which brings its own set of challenges, but allows me some form of internet access in an otherwise black hole of communication where I live. I have an 80ft tower on my property that provides line of sight access to a Point of Presence (POP) which I don't have access to. That is why I can't do anything about the providers router handing me out a private address if that makes sense. I definitely am aware of running routers in bridge mode, it just isn't in the cards for me here. I have a network engineering background, so I like to think I have tried all that I can from a reasonable perspective as an end user. Still, I am really hoping that someone on the Amplifi Team can figure something out here. I know it is not the provider as the sole issue here, as I did not have this issue running on ASUS routers or Google WiFi previously. I really feel that this is an issue with the way the Alien handles port negotiation with regards to UPnP. I feel like it might be too lax on re-assigning ports or something to that end, where others might do that hand off quicker perhaps. I'm really at a loss here. Hoping someone smarter then me gets to the bottom of this.

  • @mears148 We have been attempting to replicate this with really no success, can you share who your provider is and more detail so we can attempt to replicate this? Thanks.

  • @UI-AmpliFi My provider is iWISP and it is a local internet service provider for rural communities otherwise undeserved by the big players. The whole network is run off of a Ubiquiti Networks set of solutions using air fiber and a set of switches and routers. This is why I chose to get the Alien. I figured all Ubiquiti gear to the house would work more seamless together. I am not sure what information you are requesting specifically. I am behind a Ubiquiti Edge Router which I do not have access or control over, which provides a Class A private IP address to my home router (Alien 2x Mesh). From there, everything is pretty standard.

    I am trying to see if anyone was able to make more then one call at a time using WiFi Calling on both phones, because I am not sure I can explain how that would work, given my understanding of UPnP, in that it cannot open an internal port for more than one device at a given time.

    Outside Call -> Port 5400 (or whatever the port(s) are) on public IP -> NAT to randomly assigned internal port temporarily opened for a destination device

    The issue I see with that is that there is only one public IP to act as a destination for the requested externally exposed port. How can that be mapped to more then one device?

    This is where I think the problem lies. I don't think the port assignments (socket connections) are being revoked after the ESTABLISHED connection is terminated. I would like to know if that is being held on to for a timeout period that is set to be too long. I never seem to have issue with one device. It is always with more then one phone, and one is always connected and then the other is not at that time or will say it is and drop a call. I think one device is locking up that socket connection so other phones can't make a new one for a period of time.

    I hope this is helpful in providing something to investigate at least.

    • John

  • @mears148 In testing we did three calls simultaneously using WiFi calling and had perfect calls, we have also tested using diffrent carriers.

  • @UI-AmpliFi Yea, I have no idea then. It is odd for sure. I just tried swapping out my Alien for my Google WiFi again, and boom...works again. I'm lost.

  • @mears148

    I'm late to this party, having just installed my Alien Router a few days ago. Having stumbled on to this thread, I decided to confirm I had no issues with WiFi calling, but discovered to my surprise that i DID!

    I have an iPhone 11 Pro; my spouse has an iPhone X. Both are running iOS 13.6. If I put both phones into Airplane mode, with both phones set to use WiFi calling, my wife's phone can make calls, but mine cannot.

    Two levels of support staff at T-Mobile were unable to resolve this; they transferred me directly to an Apple Support engineer, who basically had me repeat cycles of "Reset Network Settings," toggling WiFi calling off and on, power cycling the phone, and ultimately I became able to make calls over WiFi from my iPhone 11. When I could not, the phone would post a dialog to the screen every time I tried to place a call stating that no network was available, and that I would need either to join a WiFi network or turn off Airport Mode. However, the on-screen icons and the phone's behavior confirmed that I WAS connected via my AmpliFi router's wireless LAN, it was clear that I could use multiple internet services as well; e.g., web browsing from my phone (at a blistering pace, perhaps because of WiFi 6).

    Ultimately she was able to make my iPhone 11 Pro capable of placing and receiving calls while in Airplane mode and dependent on my WiFi network.

  • I have not been able to get WiFi calling to work on my iPhone 11 Pro Max (iOS 13.6, AT&T is the service provider) while using my Amplifi Alien (Firmware 3.4.1, Comcast is my ISP). Prior to buying the Alien earlier this year, I was using my 2 TB Time Capsule as the WiFi router, and had no issues with WiFi calling. I would really appreciate it if I could use WiFi calling, because sometimes my cell signal isn't the best where I live.

  • This post is deleted!

  • @cmascatello How many iOS devices that use WiFi calling are currently connected and have WiFi calling enabled when you experience these issues? Is it a constant failure, or does it work sometimes?

    You can generate support logs using the mobile app from any device, just please be sure to generate them directly after you experience an issue with WiFi calling. In the email with the support logs, please be sure to include either the MAC ID or IP address of the device facing these issues.

  • @UI-AmpliFi 1 device is in the house (it is under construction, so no bandwidth hogs) and occasionally an iPad is connected too. I had two consecutive failures for the WiFi call to connect. The phone is able to handshake with AT&T enough to negotiate the WiFi Calling handshake, b/c my carrier name does change to “AT&T Wi-Fi” but it can not route or initiate calls.

    I sent two logs in and attached the requested info.

  • Checking in on this thread again. Still having wifi calling issues as well on my AT&T iphone 7 plus. The workaround I've been doing is I have to make phone calls with wifi disabled and then after the call is established I can turn back on wifi and then my call will successfully switch from LTE to wifi.

Log in to reply