WiFi Calling On iPhone's


  • @iamaydo
    I know it’s only a day, but it’s working flawlessly w settings I previously stated. The settings switch flipped to not working to working without a reboot. Let’s see if it holds. Crossing my fingers so I don’t have to change wireless router systems.


  • Back to square one. Not consistently working again:(


  • @Tristan-Baptist I have been having wifi calling issues for some time now and I don't recall what version of the the firmware they began. I have found that on my iPhone turning off and then back on "private address", rejoining the network in the process seems to temporarily resolve the issue. However if I leave the network, i.e. leave my home and go away and return, wifi calling stops working again.


  • I forgot to add something I noticed with my iPhone and wifi calling. When at home I always run my phone in airplane mode. I do this because I wanted to force all traffic to go through my ISP to not only reduce data usage on our phone plan, but because we have poor reception in our area and wanted to ensure calls were always placed through the wifi calling feature.

    That said, prior to upgrading to whichever version that caused the wifi calling feature to begin failing I had no problems. Afterwards and intermittently, while on airplane mode, my phone will report that I must "connect to a wifi network or disable airplane mode to place a call". This is very surprising because when this prompt is shown, it's clear that my phone is connected to the wifi as it shows the wifi symbol in the top right corner and I verify it by checking my network settings.

    Why would the phone instruct me to connect to a wifi network that I'm already connected to in order to place a call using wifi calling?

    0_1619222781220_IMG_0745 copy.PNG


  • @anilnatha https://support.apple.com/en-us/HT204234

    Are you, after turning on Airplane Mode, turning WiFi back on? Every time you turn on Airplane Mode? If not, that might explain the inconsistent behavior.


  • @Matthew-Leeds Yes, wifi is turned on.

    The screenshot in my post was taken today while airplane mode was enabled and while my phone was connected to my wifi. I was visiting websites prior to attempting to make a phone call. When I got that prompt you see in the screenshot, it prompted me to post about it. Just been dealing with the issue all this time.


  • @anilnatha Wifi calling is something your cellular provider supports, for example... when you have bad reception in your area and good wifi you can still get a good connection when calling someones phone number (it doesn't count for whatsapp/facetime/google duo video or audio..) 😉 so callin in airplaine mode with wifi on doesn't work at all!! 🙂


  • @dexx64 Wi-Fi Calling while in airplane mode does work, but you need a Wi-Fi system that actually works with Wi-Fi Calling 😉. See the screenshots below.

    1_1619284079732_6658680A-38C1-4767-8E80-6C6DD5EE24EA_1_201_a.jpeg

    0_1619284079732_CAA52860-9A8D-4505-88D2-1C2192618339_1_102_o.jpeg


  • @iamaydo oh wow, you're right! it actually works!! 🙂 i didn't know that 😄


  • i switched on airplane mode for a"experimental" test... and wifi calling works and stays on, it does not always work but when it works it doesn't go away!! 🙂 so, this Wifi call bug thing is more mysterious than before 😛


  • I am using a ton of iOS devices. Didn’t realize this was an issue with the alien products only. I think I have this somewhat better but I am only on day two of tests. I had to enable port forwarding on all phones to maintain WiFi consistently. Check your carriers - this is tmo: 3 ports not two.

    And someone needs to explain to me why you cannot hve two or more entities with port forwards when it is just a firewall and each device has its unique address to receive etc.

    Firewalls
    IPv4 Address Block: 208.54.0.0/17:
    Port &TCP/UDP
    Description
    Port: 500 / UDP
    IPsec - IKE : Authentication [WFC 2.0]
    Port: 4500 / UDP
    IPsec - NAT traversal : Encrypted voice traffic [WFC 2.0]
    Port: 5061 / TCP/UDP
    SIP/TLS : Encrypted SIP [WFC 1.0]


  • I upgraded my phone the other day to a new iPhone 12 Pro Max, enabled wifi calling and sure enough, even this brand new phone on Airplane mode was complaining that I wasn't connected to a wifi network even though my wifi connection was working fine seconds before and after I attempted to make calls. 😞

    If the issue is on the iOS side, then Ubiquiti should work with Apple on behalf of all of the owners of their hardware to help Apple resolve the issue.

    If the issue is on the Ubiquiti side, they need to step it up and get this matter resolved. This issue has been going on for a year now without resolution.

    Step it up Ubiquiti, I expected more from you.


  • @anilnatha

    I'm not sure Apple wants to work with Ubiquiti...maybe they intentionally are not fixing it to make Ubiquiti look bad. Still pissed the guy left them to start his own company. My two cents. 😉


  • @Phil-Hasseljian I believe this must be an individual or carrier set up issue. My WiFi calling has always worked through my Alien. Every now and then when I read these posts I’ll enable Airplane Mode as I did just now. I’ve never had a problem. I’m on the latest AMPLIFI Alien firmware and ATT is my carrier. I don’t doubt that people are having issues and maybe my set up is so simple, only one Alien, that it just works. But...it just works. Yes iOS does cause problems, 11 was a complete disaster from day one, 13 almost as bad and 14 not much better at first. But no issues with the Alien other than a small problem with a security camera, no WiFi or WiFi calling issues ever that we’ve noticed.

    I have a 12 Pro Max, my wife a XS, and we have a 7 that we use as a house phone. So far, fingers crossed, no
    such issues.

    One thing I noticed this time when I enabled Airplane Mode, I did not have to turn WiFi back on. It stayed on, only the cellular radio turned off. In the past both would go off and I had to manually turn WiFi back on. Maybe the latest iOS maintains WiFi unless you manually turn it off now.


  • @John-Pappas

    I was just playing around BUT, I'm the IT Director at a school and I've deployed a UniFi system. We are in a remote location so MAINLY it is WiFi calling. What I've noticed is this: If the user has an iPhone and has Verizon as the carrier, if the phone get's even a hint of a bar, it will try to use that; if that bar goes away, and one tries calling on WiFi calling, it will not work until they go into Airplane mode, reboot phone, then turn on WiFi connection. I'm on an android device with T-Mobile (the first company to really do WiFi calling on their phones), and it works MOST of the time, with the occasional hick-up in which I just reboot my phone. I think the same issue is occurring though. Sometimes I get just a hint of a bar. I do have it set on Cell preferred due to living off-campus where cell coverage is fine.

    So, I agree completely with you. Another thing I noticed, the same thing here with firmware, the UniFi gear has worked well with WiFi calling on certain models better than others. The UAP-HD's work better than Nano-HD's but once again, this could be due to firmware....they don't share the same version.

    So it goes. My Alien works just fine with my phone....but sometimes sending texts to an iOS user is no beuno....but that's a whole other issue between Android and iOS.


  • iOS 13 and iOS 14 across 4 different iPhones (X, XS, and two 12 Pros) on Verizon Wireless, all of them had WiFi calling issues for me from day one (Aug. 2020). Unfortunately, it took almost a month to narrow down that my WiFi calling issues were due to the router itself (I wasn't receiving a lot of calls during that time, I had a new modem installed too, and went from iOS 13 to 14). From there, I spent months on this community board as well as working with support to troubleshoot the issue. Before upgrading the Alien, my WiFi calling experience has always been flawless in my home with my previous routers for a number of years. The only reason I upgraded is because I was increasing my internet speeds, which my old router being an all in one cable modem couldn't handle, and the older router was experiencing performance/capacity issues as the number of WiFi devices in my house increased.

    Support had me test out some beta firmware along the way and make some changes in the router. At some points of this process around late December, it did appear that the WiFi calling did improve, but it didn't resolve the problem entirely and not to a point I would call reliable. When established, WiFi calling would then continue for a week or more without much issue until you left the house or restarted your phone. Then, you still had to jump through hoops to get the phone connected to WiFi calling. Restarting the phone, airplane mode, forgetting the network, etc. It was never seamless, not even the switchover from cell tower to WiFi (the call would drop instead). Then came an update in January/February and the problem was about as worse as it was on day one again. By March, while support was trying to do everything they can to assist me, I was at my wits end. Both my wife and I work from home and our home has nearly zero cellular service (which wasn't always the case). Between taking work calls and needing a line for emergencies, we couldn't deal with the unreliable WiFi calling capability. I experienced issues on both the 2.4GHz and 5GHz radios ( both WiFi 5 and WiFi 6). My WiFi calling issues were more problematic on 5GHz than they were on 2.4GHz, but still frequent enough to not be considered reliable.

    To make sure it wasn't something that changed at the same time with my carrier, phone, or home, I ended up buying a different router at the beginning of April to test (over 7 months since the problem was discovered). From the moment I finished setting up the new router, WiFi calling has been flawless on that router model. WiFi calling connection establishes quickly, I don't experience any drops, and switching back and forth between cellular and WiFi calling has been seamless. During this time, I was still working with support and they acknowledged the the developers were working on a solution but didn't have an ETA to when that fix would be in place. On top of that, this new router also resolved a couple of other issues I was experiencing with the Alien. Here are some of the other known issues I was battling:

    If using a Philips Hue hub or LiFX smart bulbs, their connection will drop or act sporadic after a power outage or a router reboot. They would not reconnect seamlessly and I would have to power cycle the Philips Hue hub (which is not easy to get to) and each of the individual LiFX bulbs, sometimes multiple times, before they reconnect properly to the Alien router. Turns out the fingerprint capability that Alien uses to identify devices and assign an icon to them is what interferes from their connectivity. Turning that off on the Alien router resolved that problem, great, but at the expense of losing an automated feature the router had (which is turned on by default).

    The other problem that the new router resolved that the Alien router had was if I step too far away from the router with my iPhone (going out into the yard), far enough to have a weak signal but not far enough to drop off the network, the iPhone will continue to have very poor network throughput even when you return to a strong signal area. For example, in the home, I might see between 130-200Mbps on my phone throughout the far reaches of the house, faster when close to the router. When this problem occurs, I would barely get 10Mbps and lots of latency. The only solution was to power cycle the iPhone or leave it disconnected from the WiFi for a few minutes. I don't experience this with the new router.

    After testing out the new router and no longer experiencing the issues I was with the Alien, I decided to keep the new router and return the Alien. It's a shame too because I really wanted to like the Alien router and customer service has been great. It's design and easy to use interface were exactly what I was looking for, but the problems I had with it were overshadowing all the other pros it had. I hope that they do find a solution, and soon, but I just couldn't afford to wait for it to become available. My problems with it were becoming too impacting to my day to day activities.


  • @Virtual-Mirage I can understand your frustration. We live in an area with very poor cell reception. Regardless of carrier. We are in a condo building on the top floor. We can get a weak cell connection up here but on the lower floors they get none. We still see some with older phones standing out in the rain or snow making calls. If it weren’t for the WiFi calling feature we would all be seriously inconvenienced.

    We have not had your issues but I have to admit that if we did the router would be going back to the manufacturer or the dump. This has not been the year for anyone to suffer through issues like this. That’s why I occasionally do the Airplane mode just to make sure I’m not just oblivious to this.


  • @John-Pappas
    Wifi calling still not working reliably on 3.5.2


  • @liggyboy Keep working with their support, there must be something specific to your situation. No issues here.


  • Is everyone here using a mesh setup with Ethernet back-haul? I am wondering if there is a correlation to another issue I will reference below. Possibly a UPnP issue when connected to the mesh point or when roaming. Has anyone tried going to a single router setup to see if connection conditions improve?

    https://community.amplifi.com/topic/4187/port-forwarding-not-working-when-connected-to-ethernet-backbone-access-point


Log in to reply