WiFi Calling On iPhone's

  • @Virtual-Mirage My iPhone did something similar to that a few times, I resolved it by forgetting the network, rebooting the phone, and reconnecting to the WiFi network. I had to do it when I updated to 3.4.3 and again when I downloaded the latest beta. I believe that particular bug began showing up for me around iOS 14.3, try that and maybe also try resetting network settings?

  • I just want to give an update that I am still experiencing issues with WiFi calling on my iPhone 12 Pro, especially if I leave my home and come back. It seems that my phone will have trouble re-establishing a stable WiFi calling connection until I power cycle my phone and/or swap to a different radio (2.4GHz or 5GHz). Odd, that once it has established WiFi calling, it remains pretty stable until I my phone leaves the network coverage area again. This includes going out to run errands, taking a walk around the neighborhood, or even going outside to do yard work. I don't have any issues if connected to other networks outside my home. Has there been any headway on a solution here?

  • I also have sporadic Wi-Fi calling issues. I do find that setting my iPhone 12 pro max to airplane mode for a few seconds and then turning airplane mode off I reestablish a Wi-Fi calling connection.

  • Just adding my issue to the pile. I have wifi calling problems as well. Have two alien routers in mesh configuration. Have 802.11r/k/v all checked as recommended by support. Phone still has trouble maintaining a clean signal. Using VZW-WiFi and Charter Spectrum with 100/15 service. Last system (older Orbi) was troublesome when roaming from point to point. Was hoping these two Aliens would fix it. Did notice that "Additional 5Ghz radio" with the same SSID as my primary was checked on this last reboot. Shutting that off seems to have helped it.

    really hope this gets sorted. I have 14 days left in the return window. So far, love the Alien as far as features and general "slickness" is concerned, but have to have reliable cell for work.

  • I would like to give another update. For over a month I was getting some pretty reliable WiFi calling on my iPhone 12 Pro when having both "Forbid IGMP Proxy Service" and "Forbid Fingerprint Service" checked in the beta options. I disabled the "Forbid Fingerprint Service" due to some known issues with houses using Philips Hue and LiFX bulbs, so whether it made any improvement to WiFi calling is purely incidental. But there are some catches to this.

    First, I only have luck when my phone is using the 2.4GHz radio. The 5GHz radio continues to give me WiFi calling issues. Secondly, if I leave the house and come back home, it does take more than a few minutes before my phone will confirm that WiFi calling is enabled and working properly. So it is not as instantaneous as my older router was and prevents me from "hot swapping" between cellular and my WiFi and keeping the call from dropping.

    Today was the first time I heard my wife complaining of constant dropped calls on her iPhone X. Sure enough, it wasn't holding the WiFi calling and she was on the 5GHz radio. I forced her to join the network on the 2.4GHz radio and after a number of minutes and a phone restart it started to work fine.

    I did notice during these issues that there was a newer firmware update out, 3.5.0rc5 and decided to upgrade to it today (albeit reluctantly). I was on 3.4.3 earlier when the issues above were happening. I can't say much if the newer firmware update resolves my problems since it is still too early to tell.

    Needless to say, this is extremely frustrating. I am going on 6 months now since buying the Amplifi Alien and I am STILL having WiFi calling problems across multiple iPhones. With us working from home and not having a strong enough cell signal to depend on that, this has become way more than just an inconvienence.

    On a somewhat side note of other issues, I have noticed with my iPhone if I stray too far away from the router when on the 2.4GHz radio to have weak, but still connected signal, when I get back to a stronger signal the phone's speed and responsiveness doesn't always improve. After doing this, I have had instances where when I am back within 10ft of the router my response time will be in the seconds (not milliseconds) and my throughput will barely top 5Mbps. To fix the problem, I either have to change to the 5GHz radio and back or restart my phone.

  • So the same day I upgraded to 3.5.0rc5 I noticed a few hours later there was 3.5.0.rc6. I went ahead and updated to that since it mentioned something about iPhone connectivity issues being addressed. I have been on it for about a week and I believe I am still having some WiFi calling issues. Sometimes it works fine while others it just doesn't connect or drops. Just today I was on a call that started as WiFi calling but shortly switched over to regular cellular, which my signal is very weak. At least this time the call didn't drop. Also strange, during this call, my WiFi connection on my phone also dropped. WiFi didn't come back until after the call ended. Shortly after coming back, it showed the WiFi calling was enabled again on the phone. I then made another call and almost immediately WiFi calling dropped, forcing me back over to cellular. At least this time my WiFi connection remained. I am currently using the 2.4GHz radio.

  • We have setup hundreds of AMPLIFI systems over the last 3 years. The issue only happens with the Alien systems.
    We’ve updated everything on the phones and mesh router with the same results. This happens with android and iOS on Verizon and AT&T.

  • happy to read i'm not the only one with this issue 😉

  • @dexx64
    I also find Wi-Fi calling to be very sporadic. One minute I see Wi-Fi calling and the next minute all I see is the T-Mobile icon. And I find that on both iPhone 12‘s’

  • @Craig-Fabian I’ve often wondered what possible issue there is with WiFi calling. Several times I’ve even deliberately gone into Airplane Mode but turned WiFi back on and then placed several calls. Have never had a problem. I did it just now since the newest update was installed on my Alien this morning, again no issues.

    I can only assume it’s because my set up is simple - only one Alien and no mesh devices. My iPhone 12 as well as a 7 and XS have never had an issue. We’re on ATT. There must be some factor that gets introduced once your setup gets more complicated.

  • @Craig-Fabian yes, same thing happens on all iphones that are capable to use Wifi Call, it works great on all other routers i've tested including the amplifi HD router... but unfortunately... there is just a BUG that isn't squished yet in the alien.

    i use a iphone 12 pro with KPN (Netherlands 😉 )

  • Just wondering, with the updates to the alien is it still mandatory to have port forwarding of ports 500 & 4500 to get wifi calling to work? I've never liked having to create port forwarding rules for all my iPhones.
    iPhone 12 Pro Max
    Verizon Fios.


  • @Craig-Fabian I'm curious as well. Initially, I had it set up for each phone in the house but was then told that you can't do that. So then I had it on just my phone but after the more recent updates, I had the port forwarding disabled for a while. I only recently started using the port forwarding again when I was experiencing frequent issues again but I am not sure it really makes much of a difference from my experience on the newer firmware updates. I still experience WiFi Calling consistency problems.

  • I am still experiencing numerous issues with WiFi calling both on the 2.4GHz and 5GHz radios on multiple phones. It appears to be more frequent than before and is becoming extremely impacting to my day to day activities. I've got some very important calls that I am expecting and I am now afraid that there is a chance they will never come through because of the unreliable WiFi calling this router has been providing. Usually it only occurs if the phone has left the network or goes too far where the signal becomes weak. When that happens, WiFi calling will fail to properly reestablish itself and I will get failed calls out and no calls coming in. The WiFi Calling notifier at the top of the phone will disappear too when this happens. But lately it has been dropping out even when I have been on the network the whole time where it will work one moment then not the next. My wife's phone, also an iPhone 12 Pro, recently experienced where any calls going out or coming in will be received and she can hear the other person but they couldn't hear her. Forcing the phone to drop off the network and rejoin the network resolved that issue but took multiple attempts since we were then receiving the failed calls issue. And to state for clarification, this problem existed even when we originally had an iPhone X and iPhone Xs (which worked fine on my older router). Moving to new phones, both iPhone 12 Pros, didn't improve the situation at all and we are still experiencing WiFi calling problems.

    I have been actively working with support but lately there hasn't been any improvements, sending logs almost every few days. They keep having me make changes to the router and I almost immediately am able to see if it helps or not and end up sending more log files to them. They have had me disable my second 5GHz radio, change back and forth from 2.4GHz to 5GHz radios, forget networks, etc. But at the end of the day, while some progress has been made since my purchase of this router back in August, there hasn't been a full blown solution and the problem is still impacting.

    While I appreciate all the help support has been giving, and I do look forward to hearing back from them again soon in hopes to solve the problem, I am starting to get at my wits end here. I may have to look at getting an alternative solution and reaching out to Amplifi about returning this product, unfortunately. While I am past the original return period, I only held out because I was under the assumption that this flaw in the hardware was going to be resolved in fairly short order. And since it has not, it is failing to deliver a crucial requirement as to one of the reasons why I bought this router in the first place. Shame too, because I have been holding out to buying a second Amplifi Alien router to use as a mesh but have been waiting to verify this problem has been resolved first before investing more money into it.

  • @Virtual-Mirage
    I am having similar wifi calling issues on ios. Unreliablity is the norm, even with new 3.5.1 firmware and latest ios updates on iPhone 12s and 11s. This has not been a problem with previous wireless routers (older technology) nor at work where wifi calling works fantastically with a different wireless router system. I would hope the the Amplifi team addresses this ASAP as it makes using this system a deal breaker.

  • So I went ahead and bought a different mesh router in preparation to swap out and see if my WiFi calling improves with it. But before I set it up, I did some reading and saw that one suggestion people with WiFi calling should do is to see if SIP ALG is disabled. If it is not disabled, then they recommend disabling it since it has been known to cause lots of issues for VOIP and video conferencing, WiFi calling included. I don't see this as an option on the app nor via the web interface. How can we check to see if it is enabled or not and how can we disable it?

    This is my last ditch effort before giving up on this router and trying to return it for failing to perform. I can't afford to miss any more calls, especially if they are work related or an emergency.

  • @Virtual-Mirage I think I found a test that is used to determine if SIP ALG is disabled or not and ran it. The results came back as either SIP ALG is disabled or that it wasn't able to determine a result. So, inconclusive.

  • Happy to see I’m not alone here. Spent a LOT of money on 2 AMPLIFI Aliens to upgrade from combo of bt router and google wifi mesh routers. Just ran into the Wi-Fi calling issue having installed alien routers a couple of days ago. Tried every combination of restarting and resetting iPhone before checking out AmpliFi as this was the only thing I had changed. Never had an issue with Wi-Fi calling before and since I live in the countryside with not mobile signal I’m really really annoyed. I mean like blazingly annoyed....grrrrrrr. Ahhhhhhhhhhhh

  • I think I’ve found some success but it’s only been a few hours but WiFi calling via AT&T is working again.

    Changed router settings in amplifi.lan

    To enable ipv6
    Enabled automatic band switching
    Enabled 802.11 r k and v

    All other boxes unchecked in amplifi.lan
    Using multiple Amplifi Aliens with ethernet backbone
    No special wireless bands turned on
    Wireless network with WPA2

    I’ll report back if this still works after a few days.

    Good luck!

  • @liggyboy Unfortunately that’s most likely not going to work. Myself along with many others in this thread have spent months troubleshooting the issue, including every possible combination of settings but none have worked reliably.

    I can tell you for certain I had 802.11k/v/r enabled and it didn’t work. Sadly, it looks like AmpliFi have lost interest in finding a solution. I was forced to buy an eero 6 Pro system to have working Wi-Fi Calling, and it works flawlessly. I still have my Aliens and loved when I had them hooked up, such a shame for a great system to dogged by such persistent issues.

Log in to reply