WiFi Calling On iPhone's


  • @Tristan-Baptist @iwilliamsj @Steven-Tellman We are still researching and testing as much as possible. It seems there is a correlation with iOS devices, and Spectrum ISP. So far in reviewing support files, everything on our end looks normal, but obviously its not working as desired so we will research more with details from spectrum if possible.

    Can everyone please also let me know what apps are you using for WiFi calls? Specific 3rd party apps or native iOS?
    Also, more support files may help, if you could please generate support files for me after you experience the issues (including MMS messages being delayed)


  • @UI-Brett it’s the regular iOS @UI-Brett. This issue only started with the alien. I never had any issue with the HD units using spectrum with WiFi calling. I’m going to attempt cloning the MAC address. That’s the only thing I haven’t tried.


  • @UI-Brett Heya, it's just the built-in iOS WiFi calling, no special app. I'll see if I get a text but not accompanying picture today and capture logs. Thanks!


  • @Tristan-Baptist @Steven-Tellman Can you test the following for me:

    Is the one you're trying to call also using Wi-Fi calling?
    If yes, try to call someone else who is not using Wi-FI calling. Are you experiencing the same issues?
    After that,
    try to create static lease and port forwarding for port 4500 to the iPhones. (each needing to be created individually, I suggest creating a static IP for them as well)
    https://help.amplifi.com/hc/en-us/articles/360017392014-Creating-a-Static-Lease
    https://help.amplifi.com/hc/en-us/articles/219134387-Configuring-Port-Forwarding


  • @UI-Brett it’s experienced wether calling someone with WiFi calling or not with it. I’ll try the static & port forwarding right now then get back to you after


  • This post is deleted!

  • @UI-Brett do I need to restart the alien after? If not I’ve gone over all the steps with 3 iPhones and it’s still catch & miss with the WiFi calling. 2 iPhones will get it and 1 wont. Or 1 will have it and the other two won’t kick over even with the phones in airplane mode.

    I was told this
    You’ll need to verify that UDP ports 500 and 4500 are allowed from WiFi subnets to the internet. UDP 500 is used for phase one of the setup while IPsec encrypted packets are sent over UDP port 4500. Having either of these ports blocked means that WiFi calling will not function.


  • @Tristan-Baptist Im looking into this now, thank you for the update!


  • @iwilliamsj & @Steven-Tellman What DNS servers were / are you guys using by any chance? Just curious if that would play a role in this....


  • @Tristan-Baptist I was using CloudFlare DNS in the beginning and I switch to NextDNS it made no difference which one I used, even the ISP DNS was having issues with Wi-Fi calling from AT&T using iPhones it did not matter which model it was.


  • @Tristan-Baptist I'm on Cloudflare 1.1.1.1

    I haven't had a chance to try setting static routes, making sure my work from home setup works while I'm actually working.


  • Any update on those who were having issues with Wi-Fi calling who have AT&T as a carrier and Spectrum as a internet provider.

    I am extremely lucky to have a spare Alien that I was going to set up at my kids house to replace her horrible Spectrum supplied router. She and her husband are working from home now and need both fast internet and Wi-Fi calling. I don't want to give them better coverage and speed with the superior Alien if they then will then have have issues with Wi-Fi calling...

    My Alien absolutely rocks BTW!!!
    Thanks


  • @T-Russ It's still pretty catch and miss... You can do as @UI-Brett mentioned above & try the port forwarding. That i've tested & helps a little but there's times where it refuses to connect or 2/4 phones will connect to WiFi calling... even when in airplane mode... (I've pretty much started taking conference calls in the car driving now lol). It's prob the only headache with the Alien... other than this I simply love this machine! If they have good service in their area then they shouldn't have too much of an issue.


  • @Tristan-Baptist @T-Russ @iwilliamsj @Steven-Tellman Are all of you experiencing this issues with just one iPhone using WiFi calling, or do you have multiple? I have been testing this with all possible scenarios and i'm still not experiencing any issues.
    I am in a house full of Androids, so only the one iOS device maybe why i'm not getting this issue compared to others? Just trying to gather more and more information for tests.


  • @UI-Brett it's with multiple iPhone devices. Hence why I keep saying it's catch or miss. I believe on an early support logs I sent to you... the devs mentioned that they were seeing on port 4500 being picked up by one device & it changing the port on the other due to that port (4500) taken.

    If i'm home alone it kicks in more frequently... if others in the household are home which is high now due to working from home it's a hit & miss. I've also switched my the router from IPV6 to IPV4 as another test to see if that helps at all.


  • @Tristan-Baptist
    Unfortunately they have spotty AT&T signal at their house. I only just recently explained and set up Wi-Fi calling to them on their iPhones and its helped them work at home. I don't want to then set up the Alien so their children can get better signal for the tablets and computers but then the parents have issues working from home... Crazy!
    Kind of a conundrum...
    Thanks!


  • @UI-Brett Hi Brett, we have two iPhones in our house. Both connect fine to WiFi Calling, but we get missed calls and missed sms messages. It’s not consistent so it’s the worst kind of bug to report 😉

    I have noticed it’s been better lately, so not sure it’s Alien related honestly.


  • I’m having the same issue with att and Verizon iPhones. They both connect to WiFi calling but can’t make calls until turn off WiFi. When in bridge mode it works sometimes.


  • @UI-Brett
    Sounds like more of an iPhone issue to me Brett.. Is it possible to troubleshoot this issue in a house with iPhones???
    Thanks


  • Hey @UI-Brett... I’ve started experiencing @Steven-Tellman Bug today with the missed calls / sms not being delivered unless turning the WiFi off. I’ve successfully gotten 2/4 phones to connect to WiFi calling applying the port forwarding method. Most times I’d have to force them into it when needed by making the phone go into airplane mode.


Log in to reply