Firmware 3.3.0 breaks Ethernet ports


  • Upgraded firmware to 3.3.0 on AmplifiHD, Instant and Meshpoint. Discovered that devices connected via Ethernet using AmplifiHD router were no longer connected and showed the "no internet connection" graphic on the LCD panel.

    Completely reset the entire network (3 AmplfiHDs [1 Router, 2 Mesh w/ethernet backhaul], 1 Instant [ethernet backhaul] and 1 standalone mesh point) pulling one of the AmplifiHDs used as a mesh and reset to make it the router. Reset remaining Amplifi devices and re-established the network. Ethernet ports worked briefly then stopped working so not a hardware problem.

    Worked with support 3 times and finally rolled back to previous firmware version 3.1.9 on all devices. All ethernet ports functioning normally.

    This is a bug in Firmware version 3.3.0. The network was normal until the update to 3.3.0, then ethernet ports stopped working. Swapping HDs acting as the Router resulted in the same issue (not a hardware problem) and rolling back firmware corrected the problem. Network and all devices are operating normally with 3.1.9.


  • @Charles-Grimes This seems similar to my issue, although only my ethernet port #4 is dead at the moment. Did all of your ports die?


  • I just upgraded to 3.4.1 and now Ethernet port #3 is dead for me.


  • @Aaron-Kamp I would suggest as a test to use the Rollback Feature to confirm it was the update, and not just a coincidental failure. Can you please report back to me if rolling back brought LAN #3 back to life for you?


  • @UI-Brett , I performed a rollback to 3.3.0 and Lan #3 is still greyed out in LCD and not operating.


  • @Aaron-Kamp I would suggest submitting an RMA to get the unit replaced under warranty. rma.ui.com


  • @Aaron-Kamp This also occurred for me on upgrade to 3.4.1, loss of LAN#3. Rollback to 3.3.0 brought LAN#3 back.


  • @sp_murphy I should amend that. LAN#3 wasn't completely dead, but it was dead slow. I could get a ssh session back to one of the machines, but bandwidth was so limited screen share was useless. Rollback to 3.3.0 brought the speeds back to normal.


  • @sp_murphy To my knowledge, this is the only reported case of this happening. If you could update to 3.4.1 once again, and if speeds drop, generate support files for us to review and identify what is happening. Thanks!


  • This happened to me...and then I was given a much older firmware but it seems like the damage was already done. They want me to purchase a brand new $400 kit for a firmware mistake on their end. WAN port died.

    Here's the quote from my other threads:
    "I'm experiencing the same issue. Router shows "no internet connected" but as long as device is in ARP tables, it still works....a reboot resolves it but it's happening about every 12-16 hours.

    Wish they made a way for us to unbind the meshpoints from the router so we could purchase ONLY a replacement AFi-R.

    Got this device for Christmas of 2019 from my grandfather. He recently passed and there's NO way to get a receipt.

    Ubiquiti has no exceptions to this process. My serial number is showing out of warranty so now not only am I stuck with two unusable meshpoints, they won't replace the last thing my grandfather gave me."


Log in to reply