Firmware 3.3.1 vs 3.3.0


  • Updating to 3.3.0 on AmplifHD caused the ethernet ports to stop working. I swapped HDs -- the router became an HD mesh and the one of the mesh HDs became the router--same problem, no functioning ethernet ports. Worked with support and rolled back to 3.1.9 -- problem solved and makes it software/firmware vs hardware.

    -- Was this bug fixed in 3.3.1?
    -- If I update to 3.3.1 and experience the same problem, can I rollback to 3.1.9 or am I stuck with 3.3.x?

    I like to keep the network updated, but don't want to break the devices--several--that rely on wired ethernet, including the 2 HDs that operate as mesh points with ethernet backhaul.


  • @Charles-Grimes said in Firmware 3.3.1 vs 3.3.0:

    Was this bug fixed in 3.3.1?

    3.3.1 is a firmware release for the AmpliFi Alien product line, while 3.3.0 is the current public release for the AmpliFi HD product line.

    This issue is the first report of anything like this, could you generate support files from your system with ethernet devices connected, hopefully we can identify what would be causing this.

    You said both HD routers had no functionality in all 4 LAN ports? Were these devices connected directly to the 4 LAN ports or are they connected to switches or plugs?


  • This post is deleted!

  • @UI-Brett

    generate support files from your system with ethernet devices connected, hopefully we can identify what would be causing this.

    Generated and e-mailed to help@amplifi. However the system is on Firmware Version 3.1.9 (vs 3.3.0)

    You said both HD routers had no functionality in all 4 LAN ports? Were these devices connected directly to the 4 LAN ports or are they connected to switches or plugs?

    I’m not sure what difference it makes, because the HD router Ethernet ports are connected directly to the 2 HD Mesh units. The HD Mesh units were unable to connect and showed the “No internet connection” graphic on the LCD.

    1. Tried using the other 2 ports, briefly (a couple of minutes most) appeared to work, then the ports stopped working and “No internet connection” on the LCD

    2. Took and HD Mesh unit, hard reset, and made it the HD Router. Reset rest of network to connect to the new HD Router (old router now an HD Mesh). Worked for maybe 10 minutes tops then stopped—once again the 2 HD Mesh units showed “No internet connection” on the LCD

    After rolling back to 3.1.9, the system is working, although both Ethernet and wifi are slow—Ethernet is maybe 250-350 Mbps while Verizon shows the router is ~950 Mbps. The Cisco switches are gigabit and have allowed 1 Gbps (FAST, Speedtest), the cable is Cat6.


  • I've ended up with the same issue on 3.3.0, all ethernet devices disappeared and none show on the app anymore. 2 of them are airplay devices for audio playback, and no apps (spotify, apple music etc) can see them on the network, and th4e xbox one claims it has no internet any more. all wireless devices show and are functional, but no ethernet connected devices at all. issue has been sporadic. have rebooted external switch and played around with moving from port 1 to 2, to 3 to 4 etc and on occasion have seen them show up again. in fact had about 3 days of no problems but today its back.


  • @Andrew-Turley You have a switch, can you elaborate on your topology for me?

    • Are you using a modem or modem router combo? And if a combo, is it or AmpliFi placed into bridge mode?
    • Are ethernet devices from the switch and AmpliFi not connecting, or are all devices connected to this switch?

    Ethernet loops can bring down the ports, which could be causing all wired devices on the switch to stop working. I might suggest plugging all of your wired devices in one at a time to see if we can identify if a specific devices is causing the drop vs. hardware failure.


  • @UI-Brett Generally ethernet loops are not sporadic, they either exist and cause issues, or not, or at least that's been my experience in roughly three decades of networking. I agree a topology diagram would be a good first step. There are tools for that: https://www.comparitech.com/net-admin/network-topology-and-mapping/


  • @UI-Brett - thanks for the response.

    The issue is new, basically the system has operated flawlessly for over a year, in the configuration it is now in, and then after applying the firmware update, it's broken. no other variables or changes have been introduced. With 3 devices permanently connected via ethernet (1x xbox, 2x airport express), and also my laptop plugged in most days in the office. Now all wireless devices continue to work, and they appear in the app, but zero ethernet devices are functioning.

    The config I have is fibre into the house switchboard, thats connected to the modem (straight thru) to the amplifi HD. The LAN port #1 is connected to a basic switch that has connections to all the wallpoints in the house. Again, I set this up as per all the guides originally, and it worked flawlessly. now the xbox says 'no internet' over ethernet, and the airport express devices are un-reachable. None of it works now. I tried restarting and reconnecting everything in the chain and for a day or two, it came back and worked as normal. but now it's gone again.


  • @UI-Brett - update! I rolled the firmware back to 3.1.2 and factory reset the Amplifi HD. Now everything is working perfectly again. All Ethernet devices visible in app and functioning as before. So no physical changes to anything in the network or changes to any other device or device settings in my home network, which can only indicate that the 3.3.0 firmware update was the culprit. Going to ignore the prompt to update from now on! The new icon selections for devices was a nice touch, but I couldn’t recommend the firmware update to anyone as something’s definitely not right with it.


  • @Andrew-Turley This is strange behavior indeed, were you able to generate support files from your system before the rollback so we can try and identify what exactly was causing this issue?