Problem connecting Billion 8800NL R2 to a Amplifi HD


  • To Start with, I am a thick, so please make your answers in plan language and not Tech speak.

    Using EE broadband.

    I have Billion 8800NL R2 which I would like to set in Bridge Mode and connect it to a Amplifi HD Mesh system

    I can seem to get the Billion 8800NL R2, into bridge mode, but which port should I use.
    Then which port on the Amplifi HD should I use as input from Billion 8800NL R2.

    So, if anyone can help with simple instructions, it would be very much appreciated

    Living in hope, all alone at home.

    Cheers Dave


  • @Minty-Murray have you managed to get your EE's broadband username and password sorted out and ready?


  • Hi Ali

    yes, I have them, The router connects no problem with EE, is the link to Amplifi and its setting that seem to be my problem


  • @Minty-Murray great. Connect one of your LAN ports from the parent router to the WAN port of your AmpliFi. Go to the settings of your AmpliFi and change the internet mode in settings to PPPoE and enter your details and wait for it to restart and it should work.


  • @Minty-Murray also before you do the above make sure you Billion is in modem-only mode.


Log in to reply