Performance Degradation after Firmware 3.3.0. Used to Be a Seamless Network Experience - No more!


  • Ever since the upgrade to 3.3.0, I have noticed that my home network performance is lumpy. I haven't had complaints from the family for months - now, every day someone is telling me they can't connect, or their connection is slow or even patchy.

    Both meshpoints have 5 LEDs lit. Both have worked flawlessly before. I have changed nothing.

    When someone complains, I login to the router and look at the device and where it's connected. Most of the time, it's connected to a meshpoint at the furthest point of the house. Sometimes to the router. It seems that the passing between the router and meshpoints isn't functioning as well as it used to - or the connectivity between the devices (router and meshpoints) is no longer working as it used to.

    I used to get 60Mbps down without fail. Now, there are times when I get no more than 1 or 2 Mbps.

    It seems from other points there are some issues since this update. How can we get this fixed?


  • A bunch of us are experiencing these same issues. Email in a support file from your Amplifi app to them.


  • @Robert-Ames

    Hi Robert,

    I have the same problem. LAN is OK but wifi degrades over time. When it is at worst I have a ping latency of ca: 1000ms.

    After reboot of router and mesh points, I got a latency around 20ms for ping. I need to reboot every 3-4 days.

    Br,

    ///Mike


  • @Mikael-Johansson
    I was told by AmpliFi to to downgrade to the previous release of the firmware. It’s quite easy to do by connecting to your unit over the web. I have had no problems since. They have said it was a buggy firmware release and they are working to rectify it.


  • Just another +1 for issues starting on 3.3.0. Definitely seems to be wireless degredation, possibly related to roaming between base and mesh points. Most of the time reconnecting (turning wi-fi on my phone/laptop) would fix it.

    Regardless, I've downgraded to 3.1.2 via the web interface. Thanks @Robert-Ames .


  • @Robert-Ames

    Tnx for this Robert. I will give it a try.

    Br,

    ///Mike


  • +1. Wifi is currently wayyyyy worse than before I moved to mesh a year and a half ago. Constantly rebooting trying to retain some semblance of what the connectivity used to be. What happened?!


  • I'm on 3.4.1 and my experience is currently quite bad.
    Not only slower speeds, but also I have to quite often restart the whole system after wifi simply stops working – connected by slow or no internet connection.

    Issue is not affecting LAN ports.


  • @Carlos-Vargas Would you be able to generate support files from your system after you experience these issue, but before you restart the network. Then, I would suggest using the rollback feature to see if returning to the last firmware you were on restores performance.


  • @Robert-Ames
    Agreed, but it's worse than that. about 2 weeks ago suddenly terrible wifi. To be specific, terrible mesh performance, and the mesh points are at best 40% of the router, by design as support has assured me. Rolled back to 3.3.0, with no effect. Unable to go back further since selecting 'roll back' only offers an upgrade to the lastest firmware. Really had it with these guys, going to another vendor.


  • Unfortunately I have the same problem, at first I thought the hardware was broken because it had worked flawlessly for years. Luckily I stumbled upon this thread (and a few others).

    My current firmware is 3.3.0, after I rolled back from 3.4.1. I'm experiencing varying speeds when connected to a mesh point, from bad (5mbps) to extremely bad (0.2mbps). I also see a degraded performance when I connect a 2.4ghz-only device to my main router, but it varies.

    There are some comments that say the 3.1.2 version was way more stable, but I can't seem to rollback that far. I'm going to try and go back to 3.1.2 by mailing the support.


  • Unfortunately the 3.1.2 version of the firmware did not resolve my issues. I have tried support what to do next.


  • @arjenlodder Have you done a full factory reset after the downgrade?


  • @arjenlodder Are you seeing this loss of performance from one specific MeshPoint or from both? If it is in one specific location, you could swap MeshPoint locations to rule out or confirm a hardware issue.


  • @Ali-Hadi Yes, I have. However, I did restore the backup I previously made (I have a lot of static addresses and some offline-rules).
    @UI-AmpliFi I have already swapped the Mesh points, unfortunately this doesn't seem to help at all.


  • @arjenlodder Is the performance now poor on all devices or is it limited to a single device? What backhaul is the MeshPoint using?