Teleport Router-to-Router Stability


  • Anyone else recently (17-18 April) experiencing extremely slow Teleport Router-to-Router throughput speeds? I’m in Southeast Asia with my home HD router in the States using Comcast. I’m typically able to teleport with downloads in the 6-8Mbps range, but over the last ~48hrs it has been only .1 - .75 Mbps... absolutely brutal and unusable.

    I noticed at status.ui.com, there has been some mild stability outages listed for the AmpliFi cloud - could this be the culprit? Is there another UBNT status page specifically for the Telrport functionality that I can check?

    I verified speeds at home and at my remote site (without Teleport) and they are fine.

    Thanks in advance!


  • FWIW, I’m still running 3.1.2 on all my devices. I haven’t upgraded to 3.3.0 yet.


  • 0_1587193195626_teleport_blazing_speeds.PNG


  • Hi @Derek-S - Router-to-Router from an iPhone in Asia to Comcast in the States, I just quickly checked Fast.com and Speed.ui.com and don't see any abnormal results ~16Mbps down & up on Fast, 16 down / 12 up from UI

    I haven't noticed any issues streaming over the last couple days either...


  • @Derek-Saville

    Thanks for the warm fuzzy -- so doesn't appear to be an issue with the Amplifi Cloud then. Interesting - not sure what else to debug. I'm still seeing 200 Down and 12 Up in the States (Comcast) and local connection here in Asia is still 100 Down and stable. I've tried rebooting both the HD in the States and the Teleport and Instant here. I guess I could try upgrading to 3.3.0, but I doubt that will fix anything.

    I seem to recall you upgrading to the Aliens on both ends -- could the Aliens be leveraging different cloud infrastructure by chance for the VPN?


  • Hi @Derek-S - yes, I have changed over to Aliens at both ends and this Comcast service has 20 Mbps upload, so the highest Teleport throughput I see is 18 Mbps

    I don’t think the Cloud structure is any different, but I don’t know for sure

    Have you tried the Teleport App for comparison?

    The speed test in the app matches (and probably uses) speed.ui.com and I am seeing the same results as Router-to-Router

    Have you also rebooted the modems at both ends?


  • Hi @Derek-S - is that ping time of 415ms normal for your connection?

    That’s ~4x to 5x of what I typically see and may be indicating a route issue


  • @Derek-Saville

    Thanks for your help! So I gave the teleport App a try and the download is still unusable (see attached screenshot), but the upload seemed to be normal.

    I typically have ~300ms of delay - not good I know, but still usable for streaming here. 400ms is definitely higher than normal. Also, I’ve rebooted the routers on both sides and no improvements.

    I actually just reached out to Comcast just now and asked if they would send a hard reset command to the router (not sure if it does anything more than a power reset). Anyway he wanted to debug first and his first question was whether or not I was trying to access my internet through a VPN. I played dumb and asked what that was and if it was operating in a degraded state and he said yes?! I of course was hesitant to inquire further...

    Could Comcast somehow be detecting VPNs and throttling them on the modem somehow? I really hope not!!! It almost seems like my outbound upload from my home internet in the US is now throttled... going on day 2 of this.

    Anything else you would try/suggest?

    0_1587200804238_BB103CD5-C4A6-4F3F-8F11-73F2C77B69A3.jpeg


  • Hi @Derek-S - for my service I can login to my.xfinity.com and/or login to the gateway over a Teleport connection and reboot it, so no need to contact them
    (could also enable remote access but I choose not to)

    I usually find a reboot clears things up

    Not sure what else to try

    I personally would not recommend a firmware update except as a last resort just in case things go wrong - internet is too important right now

    From a conspiracy perspective I always believed there were times they throttled my SlingBox back in the pre-Teleport days but they insisted that was never the case, and there were times I thought my HW Teleport was being throttled as I couldn’t find anything else wrong, like your situation today

    Eventually it seemed to sort itself out, but over 48 hours seems excessive

    I can’t think of anything else to try other than connecting through the Teleport app from another remote location to see if it’s a problem in the States or your local ISP

    And / or try to connect via the Teleport app to another AmpliFi router for the same reason


  • @Derek-Saville
    Appreciate your feedback today - always good to have a sounding board to make sure I'm not overlooking anything obvious!

    That's not a bad idea trying the Teleport App on a different remote network just as another datapoint. I also sent in support files from both my Router and Teleport in case there's some glaring issue -- bug again, I've been streaming for months with only minor/brief outages or reduced speeds... this is the first time I've had a sustained issue that I haven't been able to work through.

    It's very odd -- hoping I wake up tomorrow and its magically resolved, but I'm not overly confident.

    Thanks again!


Log in to reply