PPPoE configuration missing basic IP options

  • Folks,

    I am running a brand new Amplifi gamers edition router with 2 x MESH points.

    Was shocked to find when I set it up, that the configuration options available for PPPoE is very very limited. I am only given the option for DHCP configuration via our ISP - there are no options for specifying the DNS server address, so I currently cannnot configure OpenDNS.

    Secondly the DHCP server configuration seems broken. It won't let me select a different DHCP range (I usually use 10.x.x.x for local DHCP). There is an option to select the address range, but it is broken and reverts to 192.168.140.x when I try to apply it.

    Finally, nothing in the configuration or monitoring tells me the router's own gateway IP address which I need to know for the couple of computers which are statically configured on my network. Have had to configure them for DHCP to aquire this and then reconfigure with static addresses.

  • I am using PPoE also and you can change your DNS to whatever you want through the app under the Internet settings menu. By default the AmpliFi hands out the routers address as the DNS address to devices. You can override this by selecting Bypass DNS Cache in the advanced settings webpage of AmpliFi by visiting your routers IP address on a web browser.


    You can also change your DHCP IP assignment/range from the app as well under the DHCP menu. I have 10.0 block selected for handing out, then you choose your Subnet number as well, I chose 0. And then your AmpliFi will always have the first allocated address of .1, for example with my above settings my AmpliFi’s router address is


  • @Tony-Penev Was able to update the DNS v4 nameserver IP addresses a few days ago. Previously the DNS server address fields had been greyed out, although I found a 'tip' on the support page which says that they can be edited despited being greyed out, but recently noticed that they were no longer greyed out in the app. Have changed mine to point to OpenDNS filtered v4 nameservers at the same time as updating the LAN DHCP range to the block I wanted to use.

    Using 'Bypass DNS cache' should be used with caution as this forces external nameserver lookups for every single query.

    The PPPoE option seems to be DHCP based - I have a static IP address though and was puzzled to find that there is nowhere to input this. Fortunately the correct WAN ip address resolved from my ISP's DHCP, so was able to get the internet connection up and running. That leaves a nagging doubt though - If the PPPoE configuration is hard coded to be DHCP based, what is the likelihood that the DNS server addresses I have input might be replaced with my ISP DNS servers when my DHCP lease expires?

    Note that PPPoE and PPPoA are the most common ISP connections in the UK. Few people have cable modems or equipment that uses native ethernet.

    Since are no fields to specify IPv6 DNS server addresses and none are listed in the diagnostic info, I'm assuming DNS v6 is either not supported or the router transparently uses ISP nameservers obtained via DHCP. Have manually configured the OpenDNS filtered v6 nameservers on my desktop computer as a workaround, but not able to do this on other devices in the house.

    Apologies for puzzled comments here in the forum. Have been finding numerous things in the support pages which are missing entirely from the device user guide. Having to configure the router via an app really isn't helping thanks to the wierd quirks of the app user interface, some of which are especially confusing for people who are used to configuring networks.

  • @shealey you are correct about using the Bypass DNS cache option but home routers usually only cache your frequently visited websites via your internet traffic patterns. So it does reach out to your ISP’s DNS server to “cache” a new website when visited. Most high speed (1Gig) connections won’t be affected much by bypassing because their latency is very low already.

    Not entirely sure what you mean by your ISP’s DNS addresses expiring when your DHCP lease expires. You mentioned you have a Static IP setup from your ISP. That means your ISP has given you a static block if IP addresses and your ISP’s provided DNS address too. An ISP’s DNS server address changing is HIGHLY unusual and almost never happens unless they are adding more servers to accommodate more customers. So since you are on a static IP setup when your “lease” expires from the ISP it should just renew again with the same IP address over again, hence being “static”. As for your custom DNS address you put into your AmpliFi, that won’t change unless you reset or change the settings again. Whatever you typed into those “greyed” out fields will override the ISP’s provided DNS address.

    And lastly, yes IPv6 configuration is limited on AmpliFi. You have two options, a (6to4)rd style and a (DHCP6) for dual-stack if your ISP is setup to run “true” IPv6. Find out what type your ISP uses for IPv6 connections. If it is dual-stack just set AmpliFi’s IPv6 settings time DHCP6 and let AmpliFi resolve the IP and DNS addresses on its own. In the future AmpliFi might open up IPv6 customization more and let us choose different DNS servers. But as of right now IPv6 still hasn’t caught on and popular enough.

Log in to reply