"Configure Router -> Advanced -> DHCP Server" configuration is broken

  • Sorry just saw this category after posting a comment in the general usage category.

    The Amplifi Gamer Edition router's 3.3.0 firmware has a broken WIFI network DHCP range option.

    Although there are 'start' and 'end' range options and a comment advising that the legal ranges are - in practice the options are ignored and the configuration reverts to usign the 192.168.140.x range. I have tried setting up my own 10.10.x.x range, but have not been successful in applying the settings. There is also nowhere to specify the subnet mask or the router's own gateway address in the new range, so am really not sure how this setup step can possibly work in its current form.

  • @shealey If you are configuring your network using iOS, it is different that Android and the two ways are explained on this Article: DHCP Server.

    The Gateway address should automatically change once you have modified the other settings, since it will be a xxx.xxx.xxx.1 by default. On Android, changing the "Start" field is where you would change your range to a 10.10.x with the 3rd octet being set there as well. In iOS, you would just change the "Subnet" field to be the desired 3rd octet, where the "Range" section above it would be where you change to 10.0 (iOS only has three options compared to Android, they are 10.0.x.x, 172.16.x.x or 192.168.x.x)

    Hope this helps!

  • @UI-Brett I have the Android app, not iOS. I read the notes on DHCP Server before trying to configure it - but as I pointed out, each time I tried to apply a configuration for a range other than the 192.168.140.x factory default, my configuration got thrown away and the router reverted to the factory default.

    The app updated itself just today so I'll try configuring the router again in the next couple of days.

  • @shealey When you make changes to the DHCP server, the check mark in the top right hand corner has to be selected orelse the settings all do revert back to what they were prior. I tested on my network and it saved, but I can try and replicate more on my end to identify the issues. Can you help me replicate with your exact steps?

  • @UI-Brett Yes I understand that I have to 'apply' the settings using the green tick icon. I was trying to explain that having done so, the values I had specified were being thrown away and the config reverting to the factory range.

    I'm happy to report that I have been able to reconfigure the DHCP range to the 10.10.x.x range that I was trying to set up now.

    The only thing that has changed seems to be that both the router and the app have updated themselves since I originally experienced the problem I reported here. Apologies I realise that my original post was misleading - the firmware version I quoted was the current version as at when I posted the comment, not when I was having the issues originally. As per another issue I posted which I'm about to reply to, I suspect that the router shipped with very old firmware, and some of my problems may have been related to that. In the days after I set it up, the router updated itself at least three times after I ran the initial firmware update - must have been really out of date!

    One final thing - as I think I mentioned, the Amplifi UI - unlike any other router I have used - does not give me a field to configure the subnet mask. The private 10.x.x.x range is a class A address block reserved for private networking, which should allow me to configure the last three octets. The Amplifi UI doesn't respect this and only allows me to configure the last octet, forcing it to be a class C IP block. While this is probably sufficient for most "home" use cases, it is still a deviation from networking standards.

Log in to reply