Multiple HD’s not handing devices to the strongest signal


  • I had an HD with 2 mesh points but the wireless mesh points were too slow for all the video streaming for online classes. Now that all the kids are home distant learning, I upgraded the wireless mesh points with 2 HD units as wired back hauls. I am finding that the devices are not being handed off to the strongest signal from one of the backhaul units. I have Router Steering set to off on the main router. The only way to fix a device is to turn off its WiFi and turn it back on so it will find the stronger signal.

    I do not want to set up 3 separate networks. How can I set the units to hand off devices to stronger signals.


  • Hi @Jamie-Loeb - it is the client device that has to decide to give up the weaker signal before it looks for a stronger one to roam to

    The AmpliFi units themselves cannot hand off a client on their own, they can only try to influence the client when it starts to consider roaming

    So it may be the the HD mesh points are too close together without enough signal separation, so the client still thinks the signal from the mesh point it is currently connected to is "good enough" and holds on to it longer than ideal

    This is why turning WiFi off and on again works, because it forces the client to then find the best signal again

    You can consider trying is to temporarily disable the wired Ethernet backhauls and run them as wireless mesh points to check the signal strength back the to main router

    Then move HD's further away from the main router (as much as your Ethernet backhaul and living space allows) and/or rotate them or put them in less ideal positions (i.e. against walls or behind obstructions) to reduce the signal overlap

    Then enable the Ethernet backhaul again and see if roaming improves


  • @Derek-Saville I tried using the HD as wireless meshes. They are getting about 43% signal from the main router in the middle of the house. I can’t move the HD units any farther apart. When I used the wands, I was getting 70% signal on 2.4 and 45% signal on 5.0. Would the HD as wireless mesh work better and faster than the mesh wands? I am worried about not having enough speed for 2 kids doing online learning and someone else using the WiFi at the same time.


  • Hi @Jamie-Loeb - AmpliFi does not use dedicated backhaul radios, so you will want to be using Ethernet backhaul for your bandwidth needs

    There isn't anything AmpliFi can do force a client to disconnect from one mesh point so it finds a stronger signal on another

    The client has to decide when a signal is weak enough to start looking for something stronger, and unfortunately some hold on to weak signals longer than necessary...or the user turns the WiFi off and on again to force a scan

    Are your devices dropping to 2.4 GHz in between connecting at 5 GHz?

    You might consider creating separate 5 GHz Only SSID's on the mesh points, having your client 'forget' the main SSID, and see what the roaming performance is like when only using the 5 GHz band as a test


Log in to reply