LAN port constant connect / disconnect


  • Aplifi HD, been running it for almost 2 years now. 3 mesh points as well. My LAN ports are connected as:

    1. iMac
    2. PC
    3. Xbox
    4. DVR home camera recorder

    Last week my iMac suddenly would start to disconnect, and then reconnect every 45 seconds. (wi-fi on iMac is OF3, I only use wired connection). It would reconnect, assign itself to the same address, and connect for about 45 seconds or so, and then disconnect for about 20 seconds, and reconnect. Never had an issue before, just happened out of nowhere.

    Thinking maybe it's the cable (not sure how they "go bad" but fine, I replace the cable. No improvement. I switch it from port #1 to port #2, and great, all is working fine.

    This morning I turn on the Xbox in port #3. And low and behold it is doing the exact same thing. Worked fine last night. Not today though. Disconnect, connect, disconnect, connect.

    So I switch #3 and #4. Wholla, all is good again.

    What is making these LAN ports suddenly stop working, and yet swapping devices make them work again?


  • @Devan-Kadwish This is strange behavior that I can't explain by just reading your description, but you can generate support files for us to review to try and identify what's exactly happening.


  • @Devan-Kadwish I'm having the same issue when it comes to disconnects and reconnecting on my LAN port.. I'll try swapping ports..

    Also, my wireless is stable there is no disconnects on wireless just LAN


  • I have a similar issue. I also had the intermittent connection/disconnects, but it has progressed to not working at all anymore.

    The last few months my ethernet port #4 has been unstable, and it died this weekend.
    Had my main PC connected there, moved it to port #3, instantly worked.
    Moved my Xbox to port #4 for verification, lost connection. Had to move it to my switch on port #2.
    Port #1 is also working.
    Should I expect the other ports to fail soon as well? Or is this a firmware issue?



  • @Thomas-Aasebø If the port does not work, (sounds like you have verified this by swapping devices) I would suggest submitting a warranty claim for your product.


  • As of today (apx 9 days since swapping) I haven't had any duplicate issues. So Im not able to run the diagnostic test as it's not duplicating the same problem. The port that was originally bad when it had the iMac in it, seems to be fine now that it has a DVR instead. The Xbox which stopped working on port 3 seems to be fine in port 2. Makes no sense.
    If it starts to reproduce itself again, I will keep the source connected and run the diagnostic as described.


  • Well it's back. This morning I sit down at the desk, and ports 2, 3, and 4 are not working. Port 1 is okay.

    Nothing has changed hardware wise since the last problems.

    I rolled back the firmware as previously suggested by users. https://community.amplifi.com/topic/2798/firmware-3-3-0-breaks-ethernet-ports

    I then did a factory reset of the HD.

    Port 1 is good to go. 2, 3, and 4 still no response.

    So I checked 1 device and port at a time. I tried multiple devices into port 1 (iMAC, XBOX, ROUTER and DVR). Each device worked when connected to port #1. However if I plugged any of those devices into 2, 3, or 4, I would get no response.

    So this time I plugged a device (xbox) into port 1. I then assigned it a static IP. (106.2) I then moved it to port 4. AND IT WORKED.

    I then plugged the iMAC into port #1. It worked. I then assigned it a static IP. (106.3) moved it to port 3. AND IT WORKED.

    Plugged DVR into port #1. It worked. I then assigned it a static IP. (106.4) moved it to port 2. IT DID NOT WORK. Moved it back to port #1. Worked again.

    Lastly, plugged router into port #2. *** Port 1 is working. Port 3 is working. Port 4 is no longer working. Port 2 is not working. Removed router from port #2. Port 4 started working again. (This is like playing a puzzle game!) Removed router and Xbox. Plugged router into port #4, the router works! Nothing is in Port 2, so I try the XBox. It does not work, and now kills Port #4.

    So... looks like if anything is in Port #2, it wont work AND it will stop anything in Port #4 from working. Port #2 is definitely DEAD.

    Plugged the router back into Port #4, left #2 empty, and plugged the xbox Into the router itself. Poof, all is working again. Except the fact that I have a dead port.

    Left it at rollbacked firmware. Have not updated it and wont until I see or hear from someone on the Aplifi side advising to do so.


  • @Devan-Kadwish I don't think firmware is related in any way, I think its hardware related from the last time as well. I would still suggest an RMA to replace this unit.


  • @UI-Brett Hey Brett, I have the exact problem, my ports stop working and I reboot, everything boots fine and then 1 hour later everything crashes. I have googled this and I saw somewhere that you said that you had not heard of this issue before. First of all you have and second of all there are a bunch of us experiencing this problem. This is quite an expensive equipment so nobody is going to accept it not being fixed or at least looked at. Give us some answers other than "that's strange" "this is new to me". Either we have broken units or there is a flaw in the firmware updating. My free ISP huawei router is now up and running because I cant run my business on this crap if it's constantly crashing.

    Sorry for the language but something has to be done, people are constantly left empty handed here with a huge problem.


  • Add me to the list. I just sent a request to help@amplifi.com because the ports on my router stopped working today, out of nowhere. It's slowed down the internet in my 3000sq ft house because two of the ports go to 2 other amplifi hd routers that act as mesh points over ethernet backbone. I've had this configuration for several years with no issue until today. Not happy!


  • My problem is the same as the OP.

    You can add me to the list of people with problems on ports 2 and/or 4. Since last year (May 2019), I've had my system, and I didn't have many items plugged into the Ethernet LAN ports on the back of my Amplifi HD until recently. I decided to add in a laptop - wanting to transfer some information. I plugged the cable into Port 4, which didn't work, and nor did Port 2, which had my iMap Pro plugged into it (although it had been fine since purchasing the Amplifi.) I figured it was a cable problem or a hardware problem with the laptop but even tested cables weren't working, and the laptop was connecting fine through wifi. I stopped worrying about it and went on to other things. Now though, I've added in another device, and I can't get the ports to stabilize.

    @UI-Brett - For the close to $600 (CAD) that I paid for this unit, I expected a longer device lifespan and an easier way to get it fixed. How do I go about getting an RMA?


  • I am having the exact same issue. I have replaced the cable and the computer. LAN 4 gave me connect/disconnet for a couple of weeks then died altogether. Unit had been working great for a couple of years. Other ports work fine, for now. Still looking for answers.


Log in to reply