feature request: add IPv6 to preferred DNS resolvers


  • Hello,

    The addition of IPv6 support to v2.2.0 in June was much welcomed.

    One niggle is that Amplifi preferred DNS resolver config. still only permit IPv4 addresses. Could IPv6 preferred DNS resolvers be added to a future release?

    Yogi P on a support chat today suggested this forum to post a feature enhancement. Request was previously noted on the Reddit /Amplifi forum post from June.

    Use case, for me, is substituting OpenDNS resolvers for the ISP's. Attempting to add OpenDNS IPv6 resolver addresses (2620:0:ccc::2, 2620:0:ccd::2), instead of or in addition to their IPv4 addresses returns "Invalid address".
    So my LAN hosts end up with the preferred OpenDNS IPv4 resolvers plus the ISP's IPv6 resolvers, which is suboptimal. My workaround since June has been to configure the Amplifi in bridge mode and use an external router (Mikrotik).

    Thanks!


  • @a-j-klopp IPv4 resolvers should be able to answer IPv6 queries no?


  • Yes, but not the issue.

    Want the Amplifi DNS prefs to allow IPv4 and IPv6 settings, so OpenDNS gets all queries, not just those over IPv4.


  • +1 for separate IPV6 DNS setup option. Just switched to quad9.net and would like to have all my IPV6 DNS traffic covered as well 🙂


  • @german-martinez Is it the case that when IPv6 is enabled, the Amplifi router will use the specified IPv4 DNS servers, and not some assigned from upstream (ISP) DHCP?

    I'm trying to verify that I can use IPv6 and my Pi-hole, even though I cannot set the IPv6 DNS address directly.

    Edit: After testing, it looks like this is the case. I did an nslookup -debug google.com and the AAAA record was returned by 192.168.1.3 (my Pi-hole), and when I looked up a domain my Pi-hole blocks, the returned record was the address of the Pi-hole (that is, it was successfully blocked).

    So I think it's correct to say that the Amplifi simply does not provide a DNSv6 address to its DHCP clients, so the provided DNSv4 address is used even when IPv6 is enabled, and so my Pi-hole works.

    Edit #2: That only seemed to be the case on my Windows 10 machine. Soon as I did dig +trace google.com on my MacBook, the results were being returned from a DNSv6 address owned by Comcast 😞 No IPv6 for I guess.


  • This post is deleted!

  • @andrew-schwartzmeyer We are aware of IPv6 DNS issue. This is a little bit deeper problem than it seems. I hope we will address it in upcoming firmware releases.


  • @dmitrijs-ivanovs Thank you!


Log in to reply
 

Looks like your connection to AmpliFi was lost, please wait while we try to reconnect.