Mesh Stick wont connect


  • Hey Guys,

    I have a brand new Amplify HD - one of the mesh sticks connected out of the box, the second wont connect even after multiple reboots and power cycles.

    Please help

    Keith


  • Hi @Keith-Atkins - just to confirm, you purchased a kit that included an HD cube router and 2 stick MeshPoints in the box correct?

    I would also suggest first reviewing this support article to check a couple of things...

    https://help.amplifi.com/hc/en-us/articles/360026012494-How-to-Verify-if-a-Device-is-Standalone

    First, when you open the AmpliFi app, it shows the two stick MeshPoints, and one is connecting and one is grayed out 'offline'?

    Two, see if the MAC bar code on the MeshPoint that doesn't connect matches the bar code on the HD router and the other MeshPoint that is connecting?

    For the stick MeshPoint that is not connecting, what pattern is the blue LED's blinking in?

    You may need to factory reset all 3 devices to get them to re-sync themselves to each other


  • @Derek-Saville

    Hey Mate,

    The app sure does show me two sticks -
    One online and one offline.

    I tried a factory reset of it all and still no luck, although I only reset the cube by means of via the software not pressing the reset button with a pin?


  • Hi @Keith-Atkins - it is important to check the bar code labels to be sure that they match in case one stick MeshPoint was accidentally wrongly packaged in the kit

    The MeshPoints are hard coded, so if one is wrong, it will never connect, so you might want to confirm that before doing a lot of other trials to get it to work

    For the stick MeshPoint that isn't connecting, are the blue LED's lighting up when it is plugged in?

    Aside from that, you will want to hard reset all 3 devices using the end of a paperclip to push the tiny reset buttons on each of them while they are plugged in and hold it for 10 seconds

    This will cause them to reset their security keys that they exchange in order to start communicating again


Log in to reply