Internet Drop Low Signal-Rollback Helped


  • Just had the instant kit a couple weeks after ditching google WiFi and had couple times internet hiccupped. Tonight it just started flaking and then I unplugged the cat5 cable from the wall (fiber internet so nothing but the fiber equipment outside the house that I can’t get to). I plugged the wan cable to my pc and it was fine. Put the wan cable back to the instant wan port and it started behaving. Not spotty lile before where some sites would work and others not. Saw the forum posts and read 3.3.0 causing issues and I rolled back to 2.9.1 which is what it shipped with. Well I can see my mesh is now good vs average and I get 25 or so more mbps from my mesh point which is what the google. WiFi gave me. I was weirded out why it was slower but thought it was just bad memory, now seems fine. I like this system but I guess I jumped on with a bad firmware is out. I will keep 2.9.1 till I see a new firmware that fixes issues.

    Anybody seen issues like this?


  • @Michael-Melton Same thing happend to me.
    I don't use any mesh points but only the main router.

    Fix this (asap)


  • @Eric35 what firmware you on?



  • @Eric35 open the http://amplifi.lan address in a web browser and log into your WiFi. Then click on support and downgrade. Search 3.3.0 on the forums many are having issues. So far in the last couple days I see no issues and my mesh point had better connection to the router. Wouldn’t hurt to try A downgrade and you can always put 3.3.0 back on.


  • I've been running the 3.4.0rc0 beta firmware for a few days now. It's a massive improvement over the 3.3.0 official release. Speed is really good on all mesh points and transitioning from one mesh point to another is better too


  • @hunterp did you got from 3.3.0 to this? I haven’t jumped to 3.3.0 again but can’t see beta firmware now I guess I need to be latest to see them.


  • @Michael-Melton I was running 3.1.2 when I upgraded to the beta. Have you enabled the beta firmware option the web UI?


  • @hunterp yep but I figure I have to go up to current firmware which is 3.3.0 and I won’t due to stability. I just checked the option isn’t there on 2.9.1. So I have to wait.


Log in to reply