GlobalVPN connection issue with Hardware NAT enabled

  • I have an RCN gigabit connection with AmpliFi HD (firmware 3.3.0) hooked up to the cable modem using MAC bridging, so it's getting it's own public IP - no double NAT here.
    My workplace is using GlobalVPN and whenever Hardware NAT is enabled, my computer can never connect to the work private network properly via ethernet. It'll never get the proper work IP address, seems like it keeps negotiating somehow. I see this on the Windows Network Connections screen, PANGP Virtual Ethernet Adapter used by GlobalVPN gets disconnected and reconnected the whole time.
    It's not an issue with WiFi connection, the same computer is able to connect to GlobalVPN. It's also not an issue when I hook up the ethernet, with the same cable, directly to the cable modem.

    So my workaround right now is to either disabling hardware NAT or using WiFi, both of which aren't preferred since they're not taking full advantage the gig speed, especially since I have other computers hooked up to the ethernet - disabling hardware NAT slows them down.

  • @danijarsa I just ran into this as well. Same scenario, but I have Cox as my ISP. I have to enable hardware NAT to see full speed, but have to turn it off for GPVPN.

Log in to reply