Not getting good speeds on my devices


  • I recently set up AT&T Gigabit/Fiber in my home and purchased an AmpliFi Gamer's Edition.

    If I plug directly into my modem, I get 900+mbps consistently.
    On my wired CAT-6a connection, I'm getting 600 or so.
    On wireless devices I'm getting no more than 300, and even as low as 110-130 on one of my Mac computers. That Mac is sitting in the same room, about 4 feet from one of the access points.

    The speed test in the AmpliFi app on my phone is capping at 160mbps and I'm sitting 5 feet from the main router.

    I have turned on Hardware NAT.

    Please help me troubleshoot what setting I have wrong on here.


  • Hi @bluerman,

    Are you up and running with good speed now or do you still have performance issues?

    Br,

    ///Mike


  • I have an unsatisfactory exchange with Ubiquiti emails support and gave up on getting the results I expected.

    My mesh points seemed to be capped at about 150mbps at the very most, in nearly ideal conditions. I get consistent 800-950 speeds to my router from my ISP. Wired to that router, I get that same speed. Wireless to the router, I get 600 or so, which is good.

    But connected to a mesh point that's one room away from the router, and the PC is sitting 5 feet from the mesh, and I can't get above 150mbps.

    If you have any suggestions, I'd appreciate it.


  • Hi @bluerman,

    I have had the similar issue as you describe. Although I have the Amplifi HD router, but they are almost the same, and from my understanding configuration is the same.

    The information I provide is as is but I hope it will help you forward as it has helped me out. The main SSID is a dual channel SSID that support (or should) seamless movement between 2,4 Ghz and 5 Ghz band.

    Please see a info below from an earlier post I did:

    Please see my steps below that I have got from the amplifi support, big thanks to Pearl B, Myra R and Becky D @amplifi support. You might have done some steps, but I add them if others might need to do the same thing.

    -Steps to follow to troubleshoot Wifi connections:

    https://help.amplifi.com/hc/en-us/articles/360015239594-Troubleshooting-WiFi-Disconnections-and-Stability-Issues

    -I added an extra SSID on 5 Ghz band for those devices that had most problems (performance internet speed issues and latency in ping, up to 3000ms), iPhone 7 Plus, iPad Pro 9,7, Macbook 12 2015, Mac Mini 2014, Lenovo Thinkpad L490 - Windows 10. All devices are updated to latest version of OS and drivers. If you have IoT (or smart home) stuff you can add an extra 2,4 Ghz band for them.

    -I scanned my neighborhood for interference Wifi networks and changed channels for 2,4Ghz (channel 9) and 5Ghz (channel 48). I used the following software to scan for interference Wifi:

    http://www.nirsoft.net/utils/wifi_information_view.html

    -Enabled band steering.

    https://help.amplifi.com/hc/en-us/articles/360018569574-Advanced-Settings-on-the-Web-UI

    Refer to the above article to access the Web UI and make the below changes:

    Uncheck ' Enable Automatic Backbone band switching' (Make sure the mesh points are on 5Ghz.

    Check 802.11r, 802.11k & 802.11v.

    Enable A-MSDU for Wireless backbone

    Save the changes.

    Once the changes are saved, reboot each Mesh devices separately.

    After the above changes the system has been rock solid and I have great performance. I have 250/100 Mbps from my ISP via fibre and when testing, I got around 220-230 Mbps / 80-95 Mbps. I have no switches or modem between Amplifi HD, a direct RJ45 cable from the fibre converter to the router.

    You might want to test new FW as well - but before doing that, I would test the above steps first.

    If any further questions, please let me know.

    Br,

    ////Mike


  • @bluerman I have the same issue, and I just got the Gamer Edition Router 2 days ago, the exact same issue.


  • I have been having nothing but issues and seems as though every issue start with, "send us a support ticket" and ends up being the same answer, but never fixed. I was even told to change my password to a 16+ code...that doesn't solve anything.

    Straight out the box it shouldn't have any issues and now I am afraid that I will bite the bullet and sell my whole system and go to synology again which never gave me connection issues.


  • Exact same issue with my set of routers. The main router is showing max of 200Mbps, I only have 1 Mesh point setup (small apt).

    Devices in the room where the main router is are only getting speeds of 100Mbps and devices in the room with the Mesh are only getting 60 Mbps. Very confused on what is happening.

    I have enabled Band Steering (and not router steering). I also have not enabled the other SSIDs, so it's the dual band SSID, I will at some point try the separate 5G SSID and see if it helps but that defeats the user experience. The AmpliFi dashboard does the devices being connected to the 5G band so that's probably not the issue.


  • @manank Please verify that you are running Throughput mode and not Latency mode. Latency mode will cap your devices at 100 Mbps to prevent data spikes and lag

    This article explains these features on the Gamer's Edition.


  • Thanks for the quick response. Yes, it's on Throughput mode. The Apple TV next to the main router shows 400Mbps when I run Speedtest on it (while the router shows 200Mbps). The Apple TV in the Mesh room shows 50Mbps


  • @manank What speeds are you receiving from your ISP? Our onboard speedtest app can still give some users false results based on bad server selection (or the appropriate server not available at the time). If this Is the case, we ask that you use a 3rd party speed test on a hardwired device to confirm your real speeds. This can also be done with wireless devices, but performing a hardwired test first gives us a confirmation that the speeds provided are being delivered from the modem to AmpliFi.


  • @UI-AmpliFi It's supposed to be 400Mbps. Only 1 device in my apartment (wirelessly connected to the primary router) is getting that speed. The mesh room is getting 1/4th that speed (checked through Speedtest.net), and other devices are only getting 1/2 of the speed (checked on speedtest.net)


  • @manank Do you get 400 Mbps wired to the AmpliFi router? Also the devices seeing slow speeds are they connected to 2.4Ghz or 5Ghz? You may want to open the channel width in the advanced section under wireless.


  • @UI-AmpliFi I get 8-900 when using speedtest.net when wired directly into my modem.
    I get 600-700 wired directly into my new Gamer Edition.
    Wirelessly sitting in the same room as the router, I get 300
    Sitting in the same small room as a mesh point, I only get 80-120 at the very best on a laptop. And like 40-60 on my PS4 and mobile devices.

    I have throughput mode on. They're set to 5.0ghz.


  • @UI-AmpliFi one laptop 60mbps, tried 2 different laptops. Had the Spectrum technician physically come over and check the speeds and they got the expected 350Mbps through the modem. AMilfi Gamers Edition is somehow really throttling the network to a terrible rate.

    All wireless devices are on 5Ghz per the app. I have tried enabling the additional 5G SSID on the mesh device and the speeds are still throttled to 1/4th


Log in to reply