Slowly degrading WiFi performance


  • A few months ago I bought an AmpliFi HD with two extension points and overall I'm very happy with it. I'm having one annoying issue though. Over time the WiFi performance slowly degrades to a point where it is almost unusable (1-2 Mbps). If I restart the router everything is fine again and I get consistent 100 Mbps in the entire house.

    Anyone have any suggestions about what could be wrong? I have tried to debug it but have not been able to find anything. I have tested the performance on the router when I have consistent 100 Mbps to the outside. Also my ethernet connected devices work fine.


  • @Johan-Gidlund hi, what firmware are you running? V3.3.0 seems to have performance issues. You could try rolling back the firmware to v3.1.2 if you’re currently running 3.3.0 or trying the 3.4 beta software. I’m using the beta firmware and my performance is so much better


  • I'm running 3.3.0. How do I install a beta verison?


  • @Johan-Gidlund you need to open up the web UI (http://amplifi.lan), select the router and enter your Router password. You should then see an option to receive beta firmware updates at the bottom of the page. Select it then save the change. In the top right of the page, select Support and then select the Update link in the Current Firmware Version section. It’ll then perform a check for the beta firmware and give you the option to install it. A few minutes later, you’ll be running the beta version


  • Hi all,

    I have the same problem with version 3.30. Wifi degrading over 3-4 days and then I need to reboot router. When Wifi degrading, wired connections works just fine. On Wifi I got timeouts and long ping response, up to 3000ms (normal is around 1-18ms).

    I have downgraded to version 3.12 - no luck.

    I have installed beta version 3.4 - it seems to be a little better, but I still have problem with degrading Wifi. I have followed some steps from support to improve performance:

    -Enable bandsteering
    -Enable a secondary Wifi ssid
    -Changed channels for 2,4 and 5 Ghz network (used this to check current interfering Wifi networks: http://www.nirsoft.net/utils/wifi_information_view.html)

    I hope this can help.

    Br,

    ///Mike


  • @Mikael-Johansson said in Slowly degrading WiFi performance:

    I have installed beta version 3.4 - it seems to be a little better, but I still have problem with degrading Wifi.

    after the next incident of WiFi degrading on 3.4.0, could you generate support files for us to review to see if we could possibly identify what exactly is happening?


  • @UI-Brett

    Hi Brett,

    I have done that and send files to your colleague Pearl.

    Waiting for her response.

    Br

    Mike


  • Hi all,

    A little update from my side.

    If you have this kind of issue, please contact support and work together with them.

    I have upgraded to the latest beta FW 3.4.0rc1 and executed the following steps:

    Once the router is updated,

    • Uncheck ' Enable Automatic Backbone band switching' (Make sure the mesh points are on 5Ghz.

    • Check 802.11r, 802.11k & 802.11v.

    • Enable A-MSDU for Wireless backbone

    • Save the changes.

    Once the changes are saved, reboot each Mesh devices separately and let me know how it goes.

    After the above changes, my feeling is that the system is more stable than before. It has only gone 2,5 days, so we will see further on.

    I will keep you updated.

    Br,

    ///Mike


  • @Mikael-Johansson Thank you for the update, and i'm happy to hear everything is running stable at this point! Please report back if anything changes.


  • @Johan-Gidlund

    Hi Johan,

    Has the problem being solved for you now?

    I have, as mentioned above, tested beta fw and among other things changed my Wifi channel so it was not interfering with other Wifi networks.

    I have now been running this setup for over a week with no problem at all. I have gained much better performance and stability and my family has not complained over the "internet" during this time.

    For me the problem seems to be solved. I am now waiting for the production release.

    Br,

    ///Mike


Log in to reply