Alien Mesh Point Sold Separately?


  • @Damir-Alonso Open the amplify mobile app, under system select the mesh point you wish to change. Under meshpoint back bone band select either, 5Ghz or 2.4Ghz.


  • @UI-JT both are wifi 6 yet shows on the topology just 5GHz non-AX, I already toggled this with an agent, so far they're reviewing the .tar for both the mesh point and the router. Waiting on them Testing every band on both devices...


  • @Damir-Alonso Sorry i miss read that. The alien only backhauls over 802.11AX. And it can be either 5Ghz or 2.4Ghz.


  • @UI-JT Well, hopefully, it's just something the developers of the WebUI overlooked and it's actually connected via Wifi 6 @ 5GHz. Regardless, there is some sort of bottleneck and it's most likely the overloading of bandwidth having 13+ devices connected + the mesh wireless without having an ethernet backbone. As of right now, the agent that I spoke with informed me that they're looking into the .tar files so, it's the waiting game.


  • Hey Guys, I think am in the same Shoes as Damir Here.

    I just bought an Alien Amplifi standalone as the combo doesn't appear to be available in Canada. I assumed the HD would be compatible, doesn't look like it is? I am having a few dead spot issues.

    What are my options outside of buying a second Amplifi Alien?


  • @icehack you can use the standalone Mesh points from the HD as repeaters within your network. The main difference is you won't be able to utilize the Wifi 6 radios in the areas with poor connectiin but in the upside you will be able to use Wifi 4/5 @ 2.4GHz/5GHz.

    My situation is entirely different. Seems that both Alien devices are either have a tug if war affect or the 2nd unit is utilizing too much wireless bandwidth which is choking the networks throughout over wifi 6 and does not affect the lower band. Which might be the reason why the Alien devices are not wifi 6 certified and are still working out the kinks with software updates. I was informed after the dev team reviewed my .tar files from both devices that there is an ongoing (current) issue with this happening and hopefully in the future it will be patched in a firmware update... To me, that's unacceptable and will be returning the device for a full refund... I will be keeping one of the devices... So food for though for those purchasing multiple Alien devices... An Ethernet backbone is MANDATORY and should not consider any wirelessless backbone bands because they just can't handle it currently. Either get one Alien device or HD with additional mesh points.


  • @Damir-Alonso I feel as though this is wrong, I can get the backhaul on mine up to 1.1Gbps using IPERF3 test. The equipment works well, depending on your environment and particular setup. The HD products are not compatible using them as third party extenders is possible but I would not recommend it, BSS will not work very well.


  • @UI-JT i would agree but this is affecting both of my devices once connected via 5GHz Wifi 6 backhaul. Once connected via ethernet everything was fine. Yet, the justification by the live support agent pretty much put the nail on the coffin...

    0_1593653006314_nqJvtCX.jpg


  • No worries, I sent the 2nd unit back. I'm not going to be able to wait for the next round of firmware updates to see "if" that issue is fixed. Hey, I kept one, right? 🙂 More than enough for a 1500sq ft townhouse. (I was being greedy, I suppose.)


  • Would the second router run without needing connection to ethernet if the initial one is connected to modem?


  • Would the second router run without needing connection to ethernet if the initial one is connected to modem?

    Hi @service-chicago - yes, a second standalone Alien can be installed as a wireless mesh point and does not require an Ethernet connection back to the main router


Log in to reply