Slow Wi-Fi Speeds on new router - hardwired speeds are fine


  • I have AT&T Gig Fiber and got my AmpliFi HD Router device in the mail today. Before setting anything up I tested my Wi-Fi speeds on the AT&T router (BGW210). On both my iPhone and iPad I was averaging around 400-450 Mbps speeds.

    I unpacked the new router and got it all set up. Followed quite a few posts on how to do IP forwarding on the AT&T router and got that all working. Disabled the Wi-Fi on the AT&T router as well. My house is hardwired and I’m getting 900+ Mbps on all my hardwired connections so I’m happy about that.

    But my iPhone and iPad are now averaging around 40-50 Mbps everywhere throughout the house. I tested the speed standing right next to the router and while standing 900 feet away upstairs. Results are always 40-50 Mbps. The ping is the same as it was on the AT&T router - usually 2-3ms. I’m using Speedtest.net because I’ve read that the built-in speed test is not reliable.

    What settings or logs can I provide to help me figure out where the problem is?

    I have restarted the router multiple times and I’ve restarted my iPhone and iPad multiple times. They are the latest gen devices so I know they are capable of fast speeds (and I was getting the high speeds from my AT&T router.)

    I (accidentally) bought 2 of the AmpliFi HD routers but the second one is still unopened in the box. I will hook it up as an ethernet backhauled mesh point if I have signal problems. At this time there are no other routers or access points on my network.

    Thanks for any help you can provide.


  • Hi @matthewjj,

    As I understand you only have the router and no mesh points? I assume that's the configuration.

    Unfortunately I do not have the same setup, I have the router and two mesh points installed.

    To compare to your setup, I have 250/100 Mbps from my ISP and I have one iPhone 7 Plus and one iPad Pro 9,7".

    And I am able to max out the speed of my internet connection on both my iPhone and iPad. I got around 220 Mbps when I test with Speedtest. This is on 5Ghz dedicate network, a separated SSID from the main SSID.

    From the numbers you have mentioned, from what I can figure out, it seems that you are connected to the 2,4 Ghz band. Can you confirm that in the Amplifi App, by clicking on devices and see what speed your iPhone operate at?

    Below I will share my info and setup, and this information is as is, information is from an earlier post.

    My router is connected directly to the fibre converter from my ISP and I have no switches etc. Two mesh points are connected to the router.

    -Steps to follow to troubleshoot Wifi connections:

    https://help.amplifi.com/hc/en-us/articles/360015239594-Troubleshooting-WiFi-Disconnections-and-Stability-Issues

    -I added an extra SSID on 5 Ghz band for those devices that had most problems (performance internet speed issues and latency in ping, up to 3000ms), iPhone 7 Plus, iPad Pro 9,7, Macbook 12 2015, Mac Mini 2014, Lenovo Thinkpad L490 - Windows 10. All devices are updated to latest version of OS and drivers. I have not added an extra SSID for 2,4GHz band.

    -I scanned my neighborhood for interference Wifi networks and changed channels for 2,4Ghz (channel 9) and 5Ghz (channel 48). I used the following software to scan for interference Wifi:

    http://www.nirsoft.net/utils/wifi_information_view.html

    -Enabled band steering.

    https://help.amplifi.com/hc/en-us/articles/360018569574-Advanced-Settings-on-the-Web-UI

    Refer to the above article to access the Web UI and make the below changes:

    Uncheck ' Enable Automatic Backbone band switching' (Make sure the mesh points are on 5Ghz.

    Check 802.11r, 802.11k & 802.11v.

    Enable A-MSDU for Wireless backbone

    Save the changes.

    Once the changes are saved, reboot each Mesh devices separately

    After the above changes the system has been rock solid and I have great performance. I have 250/100 Mbps from my ISP via fibre and when testing, I got around 220-230 Mbps / 80-95 Mbps. I have no switches or modem between Amplifi HD, a direct RJ45 cable from the fibre converter to the router.

    If any further questions, please let me know.

    Br,

    ////Mike


  • @Mikael-Johansson

    Thank you for the response Mike. You are correct that I do not have any mesh points configured at this time. I was hoping to get the issue resolved with this single router first and then add on an additional mesh point after that. I have tried updating the configuration to the things that you mentioned in your post and I’m still receiving the same speeds.

    EDIT: So I somehow missed your point about setting up a separate 5g band. I set up a differently named 5g band on my router and also installed an ethernet-backboned mesh point (another AmpliFi HD router). On the mesh point I also set up a differently named 5g band (same name as the router). Then I forced my iPad and iPhone to connect to the 5g network. Now I am getting my original 400/400+ speeds!

    Thank you Mike for the suggestions!


  • Hi @matthewjj,

    Glad it worked out for you! Have fun with your new Amplifi.

    Br,

    ///Mike


  • @matthewjj I had anticipated an issue with my new Alien router and its use of a Common named network which could result in a device connecting to either the 2.4 band or the 5GHz band with no way for you to know. I’m in a condo apartment community and using the 2.4 band has always resulted in dramatically lower speeds with my previous router so I had created separate names for the two bands and forced my devices to forget the 2.4 network and only connect to the 5. In my apartment the 5 band reaches pretty much every area.

    So with the Alien I did the same thing, disabled the Common network, and created separately named 2.4 and 5, I did not mess with any of the additional networks. I did run one test on the 2.4 and right next to the router the download speed was quite good, so for a second I considered enabling the common network. But as soon as I moved a distance away speeds on that network dropped dramatically as they always had. So I’m using the 5 band for all my devices that can use it and a printer and Apple Watch, which can only use 2.4, connect to the 2.4. Currently Verizon Fios is supplying gig speed to all customers through the end of June and my wifi speeds on the Alien on the 5 band are in the 500+ range which just seems to be a limitation that is common to all routers and devices as that’s what I got with my previous Apple router on my devices.


Log in to reply