AmpliFi HD Firmware v3.4.0

  • AmpliFi firmware v3.4.0 for AmpliFi HD, Instant and HW Teleport has been released.

    • Security updates (CVE-2020-11752, CVE-2020-11750)
    • Enhanced device recognition
    • Teleport VPN connection improvement
    • Web portal enhancement
    • Other minor improvements and fixes

    We use a gradual rollout for the update. It may take up to a week for your device to receive this update.

  • @UI-Karlis thank you 🙂

  • Even with new firmware 3.4.0 the Wifi 2.4Ghz is slow, AFTER a reebot of the router the Wifi speed is good at max and then same problem again and again.

    So no improvements since 3.3.0.
    What is going on?

  • Update remotely from rc2. All looks good so far.

  • @UI-Karlis said in AmpliFi HD Firmware v3.4.0:

    Security updates (CVE-2020-11752, CVE-2020-11750)

    These appear to be LAN security issues as far as I can tell, and not exploitable from the WAN interface. Can you confirm?

    CVE-2020-11750 - Multicast DNS issue
    CVE-2020-11752 - relayd is a transparent routing / relay daemon and requires a crafted DHCP packet

  • Hi @Eric35,

    What speed do you get on 2,4 Ghz before reboot and after reboot?



  • Absolutly not stable. Every two hours the wifi Connection on all Devices is lost.

  • What is the process that people are using to update? Does it include a complete power off of the AmpliFi gear and bringing it all back up? Does it include a "factory reset" once the new version has loaded, with a complete power off? Does it include a save/reload of the configuration after a "factory reset"? Maybe these variables contribute to some of the "it works" vs. "it's bad"? 😕

  • @Thomas-Frensch
    5 minuters for me is the uptime before WiFi goes

  • @mambro
    Not done full restore from scratch but rest I’ve tried.
    Nothing helps. Had to revert to RC2 to be able to work from home.

  • @Mikael-Johansson Before reebot about 40 and after reebot about 90.

  • Hi @Eric35,

    Curious to know. As I had the same problem on and off for some devices. Will test and see how it works out.



  • Hi @UI-Karlis,

    I can agree to the below problems described by other users. I have been running on the new fw for around 12 hours now.

    I have been having the below problems:

    -iOS devices loses connection and asked for password for Wifi. Not my Android devices, Macbook or Windows PC.
    -On my iOS devices I can no longer access the Amplifi router via app - says Unable to locate device, although I'm connected to Wifi. (I had a short glimpse (before it stop working) of the system in the Amplifi app and then I could just see that the router was upp and running - both mesh points where offline.
    -When I try to access the web gui for the Amplifi router the screen is "blank" = I have no device to select - It just says welcome to Amplifi.

    It almost feel that the system is overloaded - CPU:s running 100% or something.

    I will try to let be to see if it come back to normal status and see if I'm able to get some log files. After that I will do as other users and rollback to rc2.



  • So RC3 was worse than RC2 but gets released? iOS devices lose connection and if you try to reconnect it states the password is incorrect even if another iOS device that is connected shares. Mesh Points are searching even though other devices such as MacBooks and Window laptops are connected and in the AmpliFi app the router shows as offline even though other devices are connected. Unable to connect to the web based portal. Looks like you need another RC to fix these issues and I’m hoping I can roll back after pulling power and plugging back in to clear whatever issue is coming up. I’d provide logs but app shows offline.

  • @Chris-Neblett Hi Chris, have you tried a "factory reset" on all the pieces of the AmpliFi after they have all been updated? I'm really curious if that would normalize things. 😕

  • @mambro finally able to access the device through the app and went ahead to the public release. If the issue comes up I’ll try to pull logs and roll back. My other AmpliFi system I can tell is up because I can access IoT devices but it too shows offline in the app. It appears after a few hours or so the base unit becomes available. I’ll wait to see if I can access it again at some point.

  • Folks,

    I think 3.4.0 is one of those AmpliFi releases to avoid like the plague. RC 4 was so terrible, I nearly cried. iOS devices, Macs, you name it couldn't connect. The UI was dead. I feel like I escaped a burning house when a reboot and rollback got me back to 3.3.0.

    Kudos to ubnt for continuing to update this system. But in all this time, they never seem to have cracked the nut on delivering consistently stable releases. There are plenty of posts here about previous releases giving the same warning I am making about this release.

    Caveat emptor applies to this update.

  • @UI-Karlis worse than rc3. Lost track of how few hours it’s been going, but just now all mesh points disconnected and the router was not reachable. Reboot. This is getting worse with every release.

  • I am seeing issues since RC4 and 3.4.0 were released. My system is comprised of 4 Mesh routers connected via ethernet backhaul, servicing ~25 hosts. After several hours, the 3 RAMPs display "connecting", but the main router display is normal. The AmpliFi App cannot connect to the main router as well. Connectivity for hosts is sporadic until a reboot of the main router is performed. I hope this issue can be resolved soon as my wife and I are WFH these days and network stability is paramount. I will continue to monitor my system over the weekend...

  • Hi @UI-Karlis,

    A little update. After I lost contact through the Amplifi app yesterday, I had wifi for around 2-3 hours.

    After that we lost the wifi connection on all devices, no SSIDs was broadcasted, neither main or others that I had created.

    As this was during the night here in Europe, I left the system alone and hoping that it might recover.

    Unfortunately this morning the situation was the same, I was not able to get any logs before I did a power recycle.

    I have now roll backed to rc2, as from my opinion has been the stable one. I have collected logs (before rollback) and sent them to your colleague Becky R.

    Kind regards,


Log in to reply