Amplifi HD - Draytek Vigor 2860n to Amplifi HD on BT - No IP address


  • Hello all,

    TLDR: Amplify HD always says "no ip address" no matter what I seem to do when setup behind the Draytek Vigor 2860.

    I've just purchased an Amplifi HD and some Mesh Points to upgrade my apartment wifi from a piece of trash that is the BT Homehub 6.

    I've got an old Draytek Vigor 2860n (I'm fully aware this is overkill, but I had it already) I'm not using so I figured I'd use it as the modem.

    Draytek Vigor 2860 -> Amplifi HD

    If I use JUST the Draytek 2860n the connection works fine by just setting the VLAN to 101 and the PPPOE login to homehub@btbroadband.com and the password to BT.

    I then plug in my AmplifiHD to LAN 1 and switch the Vigor to bridge mode, put the PPPOE details in Amplify and just get "No IP address". As far as I can tell this should just work.

    I've tried:

    • resetting both
    • tried with and without the VLAN setting in Amplifi or either
    • the Draytek just with factory defaults
    • the Draytek in both Bridge and not Bridge
    • DHCP on or off.

    I'm just banging my head against the wall here. No matter what I do, I just get "No IP Address" on my AmplifyHD. Can anyone provide details on what exactly the settings on the Draytek and Amplifi should be? I must be missing some setting here or making some rookie mistake.

    Happy to provide any other details. I really have no clue what I'm doing wrong here.

    Please save me.

    Thanks!


  • Did you do:

    WAN >> Internet Access : PPPoE Pass-through -> And TICKED the box "For Wired LAN" on your Vigor?

    Also if you connect your PC directly to your Vigor in Modem/Router mode, can you get an IP address and connect to the net?



  • @Ali-Hadi

    Yes I could connect directly through the Vigor.

    That box did the trick. Thank you so much! Don't know how I missed it.


  • @hphsts Glad it has worked for you but I would still prefer to use my Vigor as the main router and put the AmpliFi in Bidge mode. This is purely so that I don't lose out on any of the amazing features the 2860 router has to offer.


Log in to reply