AmpliFi HD Firmware v3.4.1

  • @estesbubba
    My topology is very basic with just one AmpliFi HD kit with two mesh points. Internet is 86/40 (vdsl2 on FTTC NBN in Australia)

    I have absolutely no difference in wi-fi speeds on my iPhone XS on 3.30 and 3.4.1 - when connected to the router at 866 mbit the phone fully saturates the internet connection with Speedtest. Using iPerf3 test to a wired server I am getting average 520mbit (up to 550mbit) throughput

    I saw significant drop in speeds when applied 3.30 initially (compared to 3.1.2) but then I noticed it always prefers 5GHz channel 36 that is not good for my environment. Once I manually forced the channel 157 for 5GHz band everything was fast and stable again

    I recommend you to choose channels manually in the app. Looks like the logic of automatic channel selection has changed since 3.30 and it's not choosing channels with maximum allowed power. You might need check what channels are crowded in your environment either using NetSpot app on Mac or Apple's AirPort Utility app on iOS - both can scan wi-fi and show what channels are used

    P.S. all 802.11 and A-MSDU options are enabled

  • @Timofey-K said in AmpliFi HD Firmware v3.4.1:

    I saw significant drop in speeds when applied 3.30 initially (compared to 3.1.2) but then I noticed it always prefers 5GHz channel 36 that is not good for my environment. Once I manually forced the channel 157 for 5GHz band everything was fast and stable again

    Mine also went from auto channel 149 to channel 36 when I installed 3.3.0 so I immediately changed it to manual channel 149. We live on an acreage and I've also used Airport on iOS and nothing else is on channel 149.

  • New measurements revealed fine wifi speeds for my Apple devices again, see addendum in my earlier post. I do not understand such substantially varying performance of the HD mesh system.

  • It appears that the addendum is not shown in my earlier post. Here is what I have to add:

    Addendum of June 25:

    The download and upload rates for my Apple devices at my secondary HD in the living room surprisingly turned out to be fine again in new measurements just having been performed in the same manner.
    I measured with the IPhone 407 Mbps down and 50.4 Mbps up and with the MacBook Pro 402 Mbps down and 50.5 Mbps up.

    I have no explanations for this complete different behaviour. I didn´t change anything since my earlier measurements giving the very poor rates for the Apple devices. The only think what happend which I am aware of is the downloading of a support file from the primary HD which I sent to the support. I didn´t touch anything in my network infrastructure.

    There appears to be a kind of randomness in the behaviour of the HD system which I cannot understand.

  • @Otto-Wilhelm
    It appears that you tested using Speedtest and this is highly dependent on the actual state of your internet connection and the server that was selected for the test. Could it be that you tested during peak time or Speedtest picked a different server?

    I always measure throughput to a wired client to eliminate other factors

  • @Timofey-K
    I took care that I used for my earlier measurements the same server of Speedtest, and the poor speed for Apple devices for Apple devices resulted but no for a Fire HD10 tablet. That I did these tests at all was caused by the discussions in this forum and that I had got the impression by earlier tests that there could be similar problems in my HD wifi mesh system as well. That these problems for Apple devices appear to have vanished is a big surprise. But I don't dare to touch the HD wifi mesh system, e.g. to trigger a reboot, because I am afraid that the problems could start again.

    How do you measure such speeds? Could you recommend a kind of local server software with clients for various devices which can be use as conveniently as Speedtest?

  • @Otto-Wilhelm
    I always measure wi-fi performance locally inside my network from a wireless device to an Ethernet wired machine. I have both Linux and macOS desktops connected via Ethernet so use free opensource common line tool iPerf3

    The easiest way to install on Mac is by using Homebrew package manager
    Install Brew first by running a command in Terminal
    Then install iPerf3 by running in Terminal: brew install iperf3
    Start on server using command: iperf3 -s

    On iOS I use a free app "iPerf 3 Wifi Speed Test" which is based on the same code
    Specify your server address, select direction and run test. The tool has a pretty good help that actually covers all steps I described above. Recommend to read it first

  • Hello, friends.

    I am having a constant devices disconnections since the FW 3.3 over the day. The most suffering devices from it is the Xiaomi MiPad, which lives at the kitchen all the time in 5 meteres from the router. Huawei P20 Pro also disconnects sometimes. By the way, I don't have any Apple devices in use, so, I can't agree that the problem is only at apple's.
    Today, the 3.4.1 has arrived, but I am a bit afraid to update according to yours posts.
    When I bought it, it was at early frimware 2.x or 3.1.2, I don't remember, it was brilliant.
    Will 3.4.1 resolve the connectivity drop issues? Or it adds even more issues?

    Also, after the complete Mikrotik ecosystem at my apartments, I bought the Ampllifi just because it's beautiful and it looks cool at the furniture. I am really confused that I am not able to rollback the frimware, even Apple's (!) airport allowed to do this. And I don't mention the lack of lot's of useful features. Well, if you are not able to make a stable update - then fire your outsource.

    At iperf I don't get the speeds more than 200 megabits. Average is 100-150. I haven't done the measurement when I bought it, but I was expecting a solid 800-900 over wifi by a such expensive device.

  • @Timofey-K I'm using pretty much using the same setup. I have iPerf installed on my Synology in server mode via Docker and use WifiPerf on the Mac and iPerf on the iPhone to query throughput and it works very well. Getting 934 Mbps wired and 445 Mbps Wireless. I do have a Gigabit wired network and that's with Amplifi HD on 3.3.0 and in Bridge mode.

  • @Dmitriy-Hlotenko
    It’s physically impossible to get 800-900 mbit throughput over WiFi 5 (802.11ac) Wifi protocol has big overhead so at 866 mbit wifi connection with perfect signal sitting next to your router you getting up to 550 mbit per second actual throughput. If you’re connected to a mesh point this will be less because your data is transferred in multiple hops

    900 mbit in iperf is close to gigabit Ethernet speed

  • @Timofey-K I'll take my 445 Mbps wifi speeds as good then 🙂

  • I updated mine yesterday when I saw the prompt on the router. I only have my router about 2 weeks now. Prior to the update the mesh I had furthest away from the router would connect to the mesh unit closest to the router and this is what I want. Since updating it just won't connect this way and I am constantly getting a message that the other mesh point is too far. This is extremely frustrating. Please can you prioritize being able to force mesh points to connect to other mesh points manually. I guess it will be called "Mesh Steering"

  • @UI-Karlis Well, it is back to the old story of daily issues with 3.1.2, too.
    I just filed a detailed bug report with support, who are escalating it to Tier 2. I also filed in the Bug Report Forum on this site.

    For two years this used to be a set and forget system. Now it is an ongoing issue.
    Does not seem to be hardware:

    • HD router connected devices are fine
    • It happens on all MeshPoints
    • Factory reset does not prevent the issue

    I hope we can get this resolved.

  • I updated yesterday to 3.4.1. I have had to reboot my appleTV1 this morning. My ethernet wired appleTV2 has been fine. My Macbook and iphone need to regularly have the wifi turned off and back on so that they reconnect. The Macbook and iphone show as connected but data transmission stops and web pages won't open, email won't send. Same sh^t as 3.30 if you ask me. I'm getting tired of this scene. In fact while writing this I lost data transmisison and had to turn my wifi on and off from my Macbook. I just did it 10 minutes prior. Now it just happened again within a minute me last doing it. It's like it gets worse the longer the router goes without a reboot. Now in the last minute it reconnected. This stinks.

  • @jomobco I'm on the fence of updating. I had weirdness with 3.3.0 that only got "fixed" by doing a factory reset and entering my settings back manually (I didn't have them downloaded anyways). I'm wondering if that will be the same thing for me to do with 3.4.1... so I'll ask... did you do a factory reset and start from scratch or just a rolling upgrade and rebooting?

  • @jomobco I've tried it all including factory reset. If your current config is working, I would hold off on updates for now. A lot of people are having issues.
    I have been using this system since it first came out (Dec 2017) and really liked it. It worked just like Ubiquiti gear and the Apple Airport stuff it replaced. This year has been a nightmare.

  • I'm still on 3.1.2, besides ocasional (once in couple months) mesh points restarts to fix the backbone speed degradation, the wifi is solid. It's is nothing in comparison to what folks experience with the 3.4.1 update. I guess I'll stick with existing firmware I have at least until the next update.

  • @Harald-Striepe Just got through texting tech support. They want me to enable a 5ghz additional network and connect to that and send log files when it happens again, yada yada yada. I told them I did that for 3.30 and then they told me to downgrade and that was that. I think if they don't fix this I go to EERO. I don't have time/energy to deal with this.

  • @mambro I rolled up from 3.12 to 3.30 about 2 months ago maybe. Then downgraded back to 3.12 after issues with 3.30. No reset done. Yesterday I went from 3.12 to 3.41. Now I might go to Best Buy 🙂

  • @jomobco I have sent many log files and never heard back.
    Early in my use 2 years ago I had a problem caused by a noise source (Robo vac power supply) close to a MeshPoint. Engineering identified there was noise and got back to me allowing me to isolate the issue.
    I have no communications of what seems to be the underlying issue here for too many users.

Log in to reply